amavisd-new

Issues related to applications and software problems
Post Reply
Ataru
Posts: 4
Joined: 2014/07/11 15:20:29

amavisd-new

Post by Ataru » 2014/07/11 15:52:14

Hello, I am trying to set up a new mail server using postfix and would like to filter the mail using amavisd-new.
So I'm installing the amavisd-new package from the epel repo, but I appear to be missing dependencies:

Code: Select all

sudo yum install amavisd-new

Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: altermime
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: unzoo
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: clamav-server
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: perl(Unix::Syslog)
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: clamav-server-systemd
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: cabextract
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: perl(Convert::TNEF)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Can anyone recommend the best way to get the remaining packages, or is there something else I should be using?

Thanks

User avatar
TrevorH
Forum Moderator
Posts: 29117
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: amavisd-new

Post by TrevorH » 2014/07/11 18:05:19

Since EPEL is still in beta, I think what you most need for the moment is yum install patience then sit back and wait until the EPEL GA and hope more packages arrive.

A lot of EPEL packagers don't have RHEL licenses to test their packages on so they need to wait for CentOS to be released so expecting a full EPEL before CentOS has even been out for a week is a bit hopeful!
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Ataru
Posts: 4
Joined: 2014/07/11 15:20:29

Re: amavisd-new

Post by Ataru » 2014/07/12 12:04:06

Ah thanks Trevor, thought that might have been the case.

Will try to be a little more patient. :)

Post Reply

Return to “CentOS 7 - Software Support”