Page 1 of 1

Trouble Installing Package: dkms-2.1.1.2-1.el6.rf.noarch

Posted: 2014/07/10 20:43:59
by man_at_work
I am struggling with trying to get a certain package installed. I've used the command: yum install -y dkms-2.1.1.2 and there is a dependancy called "modutils" that will not allow the install to happen. I've checked to see if there was a modutils or similar package installed and there is. It is "kmod-14-9.el7.x86_64". However, yum does not recognize this package as an upgraded version of modutils. Is there anyway to fix this? Below are my command line outputs.


[root@blahblahblah ~]# yum install -y dkms-2.1.1.2
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: mirror.hmc.edu
* extras: mirrors.adams.net
* rpmforge: mirror.hmc.edu
* updates: mirror.anl.gov
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them. If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help).
--> Running transaction check
---> Package dkms.noarch 0:2.1.1.2-1.el6.rf will be installed
--> Processing Dependency: modutils for package: dkms-2.1.1.2-1.el6.rf.noarch
--> Finished Dependency Resolution
Error: Package: dkms-2.1.1.2-1.el6.rf.noarch (rpmforge)
Requires: modutils
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


[root@blahblahblah ~]# yum install -y module-init-tools
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: mirror.hmc.edu
* extras: mirrors.adams.net
* rpmforge: repoforge.eecs.wsu.edu
* updates: mirror.anl.gov
Package kmod-14-9.el7.x86_64 already installed and latest version
Nothing to do

Re: Trouble Installing Package: dkms-2.1.1.2-1.el6.rf.noarch

Posted: 2014/07/10 20:49:45
by TrevorH
The "el6" in that package name shows it's intended for CentOS 6 not 7. There is no rpmforge for el7 and since there've been almost no updates for rpmforge for el5 and el6 for nearly two years, I'd doubt if there ever will be.

You have the wrong repo installed, uninstall it and any packages that you've installed from it.

Install the EPEL7 (currently beta) repository and that contains dkms. That is supported and does produce security updates for the packages in it.

Re: Trouble Installing Package: dkms-2.1.1.2-1.el6.rf.noarch

Posted: 2014/07/10 22:56:07
by nbritton
You have to use the el7 package, provided by epel, like Trevor said. Run these commands as root:

Code: Select all

rpm -Uvh http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/epel-release-7-0.2.noarch.rpm;
yum install dkms kernel-devel-$(uname -r) kernel-headers-$(uname -r);