Installing PHP 7.1 packages on CentOS 7.9 (2009)

Issues related to applications and software problems
Post Reply
argo0627
Posts: 2
Joined: 2021/06/20 11:47:09

Installing PHP 7.1 packages on CentOS 7.9 (2009)

Post by argo0627 » 2021/06/20 13:11:51

Installing PHP 7.1 packages on CentOS 7.9 (2009).

I'm installing below packages and getting the dependencies conflicts with php-common 7.2.

failed: [jobfeeder.testing.build.gulftalent.com] (item=[u'centos-release-scl', u'httpd24u', u'httpd24u-devel', u'httpd24u-tools', u'httpd24u-mod_ldap', u'pcre-devel', u'gcc', u'make', u'php-pecl-apc', u'php-pecl-apcu', u'php-opcache', u'php-fpm', u'links', u'libXext', u'python-devel', u'numpy', u'scipy', u'python-matplotlib', u'sympy', u'python-nose', u'libpng-devel', u'php-pecl-zip']) => {"changed": false, "item": ["centos-release-scl", "httpd24u", "httpd24u-devel", "httpd24u-tools", "httpd24u-mod_ldap", "pcre-devel", "gcc", "make", "php-pecl-apc", "php-pecl-apcu", "php-opcache", "php-fpm", "links", "libXext", "python-devel", "numpy", "scipy", "python-matplotlib", "sympy", "python-nose", "libpng-devel", "php-pecl-zip"], "msg": "Error: php72u-common conflicts with php-common-7.1.33-13.el7.remi.x86_64
", "rc": 1, "results": ["pcre-devel-8.32-17.el7.x86_64 providing pcre-devel is already installed", "gcc-4.8.5-44.el7.x86_64 providing gcc is already installed", "1:make-3.82-24.el7.x86_64 providing make is already installed", "libXext-1.3.3-3.el7.x86_64 providing libXext is already installed", "Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* epel: mirrors.coreix.net
* remi-php71: mirror.netweaver.uk
* remi-safe: mirror.netweaver.uk
Resolving Dependencies
--> Running transaction check
---> Package centos-release-scl.noarch 0:2-3.el7.centos will be installed
--> Processing Dependency: centos-release-scl-rh for package: centos-release-scl-2-3.el7.centos.noarch
---> Package httpd24u.x86_64 0:2.4.46-1.el7.ius will be installed
--> Processing Dependency: httpd24u-filesystem = 2.4.46-1.el7.ius for package: httpd24u-2.4.46-1.el7.ius.x86_64
--> Processing Dependency: httpd24u-filesystem = 2.4.46-1.el7.ius for package: httpd24u-2.4.46-1.el7.ius.x86_64
--> Processing Dependency: system-logos >= 7.92.1-1 for package: httpd24u-2.4.46-1.el7.ius.x86_64
--> Processing Dependency: /etc/mime.types for package: httpd24u-2.4.46-1.el7.ius.x86_64
--> Processing Dependency: libnghttp2.so.14()(64bit) for package: httpd24u-2.4.46-1.el7.ius.x86_64
--> Processing Dependency: libbrotlienc.so.1()(64bit) for package: httpd24u-2.4.46-1.el7.ius.x86_64
--> Processing Dependency: libapr15uutil-1.so.0()(64bit) for package: httpd24u-2.4.46-1.el7.ius.x86_64
--> Processing Dependency: libapr15u-1.so.0()(64bit) for package: httpd24u-2.4.46-1.el7.ius.x86_64
---> Package httpd24u-devel.x86_64 0:2.4.46-1.el7.ius will be installed
--> Processing Dependency: apr15u-util-devel >= 1.5.0 for package: httpd24u-devel-2.4.46-1.el7.ius.x86_64
--> Processing Dependency: apr15u-devel >= 1.5.0 for package: httpd24u-devel-2.4.46-1.el7.ius.x86_64
---> Package httpd24u-mod_ldap.x86_64 0:2.4.46-1.el7.ius will be installed
--> Processing Dependency: apr15u-util-ldap >= 1.5.0 for package: httpd24u-mod_ldap-2.4.46-1.el7.ius.x86_64
---> Package httpd24u-tools.x86_64 0:2.4.46-1.el7.ius will be installed
---> Package libpng-devel.x86_64 2:1.5.13-8.el7 will be installed
---> Package links.x86_64 1:2.20.2-1.el7 will be installed
---> Package numpy.x86_64 1:1.7.1-13.el7 will be installed
--> Processing Dependency: libtatlas.so.3()(64bit) for package: 1:numpy-1.7.1-13.el7.x86_64
--> Processing Dependency: libquadmath.so.0()(64bit) for package: 1:numpy-1.7.1-13.el7.x86_64
--> Processing Dependency: liblapack.so.3()(64bit) for package: 1:numpy-1.7.1-13.el7.x86_64
--> Processing Dependency: libgfortran.so.3()(64bit) for package: 1:numpy-1.7.1-13.el7.x86_64
---> Package php-fpm.x86_64 0:7.1.33-13.el7.remi will be installed
---> Package php-opcache.x86_64 0:7.1.33-13.el7.remi will be installed
---> Package php-pecl-apcu.x86_64 0:5.1.20-1.el7.remi.7.1 will be installed
---> Package php-pecl-zip.x86_64 0:1.19.3-2.el7.remi.7.1 will be installed
--> Processing Dependency: libzip5(x86-64) >= 1.8.0 for package: php-pecl-zip-1.19.3-2.el7.remi.7.1.x86_64
--> Processing Dependency: libzip.so.5()(64bit) for package: php-pecl-zip-1.19.3-2.el7.remi.7.1.x86_64
---> Package php72u-pecl-apcu-bc.x86_64 0:1.0.5-2.el7.ius will be installed
--> Processing Dependency: php(zend-abi) = 20170718-64 for package: php72u-pecl-apcu-bc-1.0.5-2.el7.ius.x86_64
--> Processing Dependency: php(api) = 20170718-64 for package: php72u-pecl-apcu-bc-1.0.5-2.el7.ius.x86_64
--> Processing Dependency: php72u-pecl-apcu(x86-64) >= 5.1.2 for package: php72u-pecl-apcu-bc-1.0.5-2.el7.ius.x86_64
---> Package python-devel.x86_64 0:2.7.5-90.el7 will be installed
--> Processing Dependency: python2-rpm-macros > 3-30 for package: python-devel-2.7.5-90.el7.x86_64
--> Processing Dependency: python-rpm-macros > 3-30 for package: python-devel-2.7.5-90.el7.x86_64
---> Package python-matplotlib.x86_64 0:1.2.0-16.el7 will be installed
--> Processing Dependency: stix-math-fonts for package: python-matplotlib-1.2.0-16.el7.x86_64
--> Processing Dependency: stix-fonts for package: python-matplotlib-1.2.0-16.el7.x86_64
--> Processing Dependency: pytz for package: python-matplotlib-1.2.0-16.el7.x86_64
--> Processing Dependency: python-dateutil for package: python-matplotlib-1.2.0-16.el7.x86_64
--> Processing Dependency: pyparsing for package: python-matplotlib-1.2.0-16.el7.x86_64
--> Processing Dependency: pygtk2 for package: python-matplotlib-1.2.0-16.el7.x86_64
--> Processing Dependency: pycairo for package: python-matplotlib-1.2.0-16.el7.x86_64
--> Processing Dependency: dvipng for package: python-matplotlib-1.2.0-16.el7.x86_64
--> Processing Dependency: libagg.so.2()(64bit) for package: python-matplotlib-1.2.0-16.el7.x86_64
---> Package python-nose.noarch 0:1.3.7-1.el7 will be installed
---> Package scipy.x86_64 0:0.12.1-6.el7 will be installed
--> Processing Dependency: python-six for package: scipy-0.12.1-6.el7.x86_64
--> Processing Dependency: f2py for package: scipy-0.12.1-6.el7.x86_64
--> Processing Dependency: libumfpack.so.5()(64bit) for package: scipy-0.12.1-6.el7.x86_64
--> Processing Dependency: libamd.so.2()(64bit) for package: scipy-0.12.1-6.el7.x86_64
---> Package sympy.noarch 0:0.7.6-2.el7 will be installed
--> Processing Dependency: python-fastcache for package: sympy-0.7.6-2.el7.noarch
--> Processing Dependency: python-gmpy2 for package: sympy-0.7.6-2.el7.noarch
--> Processing Dependency: python-mpmath for package: sympy-0.7.6-2.el7.noarch
--> Processing Dependency: python-pyglet for package: sympy-0.7.6-2.el7.noarch
--> Running transaction check
---> Package agg.x86_64 0:2.5-18.el7 will be installed
--> Processing Dependency: libSDL-1.2.so.0()(64bit) for package: agg-2.5-18.el7.x86_64
---> Package apr15u.x86_64 0:1.5.2-2.ius.el7 will be installed
---> Package apr15u-devel.x86_64 0:1.5.2-2.ius.el7 will be installed
---> Package apr15u-util.x86_64 0:1.5.4-3.ius.el7 will be installed
---> Package apr15u-util-devel.x86_64 0:1.5.4-3.ius.el7 will be installed
--> Processing Dependency: openldap-devel(x86-64) for package: apr15u-util-devel-1.5.4-3.ius.el7.x86_64
--> Processing Dependency: libdb-devel(x86-64) for package: apr15u-util-devel-1.5.4-3.ius.el7.x86_64
--> Processing Dependency: expat-devel(x86-64) for package: apr15u-util-devel-1.5.4-3.ius.el7.x86_64
---> Package apr15u-util-ldap.x86_64 0:1.5.4-3.ius.el7 will be installed
---> Package atlas.x86_64 0:3.10.1-12.el7 will be installed
---> Package brotli.x86_64 0:1.0.7-5.el7 will be installed
---> Package centos-logos.noarch 0:70.0.6-3.el7.centos will be installed
---> Package centos-release-scl-rh.noarch 0:2-3.el7.centos will be installed
---> Package httpd24u-filesystem.noarch 0:2.4.46-1.el7.ius will be installed
---> Package lapack.x86_64 0:3.4.2-8.el7 will be installed
--> Processing Dependency: libblas.so.3()(64bit) for package: lapack-3.4.2-8.el7.x86_64
---> Package libgfortran.x86_64 0:4.8.5-44.el7 will be installed
---> Package libnghttp2.x86_64 0:1.33.0-1.1.el7 will be installed
---> Package libquadmath.x86_64 0:4.8.5-44.el7 will be installed
---> Package libzip5.x86_64 0:1.8.0-1.el7.remi will be installed
--> Processing Dependency: libzstd.so.1()(64bit) for package: libzip5-1.8.0-1.el7.remi.x86_64
---> Package mailcap.noarch 0:2.1.41-2.el7 will be installed
---> Package numpy-f2py.x86_64 1:1.7.1-13.el7 will be installed
---> Package php72u-common.x86_64 0:7.2.34-1.el7.ius will be installed
---> Package php72u-pecl-apcu.x86_64 0:5.1.18-1.el7.ius will be installed
---> Package pycairo.x86_64 0:1.8.10-8.el7 will be installed
---> Package pygtk2.x86_64 0:2.24.0-9.el7 will be installed
--> Processing Dependency: pygobject2 for package: pygtk2-2.24.0-9.el7.x86_64
---> Package pyparsing.noarch 0:1.5.6-9.el7 will be installed
---> Package python-dateutil.noarch 0:1.5-7.el7 will be installed
---> Package python-fastcache.x86_64 0:1.0.2-3.el7 will be installed
---> Package python-gmpy2.x86_64 0:2.0.5-1.el7 will be installed
---> Package python-pyglet.noarch 0:1.2.1-2.el7 will be installed
--> Processing Dependency: python-pillow for package: python-pyglet-1.2.1-2.el7.noarch
---> Package python-rpm-macros.noarch 0:3-34.el7 will be installed
--> Processing Dependency: python-srpm-macros for package: python-rpm-macros-3-34.el7.noarch
---> Package python-six.noarch 0:1.9.0-2.el7 will be installed
---> Package python2-mpmath.noarch 0:1.0.0-1.el7 will be installed
---> Package python2-rpm-macros.noarch 0:3-34.el7 will be installed
---> Package pytz.noarch 0:2016.10-2.el7 will be installed
---> Package stix-fonts.noarch 0:1.1.0-5.el7 will be installed
---> Package stix-math-fonts.noarch 0:1.1.0-5.el7 will be installed
---> Package suitesparse.x86_64 0:4.0.2-10.el7 will be installed
--> Processing Dependency: libtbbmalloc.so.2()(64bit) for package: suitesparse-4.0.2-10.el7.x86_64
--> Processing Dependency: libtbb.so.2()(64bit) for package: suitesparse-4.0.2-10.el7.x86_64
---> Package texlive-dvipng-bin.x86_64 2:svn26509.0-45.20130427_r30134.el7 will be installed
--> Processing Dependency: texlive-kpathsea-lib = 2:2012-45.20130427_r30134.el7 for package: 2:texlive-dvipng-bin-svn26509.0-45.20130427_r30134.el7.x86_64
--> Processing Dependency: texlive-base for package: 2:texlive-dvipng-bin-svn26509.0-45.20130427_r30134.el7.x86_64
--> Processing Dependency: tex-dvipng for package: 2:texlive-dvipng-bin-svn26509.0-45.20130427_r30134.el7.x86_64
--> Processing Dependency: libt1.so.5()(64bit) for package: 2:texlive-dvipng-bin-svn26509.0-45.20130427_r30134.el7.x86_64
--> Processing Dependency: libkpathsea.so.6()(64bit) for package: 2:texlive-dvipng-bin-svn26509.0-45.20130427_r30134.el7.x86_64
--> Running transaction check
---> Package SDL.x86_64 0:1.2.15-17.el7 will be installed
---> Package blas.x86_64 0:3.4.2-8.el7 will be installed
---> Package expat-devel.x86_64 0:2.1.0-12.el7 will be installed
---> Package libdb-devel.x86_64 0:5.3.21-25.el7 will be installed
---> Package libzstd.x86_64 0:1.5.0-1.el7 will be installed
---> Package openldap-devel.x86_64 0:2.4.44-23.el7_9 will be installed
--> Processing Dependency: cyrus-sasl-devel(x86-64) for package: openldap-devel-2.4.44-23.el7_9.x86_64
---> Package pygobject2.x86_64 0:2.28.6-11.el7 will be installed
---> Package python-pillow.x86_64 0:2.0.0-21.gitd1c6db8.el7 will be installed
--> Processing Dependency: libwebp.so.4()(64bit) for package: python-pillow-2.0.0-21.gitd1c6db8.el7.x86_64
---> Package python-srpm-macros.noarch 0:3-34.el7 will be installed
---> Package t1lib.x86_64 0:5.1.2-14.el7 will be installed
---> Package tbb.x86_64 0:4.1-9.20130314.el7 will be installed
---> Package texlive-base.noarch 2:2012-45.20130427_r30134.el7 will be installed
---> Package texlive-dvipng.noarch 2:svn26689.1.14-45.el7 will be installed
--> Processing Dependency: texlive-kpathsea-bin for package: 2:texlive-dvipng-svn26689.1.14-45.el7.noarch
--> Processing Dependency: tex-kpathsea for package: 2:texlive-dvipng-svn26689.1.14-45.el7.noarch
---> Package texlive-kpathsea-lib.x86_64 2:2012-45.20130427_r30134.el7 will be installed
--> Running transaction check
---> Package cyrus-sasl-devel.x86_64 0:2.1.26-23.el7 will be installed
--> Processing Dependency: cyrus-sasl(x86-64) = 2.1.26-23.el7 for package: cyrus-sasl-devel-2.1.26-23.el7.x86_64
---> Package libwebp.x86_64 0:0.3.0-10.el7_9 will be installed
---> Package texlive-kpathsea.noarch 2:svn28792.0-45.el7 will be installed
---> Package texlive-kpathsea-bin.x86_64 2:svn27347.0-45.20130427_r30134.el7 will be installed
--> Running transaction check
---> Package cyrus-sasl.x86_64 0:2.1.26-23.el7 will be installed
--> Processing Conflict: php72u-common-7.2.34-1.el7.ius.x86_64 conflicts php-common < 7.2.34-1.el7.ius
--> Finished Dependency Resolution
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
"]}

I have all the repos under yum.repos.d and they are all there, including ius, remi71, remi 72, etc...

Is there someone else having the same issue? I do not want to skip the dependencies resolution, I basically want to use the existing php common - php-common-7.1.33-13.el7.remi.x86_64 and not the php72u-common-7.2.34-1.el7.ius.x86_64.

Please help.

BTW, the CentOS repos I used are from this - https://mirror.rackspace.com/CentOS/7.9.2009/

Kind regards,
Carlo

User avatar
TrevorH
Forum Moderator
Posts: 30873
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installing PHP 7.1 packages on CentOS 7.9 (2009)

Post by TrevorH » 2021/06/20 14:43:44

You cannot mix and match both Remi and IUS packages, they are not interoperable. Pick one of them and stick with it. Either remove all your current php 7.2 packages from IUS and replace them with the 7.1 ones from Remi or the other way around.

Why are you trying to downgrade to 7.1 anyway? It's a dead release. Actually so is 7.2 so you should really be looking to go up not down. I see that php 7.3 has about 5 months life left and 7.4 has a year and 5 months so I'd be trying to go to 7.4 not to 7.1. IUS has 7.3 and 7.4 available.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

argo0627
Posts: 2
Joined: 2021/06/20 11:47:09

Re: Installing PHP 7.1 packages on CentOS 7.9 (2009)

Post by argo0627 » 2021/06/20 14:52:48

The reason we are using PHP 7.1 is because our application needs code updates to be able to upgrade. Our current version is 7.1.33 and we are only updating our LXC containers from centOS6 to centOS7.

How do we use just the remi repo for php packages? We do not want to use the IUS for php. Can we disable the ius repo instead for just this installation? and use remi?

Sorry for the questions, as Im an newbie for the repo settings.

Thanks.

User avatar
TrevorH
Forum Moderator
Posts: 30873
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installing PHP 7.1 packages on CentOS 7.9 (2009)

Post by TrevorH » 2021/06/20 15:42:53

You already have php 7.2 from IUS installed. Are you sure that nothing is using it? If nothing is then yum remove php\* to remove all php* packages then yum remove ius-release to uninstall the IUS repo then you should be able to install the outdated and reprecated 7.1 from the Remi repos. However, long term you need to get off 7.1 and onto a current supported release. This might be the best time to do that.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
remirepo
Posts: 421
Joined: 2014/09/21 09:07:12
Location: France
Contact:

Re: Installing PHP 7.1 packages on CentOS 7.9 (2009)

Post by remirepo » 2021/06/21 04:40:31

Looks like you are trying to install httpd24u from IUS and PHP from remi

This cannot work

"mod_php" in "remi" is designed to work with "httpd" from base repository.
BTW, probably possible to use php-fpm with httpd24u, but better to not mix various providers, and httpd in base repository is maintained and secure.
Remi's Repository - Forum - Blog

Post Reply

Return to “CentOS 7 - Software Support”