Yum couldn't update postgresql 11 + postgis 25

Issues related to applications and software problems
Post Reply
Bear4
Posts: 5
Joined: 2021/03/03 07:09:24

Yum couldn't update postgresql 11 + postgis 25

Post by Bear4 » 2021/03/18 12:56:49

Code: Select all

#yum update
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: proj72 >= 7.2.0
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: geos38 >= 3.8.1
           Installed: geos38-3.8.0-1.rhel7.x86_64 (@pgdg10)
               geos38 = 3.8.0-1.rhel7
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: gdal32-libs >= 3.2.0
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: libproj.so.19()(64bit)
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: libgdal.so.28()(64bit)
After

Code: Select all

#yum update --skip-broken
Skipped (dependency problems):
  hdf5.x86_64 0:1.8.12-12.el7                   libgfortran.x86_64 0:4.8.5-44.el7
  libquadmath.x86_64 0:4.8.5-44.el7             postgis25_11.x86_64 0:2.5.5-2.rhel7
  postgresql11.x86_64 0:11.11-1PGDG.rhel7       postgresql11-contrib.x86_64 0:11.11-1PGDG.rhel7
  postgresql11-libs.x86_64 0:11.11-1PGDG.rhel7  postgresql11-server.x86_64 0:11.11-1PGDG.rhel7
  xerces-c.x86_64 0:3.1.1-10.el7_7
Replaced:
  iwl7265-firmware.noarch 0:22.0.7.0-72.el7 webkitgtk4-plugin-process-gtk2.x86_64 0:2.22.7-2.el7
Complete!
[root@viist-p-telfs10]cat /etc/centos-release
CentOS Linux release 7.9.2009 (Core)
Have found package in:
https://centos.pkgs.org/7/postgresql-11 ... 4.rpm.html

Is there a fix for this?

User avatar
TrevorH
Forum Moderator
Posts: 30797
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum couldn't update postgresql 11 + postgis 25

Post by TrevorH » 2021/03/18 18:05:20

None of those missing packages are supplied by CentOS 7. I would suspect that they are all in the PGDG repo so going on your " Have found package in:" that sounds like you manually downloaded one single package and are trying to install it. The correct way is to find the PGDG release package that adds the correct repo to your system so that all the packages in it are available.

See https://www.postgresql.org/download/linux/redhat/
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Bear4
Posts: 5
Joined: 2021/03/03 07:09:24

Re: Yum couldn't update postgresql 11 + postgis 25

Post by Bear4 » 2021/03/19 06:58:01

Thanks for reply.
>I would suspect that they are all in the PGDG repo so going on your " Have found package in:" that sounds like you manually downloaded one single package and are trying to install it.
No, I don't :) I ask about it on this forum.
After You suggesion -> PGDG release package (https://www.postgresql.org/download/linux/redhat/)
# Install the repository RPM:
sudo yum install -y https://download.postgresql.org/pub/rep ... noarch.rpm
and the same effect - no success

Code: Select all

#yum update
---> Package postgis25_11.x86_64 0:2.5.5-2.rhel7 will be an update
--> Processing Dependency: proj72 >= 7.2.0 for package: postgis25_11-2.5.5-2.rhel7.x86_64
--> Processing Dependency: geos38 >= 3.8.1 for package: postgis25_11-2.5.5-2.rhel7.x86_64
--> Processing Dependency: gdal32-libs >= 3.2.0 for package: postgis25_11-2.5.5-2.rhel7.x86_64
--> Processing Dependency: libproj.so.19()(64bit) for package: postgis25_11-2.5.5-2.rhel7.x86_64
--> Processing Dependency: libgdal.so.28()(64bit) for package: postgis25_11-2.5.5-2.rhel7.x86_64
--> Finished Dependency Resolution
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: proj72 >= 7.2.0
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: geos38 >= 3.8.1
           Installed: geos38-3.8.0-1.rhel7.x86_64 (@pgdg10)
               geos38 = 3.8.0-1.rhel7
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: gdal32-libs >= 3.2.0
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: libproj.so.19()(64bit)
Error: Package: postgis25_11-2.5.5-2.rhel7.x86_64 (pgdg11)
           Requires: libgdal.so.28()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
How to fix this missing packages?

User avatar
TrevorH
Forum Moderator
Posts: 30797
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum couldn't update postgresql 11 + postgis 25

Post by TrevorH » 2021/03/19 10:38:22

I think you're going to need to ask the people that manage the PGDG repo. None of those packages exist in CentOS nor are they in EPEL.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Bear4
Posts: 5
Joined: 2021/03/03 07:09:24

Re: Yum couldn't update postgresql 11 + postgis 25

Post by Bear4 » 2021/03/19 10:57:31

Ok.
Thanks.

NickH
Posts: 14
Joined: 2018/03/14 15:26:12

Re: Yum couldn't update postgresql 11 + postgis 25

Post by NickH » 2021/04/06 14:43:22

Why not give up on those external repos and use the SCLo repos? There is not a postgresql11 but there is a 10 and a 12 (rh-postgresql10 and rh-postgresql12)

Bear4
Posts: 5
Joined: 2021/03/03 07:09:24

Re: Yum couldn't update postgresql 11 + postgis 25

Post by Bear4 » 2021/05/10 06:44:59

And success.
Replace inside /etc/yum.repos.d/pgdg-redhat-all.repo

[pgdg11]
name=PostgreSQL 11 for RHEL/CentOS $releasever - $basearch
#baseurl=https://download.postgresql.org/pub/rep ... -$releasev$
baseurl=https://ftp.postgresql.org/pub/repos/yu ... l-7-x86_64

Post Reply

Return to “CentOS 7 - Software Support”