Missing repomd.xml for 7.9.2009

General support questions
Post Reply
jescobaru
Posts: 3
Joined: 2024/04/05 16:48:36

Missing repomd.xml for 7.9.2009

Post by jescobaru » 2024/04/05 16:55:17

We are getting the following error when trying to pull the following file:

requests.exceptions.HTTPError: 404 Client Error: Not Found for url: http://archive.kernel.org/centos-vault/ ... repomd.xml

I tried curl, but it is also failing.

Checked another mirror site and also here, but the file is missing too.

Looking at previous versions (e.g. 7.7.1908, 7.8.2003) the x86_64/repodata/repomd.xml path is there.

Can you help us fix this please?

User avatar
TrevorH
Site Admin
Posts: 33281
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Missing repomd.xml for 7.9.2009

Post by TrevorH » 2024/04/05 17:04:00

What are you trying to do? I do not think anything for 7.9.2009 should be on vault.centos.org at all as yet as it's still a live version. Only retired/dead versions of CentOS should be on vault and 7.9 is not either just yet.
The future appears to be RHEL or Debian. I think I'm going Debian.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are deadest, do not use them.
Use the FAQ Luke

jescobaru
Posts: 3
Joined: 2024/04/05 16:48:36

Re: Missing repomd.xml for 7.9.2009

Post by jescobaru » 2024/04/05 23:21:45

We have a Github action that builds a kernel probe based on the provided kernel version. We use the repomd.xml as index for installing other packages.

Why is it that other versions have that file available?

7.5.1804/ 09-May-2018 20:39 - (has the file repomd.xml on the same path)
7.6.1810/ 02-Dec-2018 14:34 - (has the file repomd.xml on the same path)
7.7.1908/ 15-Sep-2019 01:00 - (has the file repomd.xml on the same path)
7.8.2003/ 17-Jun-2020 17:55 - (has the file repomd.xml on the same path)
7.9.2009/ 18-Jan-2021 14:14 - (Does not have the file repomd.xml on the same path)

User avatar
TrevorH
Site Admin
Posts: 33281
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Missing repomd.xml for 7.9.2009

Post by TrevorH » 2024/04/06 01:50:15

Because 7.5 - 7.8 are outdated and have been moved to vault. 7.9 is the current version and is on the CentOS mirror network, not on vault (because it's still alive). Around about July this year after 7.9 goes EOL, it too will get moved to vault.centos.org.
The future appears to be RHEL or Debian. I think I'm going Debian.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are deadest, do not use them.
Use the FAQ Luke

jescobaru
Posts: 3
Joined: 2024/04/05 16:48:36

Re: Missing repomd.xml for 7.9.2009

Post by jescobaru » 2024/04/11 17:59:24

Thank you for the information provided.

Post Reply