Ethernet not showing on intel NUC NUC10FNH

General support questions
Post Reply
maretha
Posts: 1
Joined: 2022/08/29 11:03:18

Ethernet not showing on intel NUC NUC10FNH

Post by maretha » 2023/11/23 12:45:54

Good day Everyone,

After install Centos 7 minimal on my Product: BXNUC10I5FNHN Model: NUC10FNH I have no Ethernet interface.

Here some of output.
[root@pbx ~]# lspci -nn | grep -i ethernet
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (10) I219-V [8086:0d4f]

#ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
link/ether 2c:33:58:b8:80:df brd ff:ff:ff:ff:ff:ff

[root@pbx ~]# ifconfig -a
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 64 bytes 5568 (5.4 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 64 bytes 5568 (5.4 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlp0s20f3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.40.12.5 netmask 255.255.255.0 broadcast 10.40.12.255
inet6 fe80::f683:4b43:f94d:73fc prefixlen 64 scopeid 0x20<link>
ether 2c:33:58:b8:80:df txqueuelen 1000 (Ethernet)
RX packets 92845 bytes 72448970 (69.0 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 21167 bytes 1894974 (1.8 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Can anyone help please?

User avatar
TrevorH
Site Admin
Posts: 33269
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Ethernet not showing on intel NUC NUC10FNH

Post by TrevorH » 2023/11/23 21:47:35

CentOS 7 dies in about 6 months time so there really is not much point in installing it. Use a newer distro.
The future appears to be RHEL or Debian. I think I'm going Debian.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are deadest, do not use them.
Use the FAQ Luke

Post Reply