Page 1 of 1

obfsproxy running on centos 7

Posted: 2023/01/22 17:19:15
by Vort3x.Layers
I am using CentOS 7 os.
python version is 2.7.5.
pip2 version is 8.1.2.
After that i installed obfsproxy like this :

> To use obfsproxy you will need Python (>= 2.7) and pip.

pip2 install pathlib
pip2 install pyopenssl
pip2 install Twisted
pip2 install obfsproxy

Here are installation path :
/usr/lib/python2.7/site-packages/obfsproxy-0.2.13-py2.7.egg-info
/usr/lib/python2.7/site-packages/obfsproxy
/usr/lib/python2.7/site-packages/obfsproxy/pyobfsproxy.py
/usr/lib/python2.7/site-packages/obfsproxy/pyobfsproxy.pyc
/usr/bin/obfsproxy

Now after running obfsproxy command i got this error :

Code: Select all

Traceback (most recent call last):
  File "/usr/bin/obfsproxy", line 9, in <module>
    load_entry_point('obfsproxy==0.2.13', 'console_scripts', 'obfsproxy')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 378, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2566, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.7/site-packages/obfsproxy/pyobfsproxy.py", line 12, in <module>
    import obfsproxy.network.launch_transport as launch_transport
  File "/usr/lib/python2.7/site-packages/obfsproxy/network/launch_transport.py", line 2, in <module>
    import obfsproxy.transports.transports as transports
  File "/usr/lib/python2.7/site-packages/obfsproxy/transports/transports.py", line 6, in <module>
    import obfsproxy.transports.scramblesuit.scramblesuit as scramblesuit
  File "/usr/lib/python2.7/site-packages/obfsproxy/transports/scramblesuit/scramblesuit.py", line 16, in <module>
    import yaml
  File "/usr/lib64/python2.7/site-packages/yaml/__init__.py", line 362
    class YAMLObject(metaclass=YAMLObjectMetaclass):
                              ^
SyntaxError: invalid syntax

What version of python is suitable for this script and how can i fix this error?

Here is https://pypi.org/project/obfsproxy