Page 1 of 1

Centos 7 Connectivity Issues in VMware Workstation

Posted: 2021/02/12 12:41:12
by MHamas
Hi all,

I am new to CentOS and this forum too so at my part I have tried to look up the issue that I have been facing but I haven't found any desirable results. If there is already same issue posted earlier than apologies, and I would request anyone to kindly guide me to it. Anyways, coming to the problem that I am facing.

I have downloaded an ISO of Goautodial 4 which comes with CentOS 7 and asterisk 13. On my first day, I was able to login to web portal that comes by default with Goautodial after installation and I was also able to ssh it using putty. I tried rebooting the machine multiple times and everything was working at optimum. However, after doing certain tasks, I turned off my laptop and the next day, I was unable to ssh it. I was even unable to ping machine from Windows host.

At the same time, internet inside my vm is working fine apparently as I have updated my CentOS after losing access and I have tried pinging multiple sources like,, and even local IP of my host machine (Windows 10). I have also tried downloading multiple files using wget and no issue found. Details that might be useful up to my knowledge are provided below.

Ping from my host machine:


Pinging with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Ifconfig on my CentOS machine:
ifconfig.PNG (15.73 KiB) Viewed 147 times
ifconfig.PNG (15.73 KiB) Viewed 147 times

/etc/resolv.conf configuration:
resolv-conf.PNG (1.27 KiB) Viewed 147 times

ping from vm to host:
ping from host to vm.PNG
ping from host to vm.PNG (11.72 KiB) Viewed 147 times

route -n from vm:

[root@vag1xc01 ~]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface UG 100 0 0 ens33 U 100 0 0 ens33

It should be noted that currently my vmnet0 is on bridge and set to auto. vmnet 8 (through which ens33 is connected) is NAT, I have tried changing the config to bridging for vmnet 8 too but after I change it from NAT to Bridge, I am unable to ping even

Further I have also tried checking the traceroute and it is not going beyond gateway i.e Since I am facing this issue while bridging too, and I have been searching but nothing that I have found on the forum yet, has helped me so far. Or I may have not found the correct solution.

I would request anyone to please guide me through this.

Re: Centos 7 Connectivity Issues in VMware Workstation

Posted: 2021/02/13 11:51:11
by jlehtone
First a note: Commands 'ifconfig' and 'route' are ancient.
CentOS 7 does use NetworkManager.service and firewalld.service by default.
Those have their own commands to show status. For example:

Code: Select all

nmcli d s
nmcli c s
firewall-cmd --get-active-zones
There are other commands to read state too:

Code: Select all

ip li
ip ad
ip ro
brctl show
iptables -S
iptables -t nat -S
iptables -t mangle -S
You show that the VM has address that is in subnet and that the router on that network is
However, you ping as your host, which is clearly in different subnet.

I know nothing about vmware, but it sounds like your host has no clue where is -- or blocks new connections to it.
In other words, problem might not be in the CentOS config.

What do you get in VM with:

Code: Select all


Re: Centos 7 Connectivity Issues in VMware Workstation

Posted: 2021/02/19 11:59:33
by MHamas
I mentioned in the post that I was trying to ping different subnet which is on my host machine. You are right about the normal scenario that I will not be able to ping a different subnet (as per the basic networking), but this case is specific to VMware workstation where I mentioned that I have used both NAT and bridging but it was not working.

At the same time I also mentioned that when I created the machine, I was able to access it via ssh.

Anyways, I was apparently missing some drivers on my host machine due to which I had to disable and than enable vmnet manually after I restarted my machine everytime. I had a misunderstanding that issue might be related to CentOS. It was resolved after I reinstalled a few drivers.

Thanks for reaching out though.