Cannot connect to my server when vpn is activated

General support questions
Post Reply
felix1337
Posts: 2
Joined: 2021/01/29 20:40:33

Cannot connect to my server when vpn is activated

Post by felix1337 » 2021/01/29 20:57:17

Hey.

I have 2 different networks. ()
X0 - 10.0.10.0/24 is a unsecure network for all my iot devices. Tv, phone and so on.
X4 - 10.0.20.0/24 is a secure network for my servers.

The problem is, when i turn on vpn on my server, i cant access it from the X0 network. But i can from X4 network.
I don't understand why this is happening.

Here is a picture of me pinging the server from x0 and then enabling vpn, then loosing connection..
https://gyazo.com/938505aebe37eaaab4126da4599951d0

By loosing connection i mean i cant ping, ssh, use my sonarr and other web services.
But for some weird reason, i can access all of that from another server on x4 network.


Firewall settings in my router.
N2 = X4 (secure network)
Lan = X0 (Insecure network)

X4 to X0
https://gyazo.com/7a2c4c2fcc9a339f86e49dd1de2607c0

X0 to X4
https://gyazo.com/2645f54eaf8357afc44dc0e49d7cb99e
Everything from X0 to X4 is denied except some mac addresses i have whitelisted.
So i can access radarr, sonarr ect on my phone.

The interfaces on my sonicwall.
https://gyazo.com/b28599a1084103d784b54cbf079d201b

I dont think its the router thats blocking anything. I can see with packet monitor that its forwards the packets just fine.
https://gyazo.com/afafcb5e985e9cfed029b8c6854c56b8


I just installed a win vm to test. When i connect to same vpn provider, i cant replicate the connection error on a windows server 2019.
So i think its something in my centos that is blocking the connections.

felix1337
Posts: 2
Joined: 2021/01/29 20:40:33

Re: Cannot connect to my server when vpn is activated

Post by felix1337 » 2021/02/13 16:32:47

I found the problem!!!

The server tried to reach the x0 lan via the vpn default gateway.
I had to make a static route on the server. IP route add 10.0.10.0/24 via 10.0.20.1

Post Reply

Return to “CentOS 7 - General Support”