Page 1 of 1

Installing multiple php version on centos 7

Posted: 2020/12/26 14:39:06
by xdxbx
Hello ,

I am a new member here , hope you can help me solving my issue ..

I have different php coding which the old one were used to work on php ~5.4 and centos 6 .. currently i had changed my server and now it is running with centos 7 and php 7.3 + ..

So , i would like you guys to help me with a way to install and run 2 different php versions on my server to be able to run bith new and old sites coding since the old one is not working and it shows :
Zend Guard Run-time support missing!
One more more files on this web site were encoded by ZendGuard and the required run-time support is not installed orproperly configured.

For the Web site user
This means that this Web server is not configured correctly to runthe files that it contains. Please contact the Web site'sadministrator/webmaster and inform them of this problem and give themthe URL you are trying to display to help them in diagnosing theproblem.

For The Site Administrator/Web Master
One or more files on your site were encoded with Zend Guard. Thismay be third party libraries that were provided to you by an ISV. Toallow these files to properly run you need to download and installone of the Zend guard run-time libraries. This is either ZendOptimizer or Zend Loader. The proper files can be downloaded fromhttp://www.zend.com/guard/downloads.This software is provided free of charge.

General Disclaimer: Zend Technologies is not responsible tothe configuration and setup of web sites using Zend Guard technology.Please contact your software vendor if these components were providedby an ISV or consult your Zend Guard Users Guide if these files wereencoded by your organization.


And at the same time , there is no way to ask the coding provider to do anything with the coding to let it work again with my new configuration as they are no more exist ..

So , will the installation of 2 php versions help to solve my issue or not and what do you recommend ..

Hope someone can help me to solve this issue as i am not able to do anything for more than a month now and gods know when it'll be solved and worked again !!

Re: Installing multiple php version on centos 7

Posted: 2020/12/27 05:47:34
by remirepo
Running multiple PHP versions is described on
https://developers.redhat.com/blog/2017 ... tion-tips/

Of course Zend Loader have to be installed in the version which use it.

Re: Installing multiple php version on centos 7

Posted: 2020/12/27 07:36:04
by xdxbx
First of all , thank you for your reply

Secondly , the article you post , is it safe and can be installed with out any problems ?
remirepo wrote:
2020/12/27 05:47:34
Running multiple PHP versions is described on
https://developers.redhat.com/blog/2017 ... tion-tips/

Of course Zend Loader have to be installed in the version which use it.

Re: Installing multiple php version on centos 7

Posted: 2020/12/27 13:28:04
by TrevorH
Secondly , the article you post , is it safe and can be installed with out any problems ?
1) it's on redhat.com
2) it was the author of the article that pointed you to it

Re: Installing multiple php version on centos 7

Posted: 2020/12/27 16:46:26
by xdxbx
TrevorH wrote:
2020/12/27 13:28:04
Secondly , the article you post , is it safe and can be installed with out any problems ?
1) it's on redhat.com
2) it was the author of the article that pointed you to it
Thank you for your reply ..

Actually i tried to do what is mentioned in the article starting by removing php using

Code: Select all

yum remove php
and i got

Code: Select all

Loaded plugins: fastestmirror, universal-hooks
No Match for argument: php
No Packages marked for removal
also tried to install php-fpm .. didn't work

Code: Select all

Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 185.53.12.144
 * cpanel-plugins: 185.53.12.144
 * base: mirror.plustech.de
 * epel: www.nic.funet.fi
 * extras: mirror.imt-systems.com
 * updates: mirror.plustech.de
No package php-fpm available.
Error: Nothing to do
I don't know where to start and how ..

Re: Installing multiple php version on centos 7

Posted: 2020/12/27 17:02:07
by TrevorH
You're running cpanel so you need to ask them. They already replace all the LAMP stack with their own so we cannot advise here.

Re: Installing multiple php version on centos 7

Posted: 2020/12/27 17:08:04
by xdxbx
TrevorH wrote:
2020/12/27 17:02:07
You're running cpanel so you need to ask them. They already replace all the LAMP stack with their own so we cannot advise here.
Yes , i am running cpanel ..
so there is no option other than talking to them ?

Re: Installing multiple php version on centos 7

Posted: 2020/12/27 20:17:57
by TrevorH
They supply your current php so, yes, you need to talk to them.