yum update fails

General support questions
Post Reply
hoodcanaljim
Posts: 306
Joined: 2006/02/05 17:49:10

yum update fails

Post by hoodcanaljim » 2020/11/19 19:50:04

Hi
I have a problem with one of my computers (dell pc) not completing a yum- update
at the top of the list of packages to be updated is the following from logwatch
/etc/cron.daily/0yum-daily.cron:
Transaction couldn't start:
qt-settings is needed by qt-1:4.8.7-9.el7_9.x86_64
libmng.so.1()(64bit) is needed by qt-x11-1:4.8.7-9.el7_9.x86_64
at the bottom is
Install 2 Packages
Upgrade 96 Packages
Remove 2 Packages
Updates failed to install with the following error message:
Could not run transaction.
uname -a
Linux nor 3.10.0-1160.2.2.el7.x86_64 #1 SMP Tue Oct 20 16:53:08 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

both
qt-1:4.8.7-9.el7_9.x86_64
qt-x11-1:4.8.7-9.el7_9.x86_64
and
/usr/lib64/libmng.so.1

are installed so I am left wondering what are the "qt-settings needed by qt-1:4.8.7-9.el7_9.x86_64"

Jim

kdpatil
Posts: 31
Joined: 2020/10/20 07:19:31

Re: yum update fails

Post by kdpatil » 2020/11/20 01:29:33

try

yum install -y nc


give the o/p

also do

cat /etc/resolve.cof

a full output if the error always helps


what you are seeing is dependency issue

what does below have

cat /etc/redhat-release ; uname -r

hoodcanaljim
Posts: 306
Joined: 2006/02/05 17:49:10

Re: yum update fails

Post by hoodcanaljim » 2020/11/20 02:28:41

kdpatil

sudo yum install nc
Loaded plugins: langpacks
Package 2:nmap-ncat-6.40-19.el7.x86_64 already installed and latest version
Nothing to do
Not sure what this does
give the o/p
a full output if the error always helps
The two quotes in the first post have a list of the packages that will be updated *

No file /etc/resolve.conf
cat /etc/redhat-release ; uname -r
CentOS Linux release 7.9.2009 (Core)
3.10.0-1160.2.2.el7.x86_64

Thanks for your help
Jim
* edit

kdpatil
Posts: 31
Joined: 2020/10/20 07:19:31

Re: yum update fails

Post by kdpatil » 2020/11/20 07:01:42

hoodcanaljim wrote:
2020/11/20 02:28:41
kdpatil

sudo yum install nc
Loaded plugins: langpacks
Package 2:nmap-ncat-6.40-19.el7.x86_64 already installed and latest version
Nothing to do
Not sure what this does
give the o/p
a full output if the error always helps
The two quotes in the first post have a list of the packages that will be updated *

No file /etc/resolve.conf
cat /etc/redhat-release ; uname -r
CentOS Linux release 7.9.2009 (Core)
3.10.0-1160.2.2.el7.x86_64

Thanks for your help
Jim
* edit


looking at below

CentOS Linux release 7.9.2009 (Core)
3.10.0-1160.2.2.el7.x86_64

your system seems running latest & greatest already

can you give full output of below



yum update

User avatar
TrevorH
Forum Moderator
Posts: 29902
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum update fails

Post by TrevorH » 2020/11/20 15:41:59

Please post ALL of the output from the yum command that is being problematic. Include the command prompt you use to invoke it, all the way through until the command prompt returns.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

hoodcanaljim
Posts: 306
Joined: 2006/02/05 17:49:10

Re: yum update fails

Post by hoodcanaljim » 2020/11/20 17:05:22

kdpatil
TrevorH

sudo yum update
Loaded plugins: langpacks
No packages marked for update

The error that occurs appears in a Anacron job message after yum-cron has run. That is the only place the error message appears and the update fails. But entering "sudo yum update" on the command line functions fine and the system updates. That is what I have been doing for the last year.
Here is the full listing of the error report from the Anacron messge.

/etc/cron.daily/0yum-daily.cron:

Transaction couldn't start:
qt-settings is needed by qt-1:4.8.7-9.el7_9.x86_64
libmng.so.1()(64bit) is needed by qt-x11-1:4.8.7-9.el7_9.x86_64
The following updates will be applied on nor:
================================================================================
Package Arch Version Repository
Size
================================================================================
Installing:
kernel x86_64 3.10.0-1160.6.1.el7 updates 50 M
kernel-devel x86_64 3.10.0-1160.6.1.el7 updates 18 M
Updating:
NetworkManager x86_64 1:1.18.8-2.el7_9 updates 1.9 M
NetworkManager-adsl x86_64 1:1.18.8-2.el7_9 updates 163 k
NetworkManager-bluetooth x86_64 1:1.18.8-2.el7_9 updates 183 k
NetworkManager-glib x86_64 1:1.18.8-2.el7_9 updates 1.5 M
NetworkManager-libnm x86_64 1:1.18.8-2.el7_9 updates 1.7 M
NetworkManager-team x86_64 1:1.18.8-2.el7_9 updates 165 k
NetworkManager-tui x86_64 1:1.18.8-2.el7_9 updates 329 k
NetworkManager-wifi x86_64 1:1.18.8-2.el7_9 updates 202 k
NetworkManager-wwan x86_64 1:1.18.8-2.el7_9 updates 188 k
bind-export-libs x86_64 32:9.11.4-26.P2.el7_9.2 updates 1.1 M
bind-libs x86_64 32:9.11.4-26.P2.el7_9.2 updates 157 k
bind-libs-lite x86_64 32:9.11.4-26.P2.el7_9.2 updates 1.1 M
bind-license noarch 32:9.11.4-26.P2.el7_9.2 updates 90 k
bind-utils x86_64 32:9.11.4-26.P2.el7_9.2 updates 260 k
coreutils x86_64 8.22-24.el7_9.2 updates 3.3 M
crash x86_64 7.2.3-11.el7_9.1 updates 2.6 M
curl x86_64 7.29.0-59.el7_9.1 updates 271 k
device-mapper-multipath x86_64 0.4.9-134.el7_9 updates 148 k
device-mapper-multipath-libs x86_64 0.4.9-134.el7_9 updates 268 k
device-mapper-persistent-data x86_64 0.8.5-3.el7_9.2 updates 423 k
evolution-ews x86_64 3.28.5-8.el7_9 updates 380 k
evolution-ews-langpacks noarch 3.28.5-8.el7_9 updates 157 k
firewall-config noarch 0.6.3-12.el7 updates 137 k
firewalld noarch 0.6.3-12.el7 updates 448 k
firewalld-filesystem noarch 0.6.3-12.el7 updates 51 k
gdm x86_64 1:3.28.2-25.el7 updates 525 k
glib2 x86_64 2.56.1-8.el7 updates 2.5 M
glib2-devel x86_64 2.56.1-8.el7 updates 454 k
gtk-update-icon-cache x86_64 3.22.30-6.el7 updates 27 k
gtk3 x86_64 3.22.30-6.el7 updates 4.4 M
httpd x86_64 2.4.6-97.el7.centos updates 2.7 M
httpd-tools x86_64 2.4.6-97.el7.centos updates 93 k
ibus x86_64 1.5.17-12.el7_9 updates 4.8 M
ibus-gtk2 x86_64 1.5.17-12.el7_9 updates 45 k
ibus-gtk3 x86_64 1.5.17-12.el7_9 updates 46 k
ibus-libs x86_64 1.5.17-12.el7_9 updates 228 k
ibus-setup noarch 1.5.17-12.el7_9 updates 80 k
initscripts x86_64 9.49.53-1.el7_9.1 updates 440 k
kernel-headers x86_64 3.10.0-1160.6.1.el7 updates 9.0 M
kernel-tools x86_64 3.10.0-1160.6.1.el7 updates 8.1 M
kernel-tools-libs x86_64 3.10.0-1160.6.1.el7 updates 8.0 M
kexec-tools x86_64 2.0.15-51.el7_9.1 updates 351 k
kpartx x86_64 0.4.9-134.el7_9 updates 81 k
libcurl x86_64 7.29.0-59.el7_9.1 updates 223 k
libgudev1 x86_64 219-78.el7_9.2 updates 109 k
libvirt-bash-completion x86_64 4.5.0-36.el7_9.3 updates 203 k
libvirt-client x86_64 4.5.0-36.el7_9.3 updates 500 k
libvirt-daemon x86_64 4.5.0-36.el7_9.3 updates 844 k
libvirt-daemon-driver-interface x86_64 4.5.0-36.el7_9.3 updates 242 k
libvirt-daemon-driver-network x86_64 4.5.0-36.el7_9.3 updates 416 k
libvirt-daemon-driver-nodedev x86_64 4.5.0-36.el7_9.3 updates 241 k
libvirt-daemon-driver-qemu x86_64 4.5.0-36.el7_9.3 updates 751 k
libvirt-daemon-driver-secret x86_64 4.5.0-36.el7_9.3 updates 232 k
libvirt-daemon-driver-storage-core
x86_64 4.5.0-36.el7_9.3 updates 442 k
libvirt-daemon-driver-storage-disk
x86_64 4.5.0-36.el7_9.3 updates 233 k
libvirt-daemon-driver-storage-iscsi
x86_64 4.5.0-36.el7_9.3 updates 231 k
libvirt-daemon-driver-storage-logical
x86_64 4.5.0-36.el7_9.3 updates 234 k
libvirt-daemon-driver-storage-rbd
x86_64 4.5.0-36.el7_9.3 updates 236 k
libvirt-daemon-driver-storage-scsi
x86_64 4.5.0-36.el7_9.3 updates 231 k
libvirt-libs x86_64 4.5.0-36.el7_9.3 updates 4.2 M
mesa-dri-drivers x86_64 18.3.4-12.el7_9 updates 7.2 M
mesa-filesystem x86_64 18.3.4-12.el7_9 updates 19 k
mesa-khr-devel x86_64 18.3.4-12.el7_9 updates 20 k
mesa-libEGL x86_64 18.3.4-12.el7_9 updates 110 k
mesa-libGL x86_64 18.3.4-12.el7_9 updates 166 k
mesa-libGL-devel x86_64 18.3.4-12.el7_9 updates 164 k
mesa-libGLES x86_64 18.3.4-12.el7_9 updates 16 k
mesa-libgbm x86_64 18.3.4-12.el7_9 updates 39 k
mesa-libglapi x86_64 18.3.4-12.el7_9 updates 46 k
mesa-libxatracker x86_64 18.3.4-12.el7_9 updates 1.3 M
mutter x86_64 3.28.3-28.el7 updates 2.3 M
open-vm-tools x86_64 11.0.5-3.el7_9.1 updates 676 k
open-vm-tools-desktop x86_64 11.0.5-3.el7_9.1 updates 178 k
poppler x86_64 0.26.5-43.el7.1 updates 787 k
poppler-glib x86_64 0.26.5-43.el7.1 updates 142 k
poppler-utils x86_64 0.26.5-43.el7.1 updates 170 k
python x86_64 2.7.5-90.el7 updates 96 k
python-blivet noarch 1:0.61.15.76-1.el7_9 updates 835 k
python-devel x86_64 2.7.5-90.el7 updates 399 k
python-firewall noarch 0.6.3-12.el7 updates 355 k
python-libs x86_64 2.7.5-90.el7 updates 5.6 M
python-perf x86_64 3.10.0-1160.6.1.el7 updates 8.1 M
python3 x86_64 3.6.8-18.el7 updates 70 k
python3-libs x86_64 3.6.8-18.el7 updates 6.9 M
qt x86_64 1:4.8.7-9.el7_9 updates 4.6 M
qt-x11 x86_64 1:4.8.7-9.el7_9 updates 13 M
selinux-policy noarch 3.13.1-268.el7_9.2 updates 498 k
selinux-policy-targeted noarch 3.13.1-268.el7_9.2 updates 7.0 M
systemd x86_64 219-78.el7_9.2 updates 5.1 M
systemd-libs i686 219-78.el7_9.2 updates 425 k
systemd-libs x86_64 219-78.el7_9.2 updates 418 k
systemd-python x86_64 219-78.el7_9.2 updates 145 k
systemd-sysv x86_64 219-78.el7_9.2 updates 96 k
tcsh x86_64 6.18.01-17.el7_9.1 updates 339 k
xorg-x11-server-Xorg x86_64 1.20.4-13.el7_9 updates 1.5 M
xorg-x11-server-common x86_64 1.20.4-13.el7_9 updates 56 k
Removing:
kernel x86_64 3.10.0-1127.19.1.el7 @updates 64 M
kernel-devel x86_64 3.10.0-1127.19.1.el7 @updates 38 M

Transaction Summary
================================================================================
Install 2 Packages
Upgrade 96 Packages
Remove 2 Packages
Updates failed to install with the following error message:
Could not run transaction.
The execution of the command line sudo yum update runs with no errors and completes the update The yum-cron completes with no errors on both my other centos 7 computers.
I am looking at the errors at the top of the message.
Transaction couldn't start:
qt-settings is needed by qt-1:4.8.7-9.el7_9.x86_64
libmng.so.1()(64bit) is needed by qt-x11-1:4.8.7-9.el7_9.x86_64
qt-1:4.8.7-9.el7_9.x86_64, qt-x11-1:4.8.7-9.el7_9.x86_64, and libmng.so.1()(64bit) are all installed on the computer so I am left wondering what is
qt-settings is needed by qt-1:4.8.7-9.el7_9.x86_64
What is "qt-settings" is needed by qt-1:4.8.7-9.el7_9.x86_64

Thank you for your time and help
Jim

User avatar
TrevorH
Forum Moderator
Posts: 29902
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum update fails

Post by TrevorH » 2020/11/20 17:59:59

What's the output from yum list qt qt-settings libmng ?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

hoodcanaljim
Posts: 306
Joined: 2006/02/05 17:49:10

Re: yum update fails

Post by hoodcanaljim » 2020/11/20 19:13:11

TrevorH

Code: Select all

sudo yum list qt qt-settings libmng 
Loaded plugins: langpacks
Installed Packages
libmng.x86_64                      1.0.10-14.el7                        @base   
qt.x86_64                          1:4.8.7-9.el7_9                      @updates
qt-settings.noarch                 19-23.12.el7.centos                  @base   
Available Packages
libmng.i686                        1.0.10-14.el7                        base    
qt.i686                            1:4.8.7-9.el7_9                      updates 

Thanks
Jim

Post Reply

Return to “CentOS 7 - General Support”