Problem installing in VirtualBox

General support questions
Post Reply
Elliott
Posts: 37
Joined: 2018/09/14 01:30:14

Problem installing in VirtualBox

Post by Elliott » 2020/10/14 19:28:28

I'm trying to install CentOS 7.8 in a VirtualBox VM. The installer GUI appears for a few seconds and then crashes. I managed to setup NAT networking and copy the logs to the host filesystem via SCP. I attached anaconda.log. I set the VM to RedHat 64-bit with 6 vCPUs with EFI enabled. I am installing from CentOS-7-x86_64-Minimal-2003.iso. I'm using VirtualBox 6.1.14. Is EFI supposed to work? Below is the error I see:

Code: Select all

15:15:04,804 CRIT anaconda: Traceback (most recent call last):

  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)

  File "/usr/lib64/python2.7/threading.py", line 765, in run
    self.__target(*self.__args, **self.__kwargs)

  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 203, in checkSoftwareSelection
    self.payload.checkSoftwareSelection()

  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1454, in checkSoftwareSelection
    self._applyYumSelections()

  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1396, in _applyYumSelections
    self._selectYumGroup("core")

  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1281, in _selectYumGroup
    self._yum.selectGroup(groupid, group_package_types=pkg_types)

  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3899, in selectGroup
    thesegroups = self.comps.return_groups(grpid)

  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1098, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),

  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 912, in _getGroups
    self.pkgSack

  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1075, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),

  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 778, in _getSacks
    self.repos.populateSack(which=repos)

  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 386, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)

  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 244, in populate
    raise Errors.RepoError, '%s: Check uncompressed DB failed' % repo

RepoError: anaconda: Check uncompressed DB failed

Elliott
Posts: 37
Joined: 2018/09/14 01:30:14

Re: Problem installing in VirtualBox

Post by Elliott » 2020/10/14 19:36:13

It sounds like some file is corrupt, so I verified the SHA256 checksum for the ISO is correct.
I tried again with EFI turned off in the VM settings, and this time I get a different traceback. This time I don't see the error written anywhere in /tmp so I took a screenshot.
Attachments
Screen Shot 2020-10-14 at 3.31.33 PM.png
Screen Shot 2020-10-14 at 3.31.33 PM.png (124.68 KiB) Viewed 119 times

Elliott
Posts: 37
Joined: 2018/09/14 01:30:14

Re: Problem installing in VirtualBox

Post by Elliott » 2020/10/14 19:51:24

I tried text mode with EFI disabled and it hangs forever when I try to accept the default LVM partitioning.
I notice syslog shows a strange kernel version:

Code: Select all

19:36:41,566 NOTICE kernel:Linux version 3.f¸ü3…ÂA#000#000#000#000#000#000#000#0006_64 (mockbuild@kbuilder.bsys.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-39) (GCC) ) #1 SMP Tue Mar 31 23:36:51 UTC 2020

User avatar
TrevorH
Forum Moderator
Posts: 29681
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Problem installing in VirtualBox

Post by TrevorH » 2020/10/14 19:56:13

Did you check the sha256sum of the downloaded iso file against the list published in the Release Notes?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Elliott
Posts: 37
Joined: 2018/09/14 01:30:14

Re: Problem installing in VirtualBox

Post by Elliott » 2020/10/15 15:43:30

Yes I did verify the SHA256 checksum. I also tried the older version 7.7 and have similar problems there.

Post Reply

Return to “CentOS 7 - General Support”