Page 1 of 1

sendmail problem

Posted: 2020/09/07 17:33:06
by waishingleung
I have a centos7 mail server running sendmail. It have been running for few years
Today, there is one client could not receive our email

I found sendmail is trying to connect to the web server port 25 of our client, not their mail server
I have checked the dns mx record is correct
I can telnet to their mail server port 25

Tried restart service but no luck
Tried change dns server also failed
Tried send email to client using gmail

Anybody has any idea?
:?: :?: :?: :?: :?:

Re: sendmail problem

Posted: 2020/09/07 17:42:36
by TrevorH
Port 25 is not a web server port, it's the standard SMTP port so is the correct one. In any case, port selection has nothing at all to do with DNS or MX records since neither have the ability to specify a port number.

Re: sendmail problem

Posted: 2020/09/07 17:52:33
by waishingleung
TrevorH wrote:
2020/09/07 17:42:36
Port 25 is not a web server port, it's the standard SMTP port so is the correct one. In any case, port selection has nothing at all to do with DNS or MX records since neither have the ability to specify a port number.
Thanks for your reply

We could send email to all other people but this client could not
sendmail should connect to client mail server port 25 not the web server port 25
I have checked their dns record, mx record is correct

why sendmail choose to connect to our client web server?

Re: sendmail problem

Posted: 2020/09/07 20:47:54
by TrevorH
You'll have to give concrete examples of what is wrong since we have no idea what the difference is between your destination web/mail server or how you can tell. If the MX record for their domain points to their SMTP server then that is the one that it should be using. We'd need actual log information to debug it any further and you wouldn't be able to obscure the domain names involved or they'd be useless.