yum problem

General support questions
Post Reply
hans.ensing
Posts: 5
Joined: 2020/07/27 12:38:31

yum problem

Post by hans.ensing » 2020/07/27 12:45:16

i have this problem "yum"

$ yum
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

/usr/lib64/python2.7/site-packages/pycurl.so: undefined symbol: CRYPTO_num_locks

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.7.5 (default, Aug 7 2019, 00:51:29)
[GCC 4.8.5 20150623 (Red Hat 4.8.5-39)]

If you cannot solve this problem yourself, please go to
the yum faq at:
http://yum.baseurl.org/wiki/Faq

I have search on the web this problem, but i am not able to fix it

User avatar
TrevorH
Forum Moderator
Posts: 29932
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum problem

Post by TrevorH » 2020/07/27 13:10:30

Have you attempted to install a newer openssl or changed the python version that is installed?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

hans.ensing
Posts: 5
Joined: 2020/07/27 12:38:31

Re: yum problem

Post by hans.ensing » 2020/07/27 14:31:50

I have tried many things, but the main problem if i already type:
sudo yum update

I get the error as reported before...

User avatar
jlehtone
Posts: 3180
Joined: 2007/12/11 08:17:33
Location: Finland

Re: yum problem

Post by jlehtone » 2020/07/27 14:50:16

hans.ensing wrote:
2020/07/27 14:31:50
I have tried many things, but the main problem if i already type
The question is, what did you do before the problem did appear?

If you did replace some system components that 'yum' depends on, then that broke you system.

(Well, things tried after the problem started can have made it worse, but the root cause was earlier.)

hans.ensing
Posts: 5
Joined: 2020/07/27 12:38:31

Re: yum problem

Post by hans.ensing » 2020/07/27 15:08:44

I tried to install php 7.4 ... after that the problem came along...

for the rest the servers works...still receive emails and the website is running normaly..

User avatar
jlehtone
Posts: 3180
Joined: 2007/12/11 08:17:33
Location: Finland

Re: yum problem

Post by jlehtone » 2020/07/27 15:53:40

hans.ensing wrote:
2020/07/27 15:08:44
I tried to install php 7.4
More details, please.

Did you follow these instructions?
https://blog.remirepo.net/post/2019/12/ ... -or-Fedora

hans.ensing
Posts: 5
Joined: 2020/07/27 12:38:31

Re: yum problem

Post by hans.ensing » 2020/07/27 16:15:41

Yes i did, but the problem is that yum does not work anymore and gives the error.

All listed solutions on the internet requires a command with yum...so those are no option to solve the problem..

User avatar
TrevorH
Forum Moderator
Posts: 29932
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum problem

Post by TrevorH » 2020/07/27 17:34:09

What is the output from rpm -Va openssl\* python\* yum\* rpm\* ?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

hans.ensing
Posts: 5
Joined: 2020/07/27 12:38:31

Re: yum problem

Post by hans.ensing » 2020/07/28 05:30:31

Hi, the output is:

S.5....T. /usr/include/openssl/md5.b
S.5....T. /usr/include/openssl/modes.b
S.5....T. /usr/include/openssl/obj_mac.b
S.5....T. /usr/include/openssl/objects.b
S.5....T. /usr/include/openssl/ocsp.b
S.5....T. /usr/include/openssl/opensslconf.b
S.5....T. /usr/include/openssl/opensslv.h
S.5....T. /usr/include/openssl/ossl_typ.b
S.5....T. /usr/include/openssl/pem.b
S.5....T. /usr/include/openssl/pemZ.b
S.5....T. /usr/include/openssl/pkcs1Z.b
S.5....T. /usr/include/openssl/pkcs7.11
S.5....T. /usr/include/openssl/rand.b
S.5....T. /usr/include/openssl/ra.b
S.5....T. /usr/include/openssl/rc4.11
S.5....T. /usr/include/openssl/rc5.11
S.5....T. /usr/include/openssl/ripemd.b
S.5....T. /usr/include/openssl/rsa.b
S.5....T. /usr/include/openssl/safestack.b
S.5....T. /usr/include/openssl/seed.b
S.5....T. /usr/include/openssl/slia.b
S.5....T. /usr/include/openssl/srtp.b
S.5....T. /usr/include/openssl/ssl.b
S.5....T. /usr/include/openssl/ss1Z.b
S.5....T. /usr/include/openssl/ss13.11
S.5....T. /usr/include/openssl/stack.b
S.5....T. /usr/include/openssl/symbacks.b
S.5....T. /usr/include/openssl/t1s1.b
S.5....T. /usr/include/openssl/ts.b
S.5....T. /usr/include/openssl/txt_db.b
S.5....T. /usr/include/openssl/ui.b
S.5....T. /usr/include/openssl/wbrlpool.b
S.5....T. /usr/include/openssl/x5E19.b
S.5....T. /usr/include/openssl/x509_vfy.b
S.5....T. /usr/include/openssl/x5B9v3.b
L.... /usr/lib64/libcrypto.so
L.... /usr/lib64/libssl.so
S.5....T. /usr/lib64/pkyconfiy/libcrypto.pc
S.5....T. /usr/lib64/pkyconfiy/libssl.pc
/usr/lib64/pkyconfiy/openssl.pc
S.5....T. /usr/bin/openssl
S.5....T. c /etc/yum/pluyinconf.d/lanypacks.conf
Unsatisfied dependencies for python-pycur1-7.19.0-19.e17.x86_64:
libcurl >= 7.29.0 is needed by (installed) python-pycur1-7.19.0-19.e17.x86_64 libcurl.so.40(64bit) is needed by (installed) python-pycur1-7.19.0-19.e17.x86_64

Post Reply

Return to “CentOS 7 - General Support”