Unable to update docker on CentOS7 myobt-containerd conflicts with containerd.io

General support questions
Post Reply
truacaldwell
Posts: 1
Joined: 2020/07/13 05:50:35

Unable to update docker on CentOS7 myobt-containerd conflicts with containerd.io

Post by truacaldwell » 2020/07/13 06:25:51

Hello,
I'm unable to update docker on my CentOS7 vm. I get the following errors:

Error: moby-containerd conflicts with containerd.io-1.2.13-3.2.el7.x86_64
Error: moby-runc conflicts with containerd.io-1.2.13-3.2.el7.x86_64

Does someone know how i can fix it?
Thanks

broda02
Posts: 1
Joined: 2020/07/19 08:31:52

Re: Unable to update docker on CentOS7 myobt-containerd conflicts with containerd.io

Post by broda02 » 2020/07/19 08:34:16

Did you find a solution to this?

User avatar
TrevorH
Forum Moderator
Posts: 29069
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Unable to update docker on CentOS7 myobt-containerd conflicts with containerd.io

Post by TrevorH » 2020/07/19 15:21:07

Where are you getting your copy of docker from? The one from our 'extras' repo installs without any problem.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

icemyth
Posts: 2
Joined: 2020/07/21 14:10:43

Re: Unable to update docker on CentOS7 myobt-containerd conflicts with containerd.io

Post by icemyth » 2020/07/21 14:17:40

Hi @TrevorH,

I followed the instructions at https://docs.docker.com/engine/install/centos/

I'm running into this issue too.

Code: Select all

 sudo yum remove docker \
                  docker-client \
                  docker-client-latest \
                  docker-common \
                  docker-latest \
                  docker-latest-logrotate \
                  docker-logrotate \
                  docker-engine
// Output
// Loaded plugins: fastestmirror
// No Match for argument: docker
// No Match for argument: docker-client
// No Match for argument: docker-client-latest
// No Match for argument: docker-common
// No Match for argument: docker-latest
// No Match for argument: docker-latest-logrotate
// No Match for argument: docker-logrotate
// No Match for argument: docker-engine
// No Packages marked for removal
Then I ran these commands

Code: Select all

sudo yum install -y yum-utils

sudo yum-config-manager \
    --add-repo \
    https://download.docker.com/linux/centos/docker-ce.repo
Then this command where I got the errors mentioned in the orignal post

Code: Select all

sudo yum install docker-ce docker-ce-cli containerd.io

//......
//--> Finished Dependency Resolution
//Error: moby-containerd conflicts with containerd.io-1.2.13-3.2.el7.x86_64
//Error: moby-runc conflicts with containerd.io-1.2.13-3.2.el7.x86_64
//You could try using --skip-broken to work around the problem
//You could try running: rpm -Va --nofiles --nodigest
Any idea what was the issue? I was able to install docker on CentOS 7 like 3-4 weeks ago, but today it didn't work.

Thanks

User avatar
TrevorH
Forum Moderator
Posts: 29069
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Unable to update docker on CentOS7 myobt-containerd conflicts with containerd.io

Post by TrevorH » 2020/07/21 14:43:54

We don't support what docker ships. We support what we ship and you're not using it. You'll need to address these questions to the people that provide those packages.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

icemyth
Posts: 2
Joined: 2020/07/21 14:10:43

Re: Unable to update docker on CentOS7 myobt-containerd conflicts with containerd.io

Post by icemyth » 2020/07/21 14:53:46

Thank you so much

Post Reply

Return to “CentOS 7 - General Support”