Remote Desktop Connection Failure to Maintain Connection

General support questions
Post Reply
Posts: 14
Joined: 2020/05/25 04:08:41

Remote Desktop Connection Failure to Maintain Connection

Post by ASTONE » 2020/07/03 23:05:03

Hello all/anyone who has suggestion:

When I use either Windows Remote Desktop Connection of VNC to remote into my CentOS 7 Server, I can never get to the desktop. Even after successfully getting to the VNC login dialog box, upon clicking OK, the connection drops and the window closes. I've found several "solutions" on the Internet, purporting to be a step-by-step method but nothing actually comes through for me.

Sites that I've tried include: ... ss-server/ ... dp-centos/ ... 7-console/ ... -7-rhel-7/ ... to-centos7 ... hel-7.html ... -tigervnc/ ... -a-service

If anyone needs specific configurations just ask, but I've generally accepted all defaults.

Thank you in advance for your help.

Posts: 14
Joined: 2020/05/25 04:08:41

Remote Desktop Connection Failure to Maintain Connection - Update 1 (Stable Connection with Blank Blue Screen)

Post by ASTONE » 2020/07/04 16:29:49

To anyone following this saga,

I made the following 2 changes to move the ball forward:

1. Changed metalink= ... =$basearch to
metalink= ... =$basearch

2. Changed SELinux mode from "enforcing" to "permissive"

Then I re-installed all the repos indicated on the various websites, re-updated, re-upgraded, re-enabled and reloaded the vncserver service, and rebooted.

Result: I can now log into a VNC session without having it disconnect instantly and close. However, all I get is a blank, blue screen.

I refollowed instructions on the web sites listed above. There is controversy about the PID line in the server@.service file. That should probably be sorted out by "experts". I doubt if if that is the source of my problem because the problem exists both with and without the line.

Specific Question:

Server with GUI, GNOME Desktop and Graphical Administration Tools all show up as Available but never make the "Installated groups:" list. Anyone know why this is, or if this is related to my problem? I've recently installed MATE to see if that solves my problem. My next post will state whether or not that worked.

yum grouplist
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base:
* epel:
* extras:
* updates:
Installed environment groups:
MATE Desktop
Available environment groups:
Minimal Install
Compute Node
Infrastructure Server
File and Print Server
Cinnamon Desktop
Basic Web Server
Virtualization Host
Server with GUI
GNOME Desktop
KDE Plasma Workspaces
Development and Creative Workstation
Installed groups:
Available Groups:
Compatibility Libraries
Console Internet Tools
Development Tools
Educational Software
Electronic Lab
Fedora Packager
General Purpose Desktop
Graphical Administration Tools
LXQt Desktop
Legacy UNIX Compatibility
Scientific Support
Security Tools
Smart Card Support
System Administration Tools
System Management
TurboGears application framework

I do plan to fully document my process if I can get this working, so that the community will have a good source to go to, but right now, I'm not finding solutions or consistency in the ethersphere. I really could use advice from an experienced expert in this area.

Post Reply

Return to “CentOS 7 - General Support”