How do I fix this broken dependencies?

General support questions
Post Reply
joserobjr
Posts: 1
Joined: 2020/07/02 22:56:11

How do I fix this broken dependencies?

Post by joserobjr » 2020/07/02 22:59:40

I'm trying to run `yum update` but somehow I got broken dependencies and I have no idea how to fix them :/

There are some suggested commands in the last lines but I'm afraid of running them and breaking more stuff.

Code: Select all

# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: mirror.dst.ca
 * nux-dextop: mirror.li.nux.ro
 * remi: mirror.pit.teraswitch.com
 * remi-safe: mirror.pit.teraswitch.com
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.7.8.9-18.el7 will be updated
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64
---> Package ImageMagick.x86_64 0:6.9.11.22-1.el7.remi will be an update
--> Processing Dependency: ImageMagick-libs(x86-64) = 6.9.11.22-1.el7.remi for package: ImageMagick-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libMagickCore-6.Q16.so.6()(64bit) for package: ImageMagick-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libMagickWand-6.Q16.so.6()(64bit) for package: ImageMagick-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libfftw3.so.3()(64bit) for package: ImageMagick-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libraqm.so.0()(64bit) for package: ImageMagick-6.9.11.22-1.el7.remi.x86_64
---> Package NetworkManager-libnm.x86_64 1:1.18.0-5.el7_7.2 will be updated
---> Package NetworkManager-libnm.x86_64 1:1.18.4-3.el7 will be an update
---> Package SDL.x86_64 0:1.2.15-15.el7_7 will be updated
---> Package SDL.x86_64 0:1.2.15-16.el7 will be an update
---> Package acl.x86_64 0:2.2.51-14.el7 will be updated
---> Package acl.x86_64 0:2.2.51-15.el7 will be an update
---> Package atk.x86_64 0:2.28.1-1.el7 will be updated
---> Package atk.x86_64 0:2.28.1-2.el7 will be an update
---> Package avahi-libs.x86_64 0:0.6.31-19.el7 will be updated
---> Package avahi-libs.x86_64 0:0.6.31-20.el7 will be an update
---> Package bash.x86_64 0:4.2.46-33.el7 will be updated
---> Package bash.x86_64 0:4.2.46-34.el7 will be an update
---> Package bash-completion.noarch 1:2.1-6.el7 will be updated
---> Package bash-completion.noarch 1:2.1-8.el7 will be an update
---> Package bind.x86_64 32:9.11.4-9.P2.el7 will be updated
---> Package bind.x86_64 32:9.11.4-16.P2.el7_8.6 will be an update
---> Package bind-export-libs.x86_64 32:9.11.4-9.P2.el7 will be updated
---> Package bind-export-libs.x86_64 32:9.11.4-16.P2.el7_8.6 will be an update
---> Package bind-libs.x86_64 32:9.11.4-9.P2.el7 will be updated
---> Package bind-libs.x86_64 32:9.11.4-16.P2.el7_8.6 will be an update
---> Package bind-libs-lite.x86_64 32:9.11.4-9.P2.el7 will be updated
---> Package bind-libs-lite.x86_64 32:9.11.4-16.P2.el7_8.6 will be an update
---> Package bind-license.noarch 32:9.11.4-9.P2.el7 will be updated
---> Package bind-license.noarch 32:9.11.4-16.P2.el7_8.6 will be an update
---> Package bind-utils.x86_64 32:9.11.4-9.P2.el7 will be updated
---> Package bind-utils.x86_64 32:9.11.4-16.P2.el7_8.6 will be an update
---> Package binutils.x86_64 0:2.27-41.base.el7_7.3 will be updated
---> Package binutils.x86_64 0:2.27-43.base.el7_8.1 will be an update
---> Package ca-certificates.noarch 0:2019.2.32-76.el7_7 will be updated
---> Package ca-certificates.noarch 0:2020.2.41-70.0.el7_8 will be an update
---> Package centos-release.x86_64 0:7-7.1908.0.el7.centos will be updated
---> Package centos-release.x86_64 0:7-8.2003.0.el7.centos will be an update
---> Package clamav.x86_64 0:0.102.2-4.el7 will be updated
---> Package clamav.x86_64 0:0.102.3-1.el7 will be an update
---> Package clamav-data.noarch 0:0.102.2-4.el7 will be updated
---> Package clamav-data.noarch 0:0.102.3-1.el7 will be an update
---> Package clamav-devel.x86_64 0:0.102.2-4.el7 will be updated
---> Package clamav-devel.x86_64 0:0.102.3-1.el7 will be an update
---> Package clamav-filesystem.noarch 0:0.102.2-4.el7 will be updated
---> Package clamav-filesystem.noarch 0:0.102.3-1.el7 will be an update
---> Package clamav-lib.x86_64 0:0.102.2-4.el7 will be updated
---> Package clamav-lib.x86_64 0:0.102.3-1.el7 will be an update
--> Processing Dependency: libprelude.so.28()(64bit) for package: clamav-lib-0.102.3-1.el7.x86_64
---> Package clamav-update.x86_64 0:0.102.2-4.el7 will be updated
---> Package clamav-update.x86_64 0:0.102.3-1.el7 will be an update
---> Package clamd.x86_64 0:0.102.2-4.el7 will be updated
---> Package clamd.x86_64 0:0.102.3-1.el7 will be an update
---> Package container-selinux.noarch 2:2.107-3.el7 will be updated
---> Package container-selinux.noarch 2:2.119.1-1.c57a6f9.el7 will be an update
---> Package containerd.io.x86_64 0:1.2.13-3.1.el7 will be updated
---> Package containerd.io.x86_64 0:1.2.13-3.2.el7 will be an update
---> Package cryptsetup-libs.x86_64 0:2.0.3-5.el7 will be updated
---> Package cryptsetup-libs.x86_64 0:2.0.3-6.el7 will be an update
---> Package cups-libs.x86_64 1:1.6.3-40.el7 will be updated
---> Package cups-libs.x86_64 1:1.6.3-43.el7 will be an update
---> Package curl.x86_64 0:7.29.0-54.el7_7.2 will be updated
---> Package curl.x86_64 0:7.29.0-57.el7 will be an update
---> Package device-mapper.x86_64 7:1.02.158-2.el7_7.2 will be updated
---> Package device-mapper.x86_64 7:1.02.164-7.el7_8.2 will be an update
---> Package device-mapper-event.x86_64 7:1.02.158-2.el7_7.2 will be updated
---> Package device-mapper-event.x86_64 7:1.02.164-7.el7_8.2 will be an update
---> Package device-mapper-event-libs.x86_64 7:1.02.158-2.el7_7.2 will be updated
---> Package device-mapper-event-libs.x86_64 7:1.02.164-7.el7_8.2 will be an update
---> Package device-mapper-libs.x86_64 7:1.02.158-2.el7_7.2 will be updated
---> Package device-mapper-libs.x86_64 7:1.02.164-7.el7_8.2 will be an update
---> Package device-mapper-persistent-data.x86_64 0:0.8.5-1.el7 will be updated
---> Package device-mapper-persistent-data.x86_64 0:0.8.5-2.el7 will be an update
---> Package dhclient.x86_64 12:4.2.5-77.el7.centos will be updated
---> Package dhclient.x86_64 12:4.2.5-79.el7.centos will be an update
---> Package dhcp-common.x86_64 12:4.2.5-77.el7.centos will be updated
---> Package dhcp-common.x86_64 12:4.2.5-79.el7.centos will be an update
---> Package dhcp-libs.x86_64 12:4.2.5-77.el7.centos will be updated
---> Package dhcp-libs.x86_64 12:4.2.5-79.el7.centos will be an update
---> Package docker-ce.x86_64 3:19.03.8-3.el7 will be updated
---> Package docker-ce.x86_64 3:19.03.12-3.el7 will be an update
---> Package docker-ce-cli.x86_64 1:19.03.8-3.el7 will be updated
---> Package docker-ce-cli.x86_64 1:19.03.12-3.el7 will be an update
---> Package dracut.x86_64 0:033-564.el7 will be updated
---> Package dracut.x86_64 0:033-568.el7 will be an update
---> Package dracut-config-rescue.x86_64 0:033-564.el7 will be updated
---> Package dracut-config-rescue.x86_64 0:033-568.el7 will be an update
---> Package dracut-network.x86_64 0:033-564.el7 will be updated
---> Package dracut-network.x86_64 0:033-568.el7 will be an update
---> Package e2fsprogs.x86_64 0:1.42.9-16.el7 will be updated
---> Package e2fsprogs.x86_64 0:1.42.9-17.el7 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.42.9-16.el7 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.42.9-17.el7 will be an update
---> Package elfutils.x86_64 0:0.176-2.el7 will be updated
---> Package elfutils.x86_64 0:0.176-4.el7 will be an update
---> Package elfutils-default-yama-scope.noarch 0:0.176-2.el7 will be updated
---> Package elfutils-default-yama-scope.noarch 0:0.176-4.el7 will be an update
---> Package elfutils-libelf.x86_64 0:0.176-2.el7 will be updated
---> Package elfutils-libelf.x86_64 0:0.176-4.el7 will be an update
---> Package elfutils-libs.x86_64 0:0.176-2.el7 will be updated
---> Package elfutils-libs.x86_64 0:0.176-4.el7 will be an update
---> Package file.x86_64 0:5.11-35.el7 will be updated
---> Package file.x86_64 0:5.11-36.el7 will be an update
---> Package file-libs.x86_64 0:5.11-35.el7 will be updated
---> Package file-libs.x86_64 0:5.11-36.el7 will be an update
---> Package firewalld-filesystem.noarch 0:0.6.3-2.el7_7.4 will be updated
---> Package firewalld-filesystem.noarch 0:0.6.3-8.el7_8.1 will be an update
---> Package gdb.x86_64 0:7.6.1-115.el7 will be updated
---> Package gdb.x86_64 0:7.6.1-119.el7 will be an update
---> Package gettext.x86_64 0:0.19.8.1-2.el7 will be updated
---> Package gettext.x86_64 0:0.19.8.1-3.el7 will be an update
---> Package gettext-libs.x86_64 0:0.19.8.1-2.el7 will be updated
---> Package gettext-libs.x86_64 0:0.19.8.1-3.el7 will be an update
---> Package glibc.x86_64 0:2.17-292.el7 will be updated
---> Package glibc.x86_64 0:2.17-307.el7.1 will be an update
---> Package glibc-common.x86_64 0:2.17-292.el7 will be updated
---> Package glibc-common.x86_64 0:2.17-307.el7.1 will be an update
---> Package glibc-devel.x86_64 0:2.17-292.el7 will be updated
---> Package glibc-devel.x86_64 0:2.17-307.el7.1 will be an update
---> Package glibc-headers.x86_64 0:2.17-292.el7 will be updated
---> Package glibc-headers.x86_64 0:2.17-307.el7.1 will be an update
---> Package grafana.x86_64 0:7.0.3-1 will be updated
---> Package grafana.x86_64 0:7.0.5-1 will be an update
---> Package grub2.x86_64 1:2.02-0.80.el7.centos will be updated
---> Package grub2.x86_64 1:2.02-0.81.el7.centos will be an update
---> Package grub2-common.noarch 1:2.02-0.80.el7.centos will be updated
---> Package grub2-common.noarch 1:2.02-0.81.el7.centos will be an update
---> Package grub2-efi-x64.x86_64 1:2.02-0.80.el7.centos will be updated
---> Package grub2-efi-x64.x86_64 1:2.02-0.81.el7.centos will be an update
---> Package grub2-pc.x86_64 1:2.02-0.80.el7.centos will be updated
---> Package grub2-pc.x86_64 1:2.02-0.81.el7.centos will be an update
---> Package grub2-pc-modules.noarch 1:2.02-0.80.el7.centos will be updated
---> Package grub2-pc-modules.noarch 1:2.02-0.81.el7.centos will be an update
---> Package grub2-tools.x86_64 1:2.02-0.80.el7.centos will be updated
---> Package grub2-tools.x86_64 1:2.02-0.81.el7.centos will be an update
---> Package grub2-tools-extra.x86_64 1:2.02-0.80.el7.centos will be updated
---> Package grub2-tools-extra.x86_64 1:2.02-0.81.el7.centos will be an update
---> Package grub2-tools-minimal.x86_64 1:2.02-0.80.el7.centos will be updated
---> Package grub2-tools-minimal.x86_64 1:2.02-0.81.el7.centos will be an update
---> Package gtk-update-icon-cache.x86_64 0:3.22.30-3.el7 will be updated
---> Package gtk-update-icon-cache.x86_64 0:3.22.30-5.el7 will be an update
---> Package hwdata.x86_64 0:0.252-9.3.el7 will be updated
---> Package hwdata.x86_64 0:0.252-9.5.el7 will be an update
---> Package initscripts.x86_64 0:9.49.47-1.el7 will be updated
---> Package initscripts.x86_64 0:9.49.49-1.el7 will be an update
---> Package ipmitool.x86_64 0:1.8.18-7.el7 will be updated
---> Package ipmitool.x86_64 0:1.8.18-9.el7_7 will be an update
---> Package iptables.x86_64 0:1.4.21-33.el7 will be updated
---> Package iptables.x86_64 0:1.4.21-34.el7 will be an update
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.242.b08-0.el7_7 will be updated
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.252.b09-2.el7_8 will be an update
---> Package java-1.8.0-openjdk-devel.x86_64 1:1.8.0.242.b08-0.el7_7 will be updated
---> Package java-1.8.0-openjdk-devel.x86_64 1:1.8.0.252.b09-2.el7_8 will be an update
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.242.b08-0.el7_7 will be updated
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.252.b09-2.el7_8 will be an update
---> Package jenkins.noarch 0:2.231-1.1 will be updated
---> Package jenkins.noarch 0:2.243-1.1 will be an update
---> Package kernel-4.19-ovh-xxxx-std-ipv6-64-headers.x86_64 0:4.19_ovh_xxxx_std_ipv6_64-1179808 will be updated
---> Package kernel-4.19-ovh-xxxx-std-ipv6-64-headers.x86_64 0:4.19_ovh_xxxx_std_ipv6_64-1315229 will be an update
---> Package kernelcare.x86_64 0:2.24-1.el7 will be updated
---> Package kernelcare.x86_64 0:2.31-1.el7 will be an update
---> Package kexec-tools.x86_64 0:2.0.15-33.el7 will be updated
---> Package kexec-tools.x86_64 0:2.0.15-43.el7 will be an update
---> Package kmod.x86_64 0:20-25.el7_7.1 will be updated
---> Package kmod.x86_64 0:20-28.el7 will be an update
---> Package kmod-libs.x86_64 0:20-25.el7_7.1 will be updated
---> Package kmod-libs.x86_64 0:20-28.el7 will be an update
---> Package kpartx.x86_64 0:0.4.9-127.el7 will be updated
---> Package kpartx.x86_64 0:0.4.9-131.el7 will be an update
---> Package krb5-devel.x86_64 0:1.15.1-37.el7_7.2 will be updated
---> Package krb5-devel.x86_64 0:1.15.1-46.el7 will be an update
---> Package krb5-libs.x86_64 0:1.15.1-37.el7_7.2 will be updated
---> Package krb5-libs.x86_64 0:1.15.1-46.el7 will be an update
---> Package libacl.x86_64 0:2.2.51-14.el7 will be updated
---> Package libacl.x86_64 0:2.2.51-15.el7 will be an update
---> Package libblkid.x86_64 0:2.23.2-61.el7_7.1 will be updated
---> Package libblkid.x86_64 0:2.23.2-63.el7 will be an update
---> Package libcap.x86_64 0:2.22-10.el7 will be updated
---> Package libcap.x86_64 0:2.22-11.el7 will be an update
---> Package libcom_err.x86_64 0:1.42.9-16.el7 will be updated
---> Package libcom_err.x86_64 0:1.42.9-17.el7 will be an update
---> Package libcom_err-devel.x86_64 0:1.42.9-16.el7 will be updated
---> Package libcom_err-devel.x86_64 0:1.42.9-17.el7 will be an update
---> Package libcurl.x86_64 0:7.29.0-54.el7_7.2 will be updated
---> Package libcurl.x86_64 0:7.29.0-57.el7 will be an update
---> Package libffi.x86_64 0:3.0.13-18.el7 will be updated
---> Package libffi.x86_64 0:3.0.13-19.el7 will be an update
---> Package libkadm5.x86_64 0:1.15.1-37.el7_7.2 will be updated
---> Package libkadm5.x86_64 0:1.15.1-46.el7 will be an update
---> Package libmount.x86_64 0:2.23.2-61.el7_7.1 will be updated
---> Package libmount.x86_64 0:2.23.2-63.el7 will be an update
---> Package libpaper.x86_64 0:1.1.24-8.el7 will be updated
---> Package libpaper.x86_64 0:1.1.24-8.el7.remi will be an update
---> Package libpcap.x86_64 14:1.5.3-11.el7 will be updated
---> Package libpcap.x86_64 14:1.5.3-12.el7 will be an update
---> Package libreport-filesystem.x86_64 0:2.1.11-43.el7.centos will be updated
---> Package libreport-filesystem.x86_64 0:2.1.11-53.el7.centos will be an update
---> Package libseccomp.x86_64 0:2.3.1-3.el7 will be updated
---> Package libseccomp.x86_64 0:2.3.1-4.el7 will be an update
---> Package libselinux.x86_64 0:2.5-14.1.el7 will be updated
---> Package libselinux.x86_64 0:2.5-15.el7 will be an update
---> Package libselinux-devel.x86_64 0:2.5-14.1.el7 will be updated
---> Package libselinux-devel.x86_64 0:2.5-15.el7 will be an update
---> Package libselinux-python.x86_64 0:2.5-14.1.el7 will be updated
---> Package libselinux-python.x86_64 0:2.5-15.el7 will be an update
---> Package libselinux-utils.x86_64 0:2.5-14.1.el7 will be updated
---> Package libselinux-utils.x86_64 0:2.5-15.el7 will be an update
---> Package libsmartcols.x86_64 0:2.23.2-61.el7_7.1 will be updated
---> Package libsmartcols.x86_64 0:2.23.2-63.el7 will be an update
---> Package libsndfile.x86_64 0:1.0.25-10.el7 will be updated
---> Package libsndfile.x86_64 0:1.0.25-11.el7 will be an update
---> Package libss.x86_64 0:1.42.9-16.el7 will be updated
---> Package libss.x86_64 0:1.42.9-17.el7 will be an update
---> Package libteam.x86_64 0:1.27-9.el7 will be updated
---> Package libteam.x86_64 0:1.29-1.el7 will be an update
---> Package libuuid.x86_64 0:2.23.2-61.el7_7.1 will be updated
---> Package libuuid.x86_64 0:2.23.2-63.el7 will be an update
---> Package libxml2.x86_64 0:2.9.1-6.el7_2.3 will be updated
---> Package libxml2.x86_64 0:2.9.1-6.el7.4 will be an update
---> Package libxml2-python.x86_64 0:2.9.1-6.el7_2.3 will be updated
---> Package libxml2-python.x86_64 0:2.9.1-6.el7.4 will be an update
---> Package linux-firmware.noarch 0:20190429-72.gitddde598.el7 will be updated
---> Package linux-firmware.noarch 0:20191203-76.gite8a0f4c.el7 will be an update
---> Package logrotate.x86_64 0:3.8.6-17.el7 will be updated
---> Package logrotate.x86_64 0:3.8.6-19.el7 will be an update
---> Package lshw.x86_64 0:B.02.18-13.el7 will be updated
---> Package lshw.x86_64 0:B.02.18-14.el7 will be an update
---> Package lvm2.x86_64 7:2.02.185-2.el7_7.2 will be updated
---> Package lvm2.x86_64 7:2.02.186-7.el7_8.2 will be an update
---> Package lvm2-libs.x86_64 7:2.02.185-2.el7_7.2 will be updated
---> Package lvm2-libs.x86_64 7:2.02.186-7.el7_8.2 will be an update
---> Package mdadm.x86_64 0:4.1-1.el7 will be updated
---> Package mdadm.x86_64 0:4.1-4.el7 will be an update
---> Package mesa-libEGL.x86_64 0:18.3.4-6.el7_7 will be updated
---> Package mesa-libEGL.x86_64 0:18.3.4-7.el7_8.1 will be an update
---> Package mesa-libGL.x86_64 0:18.3.4-6.el7_7 will be updated
---> Package mesa-libGL.x86_64 0:18.3.4-7.el7_8.1 will be an update
---> Package mesa-libgbm.x86_64 0:18.3.4-6.el7_7 will be updated
---> Package mesa-libgbm.x86_64 0:18.3.4-7.el7_8.1 will be an update
---> Package mesa-libglapi.x86_64 0:18.3.4-6.el7_7 will be updated
---> Package mesa-libglapi.x86_64 0:18.3.4-7.el7_8.1 will be an update
---> Package net-snmp-libs.x86_64 1:5.7.2-43.el7_7.3 will be updated
---> Package net-snmp-libs.x86_64 1:5.7.2-48.el7_8.1 will be an update
---> Package nodejs.x86_64 2:10.20.1-1nodesource will be updated
---> Package nodejs.x86_64 2:10.21.0-1nodesource will be an update
---> Package ntp.x86_64 0:4.2.6p5-29.el7.centos will be updated
---> Package ntp.x86_64 0:4.2.6p5-29.el7.centos.2 will be an update
---> Package ntpdate.x86_64 0:4.2.6p5-29.el7.centos will be updated
---> Package ntpdate.x86_64 0:4.2.6p5-29.el7.centos.2 will be an update
---> Package numactl-libs.x86_64 0:2.0.12-3.el7_7.1 will be updated
---> Package numactl-libs.x86_64 0:2.0.12-5.el7 will be an update
---> Package pam.x86_64 0:1.1.8-22.el7 will be updated
---> Package pam.x86_64 0:1.1.8-23.el7 will be an update
---> Package parted.x86_64 0:3.1-31.el7 will be updated
---> Package parted.x86_64 0:3.1-32.el7 will be an update
---> Package passwd.x86_64 0:0.79-5.el7 will be updated
---> Package passwd.x86_64 0:0.79-6.el7 will be an update
---> Package perl.x86_64 4:5.16.3-294.el7_6 will be updated
---> Package perl.x86_64 4:5.16.3-295.el7 will be an update
---> Package perl-ExtUtils-Install.noarch 0:1.58-294.el7_6 will be updated
---> Package perl-ExtUtils-Install.noarch 0:1.58-295.el7 will be an update
---> Package perl-IO-Zlib.noarch 1:1.10-294.el7_6 will be updated
---> Package perl-IO-Zlib.noarch 1:1.10-295.el7 will be an update
---> Package perl-Package-Constants.noarch 1:0.02-294.el7_6 will be updated
---> Package perl-Package-Constants.noarch 1:0.02-295.el7 will be an update
---> Package perl-Pod-Escapes.noarch 1:1.04-294.el7_6 will be updated
---> Package perl-Pod-Escapes.noarch 1:1.04-295.el7 will be an update
---> Package perl-Socket.x86_64 0:2.010-4.el7 will be updated
---> Package perl-Socket.x86_64 0:2.010-5.el7 will be an update
---> Package perl-devel.x86_64 4:5.16.3-294.el7_6 will be updated
---> Package perl-devel.x86_64 4:5.16.3-295.el7 will be an update
---> Package perl-libs.x86_64 4:5.16.3-294.el7_6 will be updated
---> Package perl-libs.x86_64 4:5.16.3-295.el7 will be an update
---> Package perl-macros.x86_64 4:5.16.3-294.el7_6 will be updated
---> Package perl-macros.x86_64 4:5.16.3-295.el7 will be an update
---> Package perl-version.x86_64 3:0.99.07-3.el7 will be updated
---> Package perl-version.x86_64 3:0.99.07-6.el7 will be an update
---> Package pgdg-redhat-repo.noarch 0:42.0-9 will be updated
---> Package pgdg-redhat-repo.noarch 0:42.0-11 will be an update
---> Package php-imap.x86_64 0:5.4.16-9.el7 will be updated
---> Package php-imap.x86_64 0:5.4.45-18.el7.remi will be an update
---> Package policycoreutils.x86_64 0:2.5-33.el7 will be updated
---> Package policycoreutils.x86_64 0:2.5-34.el7 will be an update
---> Package policycoreutils-python.x86_64 0:2.5-33.el7 will be updated
---> Package policycoreutils-python.x86_64 0:2.5-34.el7 will be an update
---> Package polkit.x86_64 0:0.112-22.el7_7.1 will be updated
---> Package polkit.x86_64 0:0.112-26.el7 will be an update
---> Package postgresql-libs.x86_64 0:9.2.24-2.el7_7 will be updated
---> Package postgresql-libs.x86_64 0:9.2.24-4.el7_8 will be an update
---> Package postgresql12.x86_64 0:12.2-2PGDG.rhel7 will be updated
---> Package postgresql12.x86_64 0:12.3-5PGDG.rhel7 will be an update
---> Package postgresql12-contrib.x86_64 0:12.2-2PGDG.rhel7 will be updated
---> Package postgresql12-contrib.x86_64 0:12.3-5PGDG.rhel7 will be an update
---> Package postgresql12-libs.x86_64 0:12.2-2PGDG.rhel7 will be updated
---> Package postgresql12-libs.x86_64 0:12.3-5PGDG.rhel7 will be an update
---> Package postgresql12-server.x86_64 0:12.2-2PGDG.rhel7 will be updated
---> Package postgresql12-server.x86_64 0:12.3-5PGDG.rhel7 will be an update
---> Package procps-ng.x86_64 0:3.3.10-26.el7_7.1 will be updated
---> Package procps-ng.x86_64 0:3.3.10-27.el7 will be an update
---> Package python.x86_64 0:2.7.5-86.el7 will be updated
---> Package python.x86_64 0:2.7.5-88.el7 will be an update
---> Package python-firewall.noarch 0:0.6.3-2.el7_7.4 will be updated
---> Package python-firewall.noarch 0:0.6.3-8.el7_8.1 will be an update
---> Package python-libs.x86_64 0:2.7.5-86.el7 will be updated
---> Package python-libs.x86_64 0:2.7.5-88.el7 will be an update
---> Package python-perf.x86_64 0:3.10.0-1062.18.1.el7 will be updated
---> Package python-perf.x86_64 0:3.10.0-1127.13.1.el7 will be an update
---> Package python-urlgrabber.noarch 0:3.10-9.el7 will be updated
---> Package python-urlgrabber.noarch 0:3.10-10.el7 will be an update
---> Package python3.x86_64 0:3.6.8-10.el7 will be updated
---> Package python3.x86_64 0:3.6.8-13.el7 will be an update
---> Package python3-libs.x86_64 0:3.6.8-10.el7 will be updated
---> Package python3-libs.x86_64 0:3.6.8-13.el7 will be an update
---> Package python36-PyYAML.x86_64 0:3.12-1.el7 will be updated
---> Package python36-PyYAML.x86_64 0:3.13-1.el7 will be an update
---> Package python36-pysocks.noarch 0:1.6.8-6.el7 will be updated
---> Package python36-pysocks.noarch 0:1.6.8-7.el7 will be an update
---> Package python36-six.noarch 0:1.12.0-1.el7 will be updated
---> Package python36-six.noarch 0:1.14.0-2.el7 will be an update
---> Package redis.x86_64 0:5.0.8-1.el7.remi will be updated
---> Package redis.x86_64 0:6.0.5-1.el7.remi will be an update
---> Package rpm.x86_64 0:4.11.3-40.el7 will be updated
---> Package rpm.x86_64 0:4.11.3-43.el7 will be an update
---> Package rpm-build.x86_64 0:4.11.3-40.el7 will be updated
---> Package rpm-build.x86_64 0:4.11.3-43.el7 will be an update
---> Package rpm-build-libs.x86_64 0:4.11.3-40.el7 will be updated
---> Package rpm-build-libs.x86_64 0:4.11.3-43.el7 will be an update
---> Package rpm-libs.x86_64 0:4.11.3-40.el7 will be updated
---> Package rpm-libs.x86_64 0:4.11.3-43.el7 will be an update
---> Package rpm-python.x86_64 0:4.11.3-40.el7 will be updated
---> Package rpm-python.x86_64 0:4.11.3-43.el7 will be an update
---> Package rsync.x86_64 0:3.1.2-6.el7_6.1 will be updated
---> Package rsync.x86_64 0:3.1.2-10.el7 will be an update
---> Package rsyslog.x86_64 0:8.24.0-41.el7_7.4 will be updated
---> Package rsyslog.x86_64 0:8.24.0-52.el7_8.2 will be an update
---> Package sed.x86_64 0:4.2.2-5.el7 will be updated
---> Package sed.x86_64 0:4.2.2-6.el7 will be an update
---> Package selinux-policy.noarch 0:3.13.1-252.el7_7.6 will be updated
---> Package selinux-policy.noarch 0:3.13.1-266.el7 will be an update
---> Package selinux-policy-targeted.noarch 0:3.13.1-252.el7_7.6 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-266.el7 will be an update
---> Package setup.noarch 0:2.8.71-10.el7 will be updated
---> Package setup.noarch 0:2.8.71-11.el7 will be an update
---> Package sg3_utils.x86_64 0:1.37-18.el7_7.2 will be updated
---> Package sg3_utils.x86_64 1:1.37-19.el7 will be an update
---> Package sg3_utils-libs.x86_64 0:1.37-18.el7_7.2 will be updated
---> Package sg3_utils-libs.x86_64 1:1.37-19.el7 will be an update
---> Package shared-mime-info.x86_64 0:1.8-4.el7 will be updated
---> Package shared-mime-info.x86_64 0:1.8-5.el7 will be an update
---> Package smartmontools.x86_64 1:7.0-1.el7_7.1 will be updated
---> Package smartmontools.x86_64 1:7.0-2.el7 will be an update
---> Package sudo.x86_64 0:1.8.23-4.el7_7.2 will be updated
---> Package sudo.x86_64 0:1.8.23-9.el7 will be an update
---> Package systemd.x86_64 0:219-67.el7_7.4 will be updated
---> Package systemd.x86_64 0:219-73.el7_8.6 will be an update
---> Package systemd-libs.x86_64 0:219-67.el7_7.4 will be updated
---> Package systemd-libs.x86_64 0:219-73.el7_8.6 will be an update
---> Package systemd-sysv.x86_64 0:219-67.el7_7.4 will be updated
---> Package systemd-sysv.x86_64 0:219-73.el7_8.6 will be an update
---> Package systemtap-sdt-devel.x86_64 0:4.0-10.el7_7 will be updated
---> Package systemtap-sdt-devel.x86_64 0:4.0-11.el7 will be an update
---> Package teamd.x86_64 0:1.27-9.el7 will be updated
---> Package teamd.x86_64 0:1.29-1.el7 will be an update
---> Package tomcat-servlet-3.0-api.noarch 0:7.0.76-11.el7_7 will be updated
---> Package tomcat-servlet-3.0-api.noarch 0:7.0.76-12.el7_8 will be an update
---> Package tuned.noarch 0:2.11.0-5.el7_7.1 will be updated
---> Package tuned.noarch 0:2.11.0-8.el7 will be an update
---> Package tzdata.noarch 0:2019c-1.el7 will be updated
---> Package tzdata.noarch 0:2020a-1.el7 will be an update
---> Package tzdata-java.noarch 0:2019c-1.el7 will be updated
---> Package tzdata-java.noarch 0:2020a-1.el7 will be an update
---> Package unbound.x86_64 0:1.6.6-1.el7 will be updated
---> Package unbound.x86_64 0:1.6.6-5.el7_8 will be an update
---> Package unbound-libs.x86_64 0:1.6.6-1.el7 will be updated
---> Package unbound-libs.x86_64 0:1.6.6-5.el7_8 will be an update
---> Package unzip.x86_64 0:6.0-20.el7 will be updated
---> Package unzip.x86_64 0:6.0-21.el7 will be an update
---> Package util-linux.x86_64 0:2.23.2-61.el7_7.1 will be updated
---> Package util-linux.x86_64 0:2.23.2-63.el7 will be an update
---> Package xinetd.x86_64 2:2.3.15-13.el7 will be updated
---> Package xinetd.x86_64 2:2.3.15-14.el7 will be an update
---> Package yum.noarch 0:3.4.3-163.el7.centos will be updated
---> Package yum.noarch 0:3.4.3-167.el7.centos will be an update
---> Package yum-plugin-fastestmirror.noarch 0:1.1.31-52.el7 will be updated
---> Package yum-plugin-fastestmirror.noarch 0:1.1.31-54.el7_8 will be an update
---> Package yum-utils.noarch 0:1.1.31-52.el7 will be updated
---> Package yum-utils.noarch 0:1.1.31-54.el7_8 will be an update
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.7.8.9-18.el7 will be updated
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64
---> Package ImageMagick-libs.x86_64 0:6.9.11.22-1.el7.remi will be installed
--> Processing Dependency: libcdt.so.5()(64bit) for package: ImageMagick-libs-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libcgraph.so.6()(64bit) for package: ImageMagick-libs-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libgvc.so.6()(64bit) for package: ImageMagick-libs-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libraw_r.so.19()(64bit) for package: ImageMagick-libs-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libwebp.so.7()(64bit) for package: ImageMagick-libs-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libwebpdemux.so.2()(64bit) for package: ImageMagick-libs-6.9.11.22-1.el7.remi.x86_64
--> Processing Dependency: libwebpmux.so.3()(64bit) for package: ImageMagick-libs-6.9.11.22-1.el7.remi.x86_64
---> Package fftw-libs-double.x86_64 0:3.3.3-8.el7 will be installed
---> Package libprelude.x86_64 0:5.1.1-1.el7 will be installed
---> Package libraqm.x86_64 0:0.7.0-4.el7 will be installed
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.7.8.9-18.el7 will be updated
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64
---> Package LibRaw.x86_64 0:0.19.4-1.el7 will be installed
---> Package graphviz.x86_64 0:2.30.1-21.el7 will be installed
--> Processing Dependency: libXaw.so.7()(64bit) for package: graphviz-2.30.1-21.el7.x86_64
---> Package libwebp7.x86_64 0:1.0.3-1.el7.remi will be installed
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.7.8.9-18.el7 will be updated
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64
---> Package libXaw.x86_64 0:1.0.13-4.el7 will be installed
--> Finished Dependency Resolution
Error: Package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64 (@PLESK_17_PHP73)
           Requires: libMagickWand.so.5()(64bit)
           Removendo: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickWand.so.5()(64bit)
           Updated By: ImageMagick-6.9.11.22-1.el7.remi.x86_64 (remi)
               Not found
Error: Package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64 (@PLESK_17_PHP70)
           Requires: libMagickWand.so.5()(64bit)
           Removendo: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickWand.so.5()(64bit)
           Updated By: ImageMagick-6.9.11.22-1.el7.remi.x86_64 (remi)
               Not found
Error: Package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64 (@PLESK_17_PHP56)
           Requires: libMagickWand.so.5()(64bit)
           Removendo: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickWand.so.5()(64bit)
           Updated By: ImageMagick-6.9.11.22-1.el7.remi.x86_64 (remi)
               Not found
Error: Package: plesk-php73-imagick-3.4.3-1centos.7.190906.1643.x86_64 (@PLESK_17_PHP73)
           Requires: libMagickCore.so.5()(64bit)
           Removendo: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickCore.so.5()(64bit)
           Updated By: ImageMagick-6.9.11.22-1.el7.remi.x86_64 (remi)
               Not found
Error: Package: plesk-php70-imagick-3.4.3-centos7.18021515.x86_64 (@PLESK_17_PHP70)
           Requires: libMagickCore.so.5()(64bit)
           Removendo: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickCore.so.5()(64bit)
           Updated By: ImageMagick-6.9.11.22-1.el7.remi.x86_64 (remi)
               Not found
Error: Package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64 (@PLESK_17_PHP71)
           Requires: libMagickCore.so.5()(64bit)
           Removendo: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickCore.so.5()(64bit)
           Updated By: ImageMagick-6.9.11.22-1.el7.remi.x86_64 (remi)
               Not found
Error: Package: plesk-php56-imagick-3.1.2-centos7.18010913.x86_64 (@PLESK_17_PHP56)
           Requires: libMagickCore.so.5()(64bit)
           Removendo: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickCore.so.5()(64bit)
           Updated By: ImageMagick-6.9.11.22-1.el7.remi.x86_64 (remi)
               Not found
Error: Package: plesk-php71-imagick-3.4.3-1centos.7.190626.1727.x86_64 (@PLESK_17_PHP71)
           Requires: libMagickWand.so.5()(64bit)
           Removendo: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickWand.so.5()(64bit)
           Updated By: ImageMagick-6.9.11.22-1.el7.remi.x86_64 (remi)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
What should I do? :?

User avatar
remirepo
Posts: 390
Joined: 2014/09/21 09:07:12
Location: France
Contact:

Re: How do I fix this broken dependencies?

Post by remirepo » 2020/07/03 10:11:49

Ask plesk support, looks like they are not ready for 7.10 which have updated ImageMagick with a soname bump to 6.
(and you can disable "remi" repository if you use php from plesk repository)
Remi's Repository - Forum - Blog

Post Reply

Return to “CentOS 7 - General Support”