Page 1 of 1

BOot issues on CentOS 7.7

Posted: 2020/06/26 21:00:49
by nishikant
Hello Friends!

I had CentOS 6.4 installed in about 2015 on a Windows 7 Pro 64 bit system (edited for dual boot) about 3 months back
About 3 months back, I overwrote my Linux partition with CentOS 7.7
I was told by the friend who helped me setup the original centOS 6.4 that there may be issues updating from 6 to 7.
Unfortunately, he does not have any idea for this problem, so I am requesting you for help.
My system details (When I installed CentOS 7.7)

Board: MSI 990 FXA-GD65 Version 2
BIOS: E7640AMS V20.3
CPU: AMD FX-6300 Hex-core
MEM: 2x8GB, 1866MHz HyperX
GPU: nvidia Quadro K600
HDD/SSD: 1x Kingston SSD 120 GB + 1x 640 GB HDD

The 120 GB SSD is partitioned in 3 (60 GB Windows C. 30 GB Windows D, and a 30 GB Linux partition)
I did not have the 640 GB HDD when the computer was assembled and setup, so had used above partition scheme.

Since I wanted to be using the best drivers available for the device, I went ahead and got rid of the nouveau Drivers of CentOS and replaced them with the NVidia Drivers.

Unfortunately, about 2 weeks back when I tried to run my desktop, I realized that my Nvidia card is toast.
How do I know?
I have used both ports (DVI and Display port) to try and connect to working monitor/TV, but the card doesn't work.

Eventually, I retrieved an MSI Radeon HD 5670 card from my old 2010 desktop and tried to boot.
This Radeon card does work BUT only in Windows 7.
In the grub choices when I use CentOS 7, I do not reach login page.

Instead I get a bunch of text and the screen freezes. Here is the screenshot.
lasr message-centos.jpeg
lasr message-centos.jpeg (104.71 KiB) Viewed 238 times
As you may be able to see, there is nothing to do, and the screen remains static, I have to physically reboot the system (and ensure that Windows is selected).

Kindly suggest what I can do to get back my login page.


Re: BOot issues on CentOS 7.7

Posted: 2020/06/26 23:32:20
by TrevorH
Boot up, use ctrl-alt-F2 to switch to a cli terminal, login as root, uninstall your nvidia drivers, possibly rename or delete /etc/X11/xorg.conf and reboot.

Re: BOot issues on CentOS 7.7

Posted: 2020/06/27 05:37:10
by nishikant
Thankyou, @TrevorH
I will try and let you know!
Best regards,

Re: BOot issues on CentOS 7.7

Posted: 2020/06/28 15:17:39
by nishikant
Thanks, @TrevorH!
My issue is now sorted. I made some mistakes, but I learnt along the way! :D

To others who may want to uninstall nvidia drivers due to new non-nvidia card:

you have to run the original nvidia installer you used for installation, only with the -uninstall option at the end.
I said yes to the message you get when u are asked about retrieving xconfig file X window.

Prior to that, you need to have the installer on a USB folder which needs to be mounted or maybe download it in console mode to an accessible location from your linux root.

I expected to reverse my step of blacklisting nouveau drivers (done during installation of proprietary nvidia drivers), but I think because of the Yes to the message during un-installation, I got through and a simple reboot yielded my login page.

For those interested, relevant RHEL page is also available, you need to have a subscription to access:

Happy CentOS journey!