2 node cluster patching, after patch we are getting version difference

General support questions
Post Reply
rahulbhardwaj29_87
Posts: 1
Joined: 2020/06/24 09:21:07

2 node cluster patching, after patch we are getting version difference

Post by rahulbhardwaj29_87 » 2020/06/24 09:42:35

Hi Team, I have patch CentOS VM Hosted on Azure Cloud PF. I have patched both servers in same day & with Same Repo's.

Got approx. 36 CentOS patches difference, here I want to ask why this is So happened as well are these packages make any difference for Servers.
Could you please confirm what could be possible reason behind it.

Major difference related to Kernel:
kernel-3.10.0-1127.10.1.el7.x86_64 kernel-3.10.0-1127.el7.x86_64 ??
Please confirm both are same kernel ?


Package in VM01 Package in VM02
------------------------------------------------- -------------------------------------------------
augeas-libs-1.4.0-9.el7_8.1.x86_64 augeas-libs-1.4.0-9.el7_7.1.x86_64
auoms-2.1.7-0.x86_64 auoms-2.0.1-19.x86_64
bind-export-libs-9.11.4-16.P2.el7_8.6.x86_64 bind-export-libs-9.11.4-16.P2.el7_8.2.x86_64
bind-libs-9.11.4-16.P2.el7_8.6.x86_64 bind-libs-9.11.4-16.P2.el7_8.2.x86_64
bind-libs-lite-9.11.4-16.P2.el7_8.6.x86_64 bind-libs-lite-9.11.4-16.P2.el7_8.2.x86_64
bind-license-9.11.4-16.P2.el7_8.6.noarch bind-license-9.11.4-16.P2.el7_8.2.noarch
bind-utils-9.11.4-16.P2.el7_8.6.x86_64 bind-utils-9.11.4-16.P2.el7_8.2.x86_64
binutils-2.27-43.base.el7_8.1.x86_64 binutils-2.27-43.base.el7.x86_64
device-mapper-1.02.164-7.el7_8.2.x86_64 device-mapper-1.02.164-7.el7_8.1.x86_64
device-mapper-event-1.02.164-7.el7_8.2.x86_64 device-mapper-event-1.02.164-7.el7_8.1.x86_64
device-mapper-event-libs-1.02.164-7.el7_8.2.x86_64 device-mapper-event-libs-1.02.164-7.el7_8.1.x86_64
device-mapper-libs-1.02.164-7.el7_8.2.x86_64 device-mapper-libs-1.02.164-7.el7_8.1.x86_64
kernel-3.10.0-1127.10.1.el7.x86_64 kernel-3.10.0-1127.el7.x86_64
kernel-devel-3.10.0-1127.10.1.el7.x86_64 kernel-devel-3.10.0-1127.el7.x86_64
kernel-headers-3.10.0-1127.10.1.el7.x86_64 kernel-headers-3.10.0-1127.el7.x86_64
kernel-tools-3.10.0-1127.10.1.el7.x86_64 kernel-tools-3.10.0-1127.el7.x86_64
kernel-tools-libs-3.10.0-1127.10.1.el7.x86_64 kernel-tools-libs-3.10.0-1127.el7.x86_64
libsss_idmap-1.16.4-37.el7_8.3.x86_64 libsss_idmap-1.16.4-37.el7.x86_64
libsss_nss_idmap-1.16.4-37.el7_8.3.x86_64 libsss_nss_idmap-1.16.4-37.el7.x86_64
libwbclient-4.10.4-11.el7_8.x86_64 libwbclient-4.10.4-10.el7.x86_64
lvm2-2.02.186-7.el7_8.2.x86_64 lvm2-2.02.186-7.el7_8.1.x86_64
lvm2-libs-2.02.186-7.el7_8.2.x86_64 lvm2-libs-2.02.186-7.el7_8.1.x86_64
microcode_ctl-2.1-61.6.el7_8.x86_64 microcode_ctl-2.1-61.el7.x86_64
omsagent-1.13.7-0.x86_64 omsagent-1.12.15-0.x86_64
omsconfig-1.1.1-930.x86_64 omsconfig-1.1.1-927.x86_64
python-perf-3.10.0-1127.10.1.el7.x86_64 python-perf-3.10.0-1127.el7.x86_64
samba-client-libs-4.10.4-11.el7_8.x86_64 samba-client-libs-4.10.4-10.el7.x86_64
samba-common-4.10.4-11.el7_8.noarch samba-common-4.10.4-10.el7.noarch
samba-common-libs-4.10.4-11.el7_8.x86_64 samba-common-libs-4.10.4-10.el7.x86_64
samba-libs-4.10.4-11.el7_8.x86_64 samba-libs-4.10.4-10.el7.x86_64
sos-3.8-8.el7.centos.noarch sos-3.8-6.el7.centos.noarch
sssd-client-1.16.4-37.el7_8.3.x86_64 sssd-client-1.16.4-37.el7.x86_64
systemd-219-73.el7_8.6.x86_64 systemd-219-73.el7_8.5.x86_64
systemd-libs-219-73.el7_8.6.x86_64 systemd-libs-219-73.el7_8.5.x86_64
systemd-python-219-73.el7_8.6.x86_64 systemd-python-219-73.el7_8.5.x86_64
systemd-sysv-219-73.el7_8.6.x86_64 systemd-sysv-219-73.el7_8.5.x86_64
yum-plugin-fastestmirror-1.1.31-54.el7_8.noarch yum-plugin-fastestmirror-1.1.31-53.el7.noarch
yum-utils-1.1.31-54.el7_8.noarch yum-utils-1.1.31-53.el7.noarch
lad-mdsd-1.5.109-LADmaster.101.x86_64

User avatar
TrevorH
Forum Moderator
Posts: 28827
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: 2 node cluster patching, after patch we are getting version difference

Post by TrevorH » 2020/06/24 09:49:23

Apparently one of your 2 systems is pointing at an out of date mirror. All those packages are out of date and need to be updated. Check if you have the 'updates' repo enabled on the out of date system as, for example, kernel-3.10.0-1127.el7.x86_64 is the original kernel from the 'base' repo and kernel-3.10.0-1127.10.1.el7.x86_64 is from the 'updates' repo (also that's now out of date as 3.10.0-1127.13.1.el7 was released yesterday).
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
jlehtone
Posts: 2866
Joined: 2007/12/11 08:17:33
Location: Finland

Re: 2 node cluster patching, after patch we are getting version difference

Post by jlehtone » 2020/06/24 10:23:12

You could run these on both servers:

Code: Select all

sudo yum --enablerepo=* clean all
sudo yum repolist
Do the lists of repositories differ?

Post Reply

Return to “CentOS 7 - General Support”