Page 1 of 1

Postfix 'error: unsupported dictionary type: hash'

Posted: 2020/06/22 22:11:00
by seyamak
Hi All,

New to this site. I need to make my postfix work without an error. I am getting the following error. Mail goes through fine but I don't want to get this message.

error: unsupported dictionary type: hash

I do not have hash defined below when I run postconf -m

postconf -m
cidr
environ
fail
inline
internal
memcache
nis
pcre
pipemap
proxy
randmap
regexp
socketmap
static
tcp
texthash
unionmap
unix

Any suggestion would be appreciated.

Re: Postfix 'error: unsupported dictionary type: hash'

Posted: 2020/06/22 22:16:48
by TrevorH
What is the output from rpm -q postfix and from rpm -qf $(which postfix)

Re: Postfix 'error: unsupported dictionary type: hash'

Posted: 2020/06/22 22:39:36
by seyamak
I built the server from source code but here is my postfix version.

postconf mail_version
mail_version = 3.5.2

Re: Postfix 'error: unsupported dictionary type: hash'

Posted: 2020/06/23 05:35:04
by KernelOops
You are missing some modules, for example: btree and hash

Maybe you need to enable them and recompile postfix?

Re: Postfix 'error: unsupported dictionary type: hash'

Posted: 2020/06/23 08:32:45
by TrevorH
We do not support building from source. Most especially we do not support building things from source that we already supply. To get a working and correct copy of postfix all you need to do is yum install postfix

What is the point in using a stable distribution if you do not want to use the packages it supplies. If you want to build it all yourself then install gentoo.