[SOLVED]Skype stopped working

General support questions
Post Reply
aussie
Posts: 74
Joined: 2018/06/30 12:21:31

[SOLVED]Skype stopped working

Post by aussie » 2020/04/07 09:17:08

Hello,

I had a failed yum update and had to delete the kernel and reinstall. Also had to reinstall several modules to get the display timeout to work again. Anyway Skype stopped working.
I have applied the fix: chmod 4755 chrome-sandbox
This is the error from the Skype startup log
[1m[47m[31mA JavaScript error occurred in the main process
[30mUncaught Exception:
Error: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-utility/build/Release/electron_utility.node)
I have tried to install libstdc++ but yum says it is already installed and the latest version.
Package libstdc++-4.8.5-39.el7.x86_64 already installed and latest version
Package libstdc++-4.8.5-39.el7.i686 already installed and latest version

Does anyone have an idea what is wrong?

Aussie
Last edited by aussie on 2020/04/07 12:09:13, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 29159
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Skype stopped working

Post by TrevorH » 2020/04/07 10:36:42

Yes, MS broke it, complain to them. They have built the latest version to require a newer glibc than we ship. The chances of that changing are nil so either MS fix it or it stays broken. In the meantime you will need to yum downgrade skypeforlinux-8.56.0.103-1.x86_64 which is the last working version.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

aussie
Posts: 74
Joined: 2018/06/30 12:21:31

Re: Skype stopped working

Post by aussie » 2020/04/07 11:00:57

Hi TrevorH,

Yes, that fixed it! Many thanks.

Aussie

jalim_singh
Posts: 29
Joined: 2014/02/08 12:06:00

Re: [SOLVED]Skype stopped working

Post by jalim_singh » 2020/06/13 02:05:27

Hi
I am also getting the same error after update. Can you give the link for downloading skypeforlinux-8.56.0.103-1.x86_64.

Thanks

User avatar
WhatsHisName
Posts: 1547
Joined: 2005/12/19 20:21:43
Location: /earth/usa/nj

Re: [SOLVED]Skype stopped working

Post by WhatsHisName » 2020/06/13 02:53:55

This may be sacrilege, but I moved to flatpak skype a couple of months ago out of frustration.

https://flathub.org/apps/details/com.skype.Client

Have updated Skype twice with no problems. You likely already have flatpak installed.

Code: Select all

Install Flatpak:

 # yum install flatpak

Add Flathub:

 # flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

List installed apps:

 # flatpak list

Install Skype:

 # flatpak install flathub com.skype.Client/x86_64/stable

Launch Skype (using cli or panel launcher):

 $ flatpak run com.skype.Client
 
  (Paste that into a gnome laucher for ease)
  (You can find an icon under /var/lib/flatpak/app/com.skype.Client/current/active/export/share/icons/hicolor/)
  
Update Skype:

 # flatpak update com.skype.Client/x86_64/stable

Remove Skype:

 # flatpak uninstall  com.skype.Client/x86_64/stable

I also installed Audacity (audio editor), Avidemux (video editor) and Bluefish (program/web editor) from flathub.

There are many other options there: https://flathub.org/home

jalim_singh
Posts: 29
Joined: 2014/02/08 12:06:00

Re: [SOLVED]Skype stopped working

Post by jalim_singh » 2020/06/13 04:06:02

Thank you!
It worked for me also.

Post Reply

Return to “CentOS 7 - General Support”