Page 1 of 1

Unable to boot second raid disk from EFI

Posted: 2020/02/11 11:01:09
by sergiopasra
Hi there!

I manage a Dell Optiplex 790 machine, with Centos 7.7.1908, with two disks in raid1 and efi boot.

I know that the EFI partition can't be in RAID, so I have a dedicated partition in each disk: /dev/sda1 and /dev/sdb1 Both partitions are FAT32

I have copied the contents of /dev/sda1 into /dev/sdb1

I have added a pair of new boot entries on EFI with:

efibootmgr -c -d /dev/sda -p 1 -L "CentOS disk1" --loader "\EFI\centos\grubx64.efi"

efibootmgr -c -d /dev/sdb -p 1 -L "CentOS disk2" --loader "\EFI\centos\grubx64.efi"

I have already a centos entry, identical to the first one.

Now, from the EFI menu, "CentOS disk1" boots into GRUB normally, but "CentOS disk2" gives my a blank screen.
If I hit ESC in this blank screen I see a blinking cursor. No GRUB

AFAICS, the contents of /dev/sda1 and /dev/sdb1 are identical. efibootmgr -v reports similar entries for both disks, but one boots and the other doesn't

# efibootmgr -v
BootCurrent: 0007
Timeout: 1 seconds
BootOrder: 0000,0001,0003,0004,0005,000A,0007,0006,0002
Boot0000* Diskette Drive BBS(Floppy,,0x0)
Boot0001* P0: ST1000DM003-1SB102 BBS(HD,,0x0)P0: ST1000DM003-1SB102 .
Boot0002* centos HD(1,GPT,8cbaa92e-6cec-41e1-9efa-3ef6b8474085,0x800,0x64000)/File(\EFI\centos\grubx64.efi)
Boot0003* USB Storage Device BBS(USB,,0x0)
Boot0004* CD/DVD/CD-RW Drive BBS(CDROM,,0x0)P1: TSSTcorp DVD+/-RW SH-216AB.
Boot0005* Onboard NIC BBS(Network,,0x0)IBA GE Slot 00C8 v1376.
Boot0006* CentOS disk2 HD(1,GPT,c9f1bc08-8ff9-4463-95ef-722689c3908a,0x800,0x64000)/File(\EFI\centos\grubx64.efi)
Boot0007* CentOS disk1 HD(1,GPT,8cbaa92e-6cec-41e1-9efa-3ef6b8474085,0x800,0x64000)/File(\EFI\centos\grubx64.efi)
Boot000A* P2: ST4000DM004-2CV104 BBS(HD,,0x0)P2: ST4000DM004-2CV104

My added entries are Boot0006 and Boot0007. The UUIDs of the partitions are correct. What am I missing?


[SOLVED] Re: Unable to boot second raid disk from EFI

Posted: 2020/02/14 09:45:28
by sergiopasra
I have fixed the problem. For future reference, the difference between the two disks was the "Name" of the EFI partition. With parted, the partition layout for the functional disk was:

Number Start End Size File system Name Flags
1 1049kB 211MB 210MB fat16 EFI System Partition boot
2 211MB 1285MB 1074MB raid

And the other was

Number Start End Size File system Name Flags
1 1049kB 211MB 210MB fat16 boot
2 211MB 1285MB 1074MB raid

So I added the Name field to the partition in the second disk and now it works