Local Repository Issue

General support questions
Post Reply
Krishnapriya
Posts: 1
Joined: 2020/02/07 06:19:21

Local Repository Issue

Post by Krishnapriya » 2020/02/07 06:45:44

Hello,

I have created a local repository server for centos7 and it is working fine,
when i have installed any package via that local repo in client machine it is installed via that local repo after running the command yum info package_name i have got the confirmation,
But after updating the client via local repo then all the base repo files are showing up and further packages are installed via base repo.

Please let us know what should i do.

User avatar
TrevorH
Forum Moderator
Posts: 27727
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Local Repository Issue

Post by TrevorH » 2020/02/07 17:54:05

Where are you expecting to get updates to the rest of your system if not from base/updates? Or do you mean that your own repo is a local mirror of the CentOS base/updates ones that you would prefer to use instead? If so then do not delete the files in /etc/yum.repos.d that define those as an update to the centos-release package will put them back if the files are missing. If you edit them and set 'enabled=0' then they show as modified and yum will not replace them but create .rpmnew files instead.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - General Support”