Radius Authentication phpIPAM with Centos7

General support questions
Post Reply
seckinever
Posts: 1
Joined: 2020/01/06 11:50:10

Radius Authentication phpIPAM with Centos7

Post by seckinever » 2020/01/06 11:52:11

I have setup phpIPAM on Centos 7 and that is working fine but I need to join the webpage for phpIPAM to RADIUS. I have set up a user in IPAM, made it into a user group and setup RADIUS settings, on my RADIUS server.

I have set up a user also, but every time I try to login to the webpage with my AD account, it suddenly shows incorrect username or password. In the firewall logs, I do not see any attempt, in my event viewer at the radius server, I do not see any attempt.

Is there anyone who has faced a similar problem or have setup RADIUS for IPAM?

User avatar
TrevorH
Forum Moderator
Posts: 29171
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Radius Authentication phpIPAM with Centos7

Post by TrevorH » 2020/01/06 15:05:52

A wild guess, if you think your config is correct and should work then try running setenforce 0 as root then retry and see if the issue is fixed. If it is then you've been caught by selinux and the details of how/why will be in the audit log. Use aureport -a to show a list of the denials and get details by using ausearch -a nnnn where nnnn is the number from the righthand end of each line of the aureport -a output.

Oh, and first step is probably to look at the selinux booleans like httpd_can_network_connect
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - General Support”