A start job is running for dev-mapper-centos\x2droot.device

General support questions
rohan7
Posts: 14
Joined: 2019/11/13 11:45:34

Re: A start job is running for dev-mapper-centos\x2droot.device

Post by rohan7 » 2019/11/13 14:24:15

Thanks for that info Trevor. So is there no way for me to boot into the system currently and to backup data/config files from it. Rebuilding a server is not an issue but I am wearing thin on time tbh.

User avatar
TrevorH
Forum Moderator
Posts: 27426
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: A start job is running for dev-mapper-centos\x2droot.device

Post by TrevorH » 2019/11/13 14:30:07

From emergency mode you should be able to do things like activate LVM VGs and LVs and mount them. If it just the array name that has changed then look in /etc/fstab on the now-mounted filesystem that contains your real /etc and see what it's being told to mount. Also look at your grub.cfg as the name may be in the kernel/initrd lines there too.

I am a bit concerned that your lsblk only seems to list sda and sdb and that they have no partitions on them.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

rohan7
Posts: 14
Joined: 2019/11/13 11:45:34

Re: A start job is running for dev-mapper-centos\x2droot.device

Post by rohan7 » 2019/11/13 15:10:02

I seem to be at lost. I cant get to grub.cfg file as from emergency mode there is no /boot directory. And there is no fstab in /etc. There is just fstab.empty.

cat /proc/mdstat gives personalities:
unused: <none>

rohan7
Posts: 14
Joined: 2019/11/13 11:45:34

Re: A start job is running for dev-mapper-centos\x2droot.device

Post by rohan7 » 2019/11/13 16:27:31

So I have finally decided to rebuild the server. Thanks for all the help so far.

rohan7
Posts: 14
Joined: 2019/11/13 11:45:34

Re: A start job is running for dev-mapper-centos\x2droot.device

Post by rohan7 » 2019/11/14 09:31:05

UPDATE: Looks like the BIOS defaulted on settings maybe due to a dead motherboard battery? However, changed the BOOT options to RAID and can boot into the OS fine now. Did not have to rebuild the server.
Can mark this topic as solved.


interigi
Posts: 4
Joined: 2019/11/20 13:27:44

Re: A start job is running for dev-mapper-centos\x2droot.device

Post by interigi » 2020/01/09 18:29:05

It turned out only through server recovery?

Post Reply

Return to “CentOS 7 - General Support”