Page 1 of 1

python conflicts on 7.6 -> 7.7 upgrade

Posted: 2019/09/26 21:42:53
by noien
I recently upgraded my desktop from 7.6 to 7.7. When I run yum upgrade, I'm getting messages about file conflicts in python :

Code: Select all

Transaction check error:
  file /usr/bin/pip3.6 from install of python3-pip-9.0.3-5.el7.noarch conflicts with file from package python36u-pip-9.0.1-1.ius.el7.noarch
  file /usr/share/bash-completion/completions/pip3.6 from install of python3-pip-9.0.3-5.el7.noarch conflicts with file from package python36u-pip-9.0.1-1.ius.el7.noarch
  file /usr/lib/python3.6/site-packages/pip/__init__.py from install of python3-pip-9.0.3-5.el7.noarch conflicts with file from package python36u-pip-9.0.1-1.ius.el7.noarch
I truncated that output, it's quite verbose. You can see the output of yum upgrade -y in full at :
http://netdrms01.nispdc.nso.edu/oien/yu ... nus_y.html
I suspect I've wound up with repos enabled that I don't now want, but how can I tell what's conflicting so I can get rid of the now unwanted ones?

Thanks,

Niles.

Re: python conflicts on 7.6 -> 7.7 upgrade

Posted: 2019/09/27 04:44:47
by StevenD57
Just a wild stab in the dark but I would be tempted to remove all of the python36u packages and then re-install the newer python packages after the upgrade finishes successfully.

However you can also determine the repo where these packages came from by doing:
yum info python36u-pip-9.0.1-1.ius.el7.noarch | grep "From repo"

Re: python conflicts on 7.6 -> 7.7 upgrade

Posted: 2019/09/27 14:18:03
by noien
Thanks. I think what I'm seeing is a conflict between python3 from the base repo and python36u from the ius repo :

Code: Select all

[root@noiendesk ~]# yum info python36u-pip-9.0.1-1.ius.el7.noarch | grep "From repo"
From repo   : ius
[root@noiendesk ~]# yum info python3-pip-9.0.3-5.el7.noarch | grep Repo
Repo        : base/7/x86_64
It was a bit confusing to track down, the slightly different package name (python36u-pip from ius versus python3-pip from the base) confused me, but that's my ineptitude with yum as much as anything else.

I'm thinking that this is a new addition in the CentOS 7.7 that conflicts with the ius repo? In any event, it leaves me wondering if I should disable the ius repo or (less likely) take the package out of the base. Let me check with a user who has really delved into python on this system and see.

Thanks again,

Niles.

Re: python conflicts on 7.6 -> 7.7 upgrade

Posted: 2019/09/27 15:41:27
by noien
After thinking about it and talking to users, we decided to disable the IUS repo. First tested it by disabling it as part of the yum upgrade command :

Code: Select all

yum upgrade --disablerepo=ius
Then having established that that worked, permanently disabled the repo by editing /etc/yum.repos.d/ius.repo and setting the instance of enabled = 1 to 0.

On another server that had the issue, I didn't bother with the test, just permanently disabled the repo and upgraded, and that worked.