Page 1 of 1

Grey Screen during Install Of CentOS on VirtualBox

Posted: 2019/05/19 03:41:58
by dreafizz
I am trying to Install CentOS 7 on a VirtualBox for the first time on My HP Pavillion running Windows 10 home. I have Already ensured that the Bios Enabled Virtualization so that proper installation could occur as that was an original setback. Now it seems I am all ready to go, but whenever I go to actually start the Install I get stuck on a grey screen and it will go no further. Here is what I have done so far:
Created a new virtual machine with the following settings:

Name: CentoOS 7
Type: Linux
Version: Red Hat (64-bit)
Memory Size: I chose 2048MB
Hard Disk: VDI, Dynamically Allocated, Size – 20GB

Added the ISO Image to My New Virtual Machine

Went to start install...and bam Grey screen of foreverness! :cry:

Re: Grey Screen during Install Of CentOS on VirtualBox

Posted: 2019/05/22 06:42:26
by prabhakarpujeri
try with kernel command line parameter nomodeset

Re: Grey Screen during Install Of CentOS on VirtualBox

Posted: 2019/08/01 15:09:41
Same problem. Trying to install CentOS-7-x86_64-DVD-1810.iso on VirtualBox (Version 6.0.4).
Everything set to default. I run it and it shows a bootscreen, then goes to a light gray screen with a blinking white cursor.
I can't type and it usually freezes. I've been running Centos 7 on my PC for the past 4 months and I now it doesn't work.
I think the problem started when I set my PC's bios settings to default on accident. So it has to be something on my computers settings, maybe?
Also, this works on my laptop, and I have used the same settings on virtualbox when I go to install CentOS 7 but it doesn't work.

Things I've Done:
-Uninstalled and re-installed VirtualBox (both ver 6.0.4 and current ver)
-Deleted and re-downloaded Centos 7 ISO
-Enables virtualization in my BIOS settings

Re: Grey Screen during Install Of CentOS on VirtualBox

Posted: 2019/08/01 15:26:43
by TrevorH
Did you check the sha256sum of your downloaded file against the list in the CentOS 7.6 release notes on the wiki? How much RAM did you give your VM?

Re: Grey Screen during Install Of CentOS on VirtualBox

Posted: 2019/08/01 17:27:02
My download file is right. I've compared it to my working version on my laptop and everything with VirtualBox and the CentOS 7 file is correct. And I used the default amount of RAM, and then I've tested it at higher capacities of allocated RAM.

That means it has to be something wrong with my computer? Maybe a Windows 10 setting or something with my BIOS.

Re: Grey Screen during Install Of CentOS on VirtualBox

Posted: 2019/08/01 17:34:51
by TrevorH
The only way to tell if your download is correct is to sha256sum it and check. ... ntOS7.1810

I have no idea what the "default amount of RAM" is and it probably varies depending on how much you have installed on the host. You need to check it and see. The bare minimum required is 1280MB but 2GB is better.

Re: Grey Screen during Install Of CentOS on VirtualBox

Posted: 2019/09/22 12:18:30
by sane5ek
Hello! I ran into exactly the same problem.
My laptop HP Pavillion G6 2283-ER, Windows 10 pro system. The problem arose during the installation of the version at the current moment (although this is not important) CentOS-7-x86_64-Minimal-1908 (when installing the DVD version there was the same problem). Also, when indicating less than two processors, the cursor did not even blink on the gray screen.
After futile attempts to fix this (I checked the hash amount, turned on / off Hyper-V, checked and unchecked the settings of the virtual machine), I decided to try VMware Workstation.

With a similar installation, he told me the following:
"VMware Workstation and Device / Credential Guard are not compatible. VMware Workstation can be run after disabling Device / Credential Guard."

I went to google in search of a problem, and came across a video:

Here is translated instruction for you and other people that came accross this post:

1) Open the command line "WIN + R" and enter the command "gpedit.msc", click "OK".
2) In the window that opens, go to the section "Local Computer Policy - Computer Configuration - Administrative Templates - System - Device Guard".
Here, double-click on the item "Turn On Virtualization Based Security". In the window that opens, select the item "Disabled" and click "OK."
3) Go to "Control Panel - Programs and Features - Turn Windows Features on or off" and turn off Hyper-V and click "OK." The computer will offer to reboot - we refuse (we will reboot later).
4) Run the command line as administrator (cmd). On the command line, execute several commands in a row:

bcdedit / create {0cb3b571-2f2e-4343-a879-d86a476d7215} / d "DebugTool" / application osloader
Press "Enter"

bcdedit / set {0cb3b571-2f2e-4343-a879-d86a476d7215} path "\ EFI \ Microsoft \ Boot \ SecConfig.efi"
Press "Enter"

bcdedit / set {bootmgr} bootsequence {0cb3b571-2f2e-4343-a879-d86a476d7215}

Press "Enter"

bcdedit / set {0cb3b571-2f2e-4343-a879-d86a476d7215} loadoptions DISABLE-LSA-ISO, DISABLE-VBS
Press "Enter".

bcdedit / set hypervisorlaunchtype off
Press "Enter".

Reboot the computer.


That instruction helps me to ran and VMware Workstation, and VirtualBox. Before I did that, VirtualBox Centos 7 installation hung up even I pressed down/up arrows to choose Test Centos.

Re: Grey Screen during Install Of CentOS on VirtualBox

Posted: 2019/11/16 09:48:14
by fireball29de
I had the same problem and the solution from sane5ek worked for me too. But after reboot my Docker Installation complained with:
An error occured
Hardware assisted virtualization and data execution protection must be enabled in the BIOS. See ... be-enabled

Obviously the BIOS is not the problem, because it worked before and I did'n chaned the BIOS, so the question is, what are commands indeed doing, and how to get VirtualBox VMs and Docker running in parallel?

Thank you in advance