Page 3 of 3

Re: Centos 7 installation on Dell PE R410

Posted: 2019/05/19 19:02:36
by itzdaniel483
Okay I'll attempt to reinstall the OS on RAID 1. For some reason it shows the RAID 1 drives having 0 space which is why I have to reclaim the space

Re: Centos 7 installation on Dell PE R410

Posted: 2019/05/19 19:33:12
by itzdaniel483
The logs don't show much

"Entry 005 of 0005
Severity: Unknown
Date and Time: Sun May 19 2019 19:28:13
Description:
System Software event: OS Event sensor, unkown event"

Re: Centos 7 installation on Dell PE R410

Posted: 2019/05/22 09:51:01
by itzdaniel483
I wanted to install Centos 7 on RAID 1 so if the drive does fail, the server AND the OS would know. I was worried that in case if I set the drives up as RAID 1 but no configuration to the OS, then once a drive failed, the OS wouldn't know to copy the data to the replacement drive.

However I have just read "https://community.spiceworks.com/topic/ ... ve-failure" to discover that if I was to set the drives up as RAID 1 and the OS with no configuration, then if one was to fail the server would automatically copy everything over and I would not need to worry about Centos not copying over data.

Anyone advise me continuing with setting the drives up as RAID 1 with no OS configuration?

Re: Centos 7 installation on Dell PE R410

Posted: 2019/05/22 09:57:16
by TrevorH
Hardware RAID is transparent to the operating system. It just sees a "disk" and has no idea that there is a RAID controller there presenting multiple disk devices as a single entity.

Also, I checked my R610 and I am not sure that the RAID controller status is picked up by the iDRAC on these. My newer R620/630/640 machines all list the storage status in the iDRAC, the R610 does not. The RAID contoller does have a BIOS though and you can get into it at boot time by pressing the right keys when prompted. That will tell you if the component disks are healthy or not.

Re: Centos 7 installation on Dell PE R410

Posted: 2019/05/22 09:59:05
by itzdaniel483
Right okay. I'll go through with the RAID 1 and no OS configuration. I should be able do get back to the server at some point this week

Re: Centos 7 installation on Dell PE R410

Posted: 2019/05/22 14:16:28
by itzdaniel483
Ah, I create the RAID 1 array but the installation sees '0B Free'.

Re: Centos 7 installation on Dell PE R410

Posted: 2019/06/04 21:33:02
by itzdaniel483
I even purchased two extra drives so I now have 4x1TB. I even tried to create a RAID 10 array but the installer shows all drives as full. I must be doing somehing wrong.

Re: Centos 7 installation on Dell PE R410

Posted: 2019/06/06 13:22:13
by itzdaniel483
It turns out that my RAID card isn't a PERC 6. Its an S100. I've read up that it may not support RAID on Linux. Which would explain why it states the configuration as failed and the drives as full.

I'll do a bit more research into it and keep this post updated.

Re: Centos 7 installation on Dell PE R410

Posted: 2019/06/06 14:11:44
by TrevorH
The S100 is a FakeRAID controller and useless with linux. You either need to replace it with a real hardware controller or use linux software RAID instead. Make sure you switch the S100 to AHCI mode in its BIOS if you need to use it.

Re: Centos 7 installation on Dell PE R410

Posted: 2019/06/06 14:14:58
by itzdaniel483
I might just stick with software RAID, if I was to get another controller I would have to get the server backplate as the hard drive cables are all individual and go into their own SATA port. I'll have to look into software raid as I would have no idea where to start.

EDIT
well saying that I could install centos using this article which I have done before as a test.
https://www.thegeekdiary.com/how-to-ins ... partition/