No Presto metadata available for base

General support questions
Post Reply
sentout
Posts: 1
Joined: 2015/07/08 08:07:01

No Presto metadata available for base

Post by sentout » 2015/07/08 08:14:18

I am trying to update my installation with

Code: Select all

$ sudo yum update
Loaded plugins: fastestmirror, langpacks
base                                                                                                                 | 3.6 kB  00:00:00     
extras                                                                                                               | 3.4 kB  00:00:00     
updates                                                                                                              | 3.4 kB  00:00:00     
(1/4): extras/7/x86_64/primary_db                                                                                    |  62 kB  00:00:00     
(2/4): base/7/x86_64/group_gz                                                                                        | 154 kB  00:00:00     
(3/4): base/7/x86_64/primary_db                                                                                      | 5.1 MB  00:00:00     
(4/4): updates/7/x86_64/primary_db                                                                                   | 2.5 MB  00:00:01     
Loading mirror speeds from cached hostfile
...
<snip>
...

Code: Select all

Transaction Summary
============================================================================================================================================
Install    8 Packages (+31 Dependent packages)
Upgrade  502 Packages

Total size: 563 M
Total download size: 11 M
Is this ok [y/d/N]: y
Downloading packages:
No Presto metadata available for base
glibc-common-2.17-78.el7.x86_6 FAILED                                          ==========================-]  0.0 B/s |  11 MB  --:--:-- ETA 
http://centos.mirroring.pulsant.co.uk/7.1.1503/os/x86_64/Packages/glibc-common-2.17-78.el7.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=base clean metadata
Trying other mirror.
I tried

Code: Select all

$ yum --enablerepo=base clean metadata
But I still get the problem when I re-run. Any ideas?

User avatar
TrevorH
Forum Moderator
Posts: 29681
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: No Presto metadata available for base

Post by TrevorH » 2015/07/08 08:37:32

Are you behind a web proxy? Try adding http_caching=packages to your /etc/yum.conf and see if that helps.

The mirror that you are using appears to be missing the drpms directory which would explain the message about no presto data but that is optional and it should work without it. I think some upstream proxy has cached a bad copy of that package and keeps sending it to you.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - General Support”