Text Font Size

General support questions
Post Reply
scouser
Posts: 3
Joined: 2015/02/01 15:45:54

Text Font Size

Post by scouser » 2015/02/01 15:53:08

I apologize in advance for this simple question, but I have been unable to locate the answer for CentOS 7 (earlier versions yes). How do you permanently change the non-GUI command line font size. I am referring to the Alt-F2 - ALt-F6 logins on the console. Thank you in advance for the help!

padoauk
Posts: 4
Joined: 2015/01/25 10:02:49

Re: Text Font Size

Post by padoauk » 2015/02/01 17:42:41

Hi.

One can change the console font size by using `setfont` command. Therefore, to insert invocation of the command in the init procedure is enough, I guess.

scouser
Posts: 3
Joined: 2015/02/01 15:45:54

Re: Text Font Size

Post by scouser » 2015/02/01 18:05:54

thank you for the reply. Can you please be specific about which init process and its location. Also I guess what I'm also asking is the location of the configuration file(s) for those Alt logins. Thank you again!

padoauk
Posts: 4
Joined: 2015/01/25 10:02:49

Re: Text Font Size

Post by padoauk » 2015/02/02 05:43:15

Hi.

CentOS7 has new startup system called systemd. I am not familiar to this. I can say that one should be familiar to command `systemctl`. I hope to see the setting file like /etc/systemd/system/multi-user.target.wants/sshd.service will help you.

scouser
Posts: 3
Joined: 2015/02/01 15:45:54

Re: Text Font Size

Post by scouser » 2015/02/02 21:00:38

I was able to change the default font size at boot. If anyone else has this problem here is how I fixed it in my case. I should have called the 'Alt-Fx' logins "Virtual Consoles" (always helps searching when you use the right terminology). I changed the GRUB_CMDLINE_LINUX= line in '/etc/default/grub' to include the correct 'vconsole.font=' entry. Ran 'grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg' and now it boots with the desired font on my text virtual consoles. I tried changing the FONT line in '/etc/vconsole.conf' but I couldn't figure out why it wasn't being picked up. I did see bug #0007325, but I don't know if this is the same issue or not. In any case thanks for the help!

Post Reply

Return to “CentOS 7 - General Support”