Encryption / RAID1 CentOS Setup Bug?

General support questions
Post Reply
matthew1471
Posts: 1
Joined: 2015/01/28 23:16:37

Encryption / RAID1 CentOS Setup Bug?

Post by matthew1471 » 2015/01/28 23:21:01

Hi CentOS,

Just tried installing CentOS with Standard Partitions and RAID1 for all partitions but also ticking the encryption box...

The installer at the end said something about 4m terminated (presume a program had been running for 4 minutes before terminating?) then :

"Could not unmount /run/install/repo: Device or resource busy
Could not unmount /run/install/repo: Device or resource busy
Cannot finalize remaining file systems and devices, giving up.
dracut Warning: Killing all remaining processes
mdadm: stopped /dev/md124"

...then a few more mdadm messages pop up then it reboots.

I then found the installation was unbootable (though I can't guarantee I hadn't done something stupid so I tried again to reproduce). I tried reinstalling again but this time waiting before clicking "Reboot" at the end of setup and it succeeded in making it bootable (but the screenshot below shows the error again). Is there some sort of race condition here or something taking a bit longer than the setup expected?

Could someone please explain to me what those messages are all about?

Thanks,
Matthew
Attachments
Complete.png
Complete.png (49.49 KiB) Viewed 1063 times
Error.png
Error.png (9.73 KiB) Viewed 1063 times

Post Reply

Return to “CentOS 7 - General Support”