bootup failed

General support questions
Post Reply
pkking
Posts: 9
Joined: 2014/11/14 02:15:34

bootup failed

Post by pkking » 2015/01/27 04:57:10

I am using centos 7 with virtual box, And yesterday i can not boot into system after a reboot.
I tried to get the systemd.log from a ttyS0 like this:

Code: Select all

Welcome to [0;31mCentOS Linux 7 (Core)[0m!



Set hostname to <localhost.localdomain>.

Using cgroup controller name=systemd. File system hierarchy is at /sys/fs/cgroup/systemd.

Release agent already installed.

Using notification socket @/org/freedesktop/systemd1/notify

Set up TFD_TIMER_CANCEL_ON_SET timerfd.

Failed to open private bus connection: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

Failed to connect to system D-Bus, retrying later

Successfully created private D-Bus server.

Spawned /usr/lib/systemd/system-generators/systemd-cryptsetup-generator as 408

Spawned /usr/lib/systemd/system-generators/systemd-efi-boot-generator as 409

Spawned /usr/lib/systemd/system-generators/systemd-fstab-generator as 410

Spawned /usr/lib/systemd/system-generators/systemd-getty-generator as 411

Spawned /usr/lib/systemd/system-generators/systemd-rc-local-generator as 412

Spawned /usr/lib/systemd/system-generators/systemd-system-update-generator as 413

Spawned /usr/lib/systemd/system-generators/kdump-dep-generator.sh as 414

Spawned /usr/lib/systemd/system-generators/lvm2-activation-generator as 415

/usr/lib/systemd/system-generators/systemd-cryptsetup-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-efi-boot-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-fstab-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-getty-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-rc-local-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-system-update-generator exited successfully.

/usr/lib/systemd/system-generators/kdump-dep-generator.sh exited successfully.

It seems that nothing happened after system-generators

I have no idea where the problem is, any help would be appreciated.

User avatar
TrevorH
Forum Moderator
Posts: 29470
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: bootup failed

Post by TrevorH » 2015/01/27 09:28:57

Did you install the virtualbox guest additions and do you run your system in runlevel 5 with a GUI? If so then the GUI will break everytime you update your kernel and the vbox GA will need to be reinstalled to get the GUI working again...
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

pkking
Posts: 9
Joined: 2014/11/14 02:15:34

Re: bootup failed

Post by pkking » 2015/01/28 01:43:48

TrevorH wrote:Did you install the virtualbox guest additions and do you run your system in runlevel 5 with a GUI? If so then the GUI will break everytime you update your kernel and the vbox GA will need to be reinstalled to get the GUI working again...
I did not install a guest additions, and i boot with mulit-user target, and I tried to add a init=/sbin/init at the tail of kernel cmdline, it can boot up normally.
Is that meas something wrong with some systemd target ?

pkking
Posts: 9
Joined: 2014/11/14 02:15:34

Re: bootup failed

Post by pkking » 2015/01/28 02:17:15

I read the log again!
The log say:

Code: Select all

Spawned /usr/lib/systemd/system-generators/systemd-cryptsetup-generator as 408

Spawned /usr/lib/systemd/system-generators/systemd-efi-boot-generator as 409

Spawned /usr/lib/systemd/system-generators/systemd-fstab-generator as 410

Spawned /usr/lib/systemd/system-generators/systemd-getty-generator as 411

Spawned /usr/lib/systemd/system-generators/systemd-rc-local-generator as 412

Spawned /usr/lib/systemd/system-generators/systemd-system-update-generator as 413

Spawned /usr/lib/systemd/system-generators/kdump-dep-generator.sh as 414

Spawned /usr/lib/systemd/system-generators/lvm2-activation-generator as 415

/usr/lib/systemd/system-generators/systemd-cryptsetup-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-efi-boot-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-fstab-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-getty-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-rc-local-generator exited successfully.

/usr/lib/systemd/system-generators/systemd-system-update-generator exited successfully.

/usr/lib/systemd/system-generators/kdump-dep-generator.sh exited successfully.
it seems that the lvm2-activation-generator did not work, so the systemd will not be start?
How can i debug the issue?

Post Reply

Return to “CentOS 7 - General Support”