550-5.7.1 error when sending mail to gmail.com recipients

General support questions
Post Reply
MarkEHansen
Posts: 118
Joined: 2005/11/25 02:50:31
Location: Sacramento, CA

550-5.7.1 error when sending mail to gmail.com recipients

Post by MarkEHansen » 2015/01/04 00:38:37

I have a problem that is rather difficult to explain. I have a CentOS 7.0 system which I use as my network server. This machine hosts various services for my local network, like firewall, dhcpd, imapd, sendmail, named, etc.

This CentOS 7.0 machine is a replacement for the old machine which was running CentOS 5.11. I was not having this problem on the 5.11 machine.

Computers on my local network running Windows 7 and send e-mail using Thunderbird. Thunderbird is configured to use my local network host as the SMTP server.

When I try to send an e-mail from Thunderbird on one of these local PCs to a recipient at gmail.com, the e-mail is rejected with the following error:

Code: Select all

... while talking to gmail-smtp-in.l.google.com.:
>>> >>> DATA
<<< 550-5.7.1 [2606:400:0:5:240:f4ff:fe04:c83c      12] Our system has detected that
<<< 550-5.7.1 this message is likely unsolicited mail. To reduce the amount of spam
<<< 550-5.7.1 sent to Gmail, this message has been blocked. Please visit
<<< 550-5.7.1 http://support.google.com/mail/bin/answer.py?hl=en&answer=188131 for
<<< 550 5.7.1 more information. g6si67799938pat.30 - gsmtp
554 5.0.0 Service unavailable
I've noticed no problems sending to any other recipients. At this point, gmail.com seems to be the only one failing.

In trying to debug this, I tried connecting to the gmail server directly (using telnet on port 25) and then doing the normal protocol (EHLO ..., MAIL FROM: ..., RCPT TO: ..., etc.) and this works fine. The message is accepted for delivery and is in fact delivered).

I also tried sending a message to the same recipient using a perl script running on the same Windows 7 PC. The perl script utilized the Net::SMTP library and uses my CentOS 7.0 host as the mail server). This message, too, is accepted for delivery and is then delivered successfully.

On the CentOS 7.0 host, I'm running sendmail 8.14.7, and I have it configured to allow relay for the hosts on my local network (if you want me to show more of my sendmail configuration, I can but I think the above "perl" test shows that it is allowing this properly).

Can anyone please suggest what I can try next?

Thanks,

User avatar
TrevorH
Forum Moderator
Posts: 29160
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: 550-5.7.1 error when sending mail to gmail.com recipient

Post by TrevorH » 2015/01/04 00:45:44

I'd guess your problem is that the new system is connecting to google over ipv6 and there's no reverse dns lookup entry for your ipv6 address and when you telnet you connect over ipv4 and you do have an rdns entry.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

MarkEHansen
Posts: 118
Joined: 2005/11/25 02:50:31
Location: Sacramento, CA

Re: 550-5.7.1 error when sending mail to gmail.com recipient

Post by MarkEHansen » 2015/01/04 01:06:13

Thanks, Trevor. In fact, on my last machine I started getting errors from mail going to gmail.com recipients in October of 2013. In that case, the message was more clear that it was talking about no reverse DNS for my IPv6 network. What I did to get around that was disable my IPv6 network.

I thought I did that here too, but perhaps I'm missing something. Can you please tell me what I need to check to verify whether or not my IPv6 network is still active and what I need to do to disable it?

Thanks,

MarkEHansen
Posts: 118
Joined: 2005/11/25 02:50:31
Location: Sacramento, CA

Re: 550-5.7.1 error when sending mail to gmail.com recipient

Post by MarkEHansen » 2015/01/04 01:08:52

I should say that my /etc/sysconfig/network-scripts/ifcfg-enp5s5 (this is for my external network) has the following settings:

Code: Select all

IPV6INIT=no
IPV6_AUTOCONF=no
IPV6_DEFROUTE=no
IPV6_PEERDNS=no
IPV6_PEERROUTES=no
IPV6_FAILURE_FATAL=no
Also, my /etc/sysconfig/network file looks like this:

Code: Select all

NETWORKING=yes
NETWORKING_IPV6=no
IPV6INIT=no
Is there anything else I need to do?

MarkEHansen
Posts: 118
Joined: 2005/11/25 02:50:31
Location: Sacramento, CA

Re: 550-5.7.1 error when sending mail to gmail.com recipient

Post by MarkEHansen » 2015/01/04 01:10:38

One other thing I did on my previous machine (CentOS 5.11) is that I added the following line to /etc/modprobe.conf
install ipv6 /bin/true

but I don't see how to do that on CentOS 7.0. Is that what I'm missing?

MarkEHansen
Posts: 118
Joined: 2005/11/25 02:50:31
Location: Sacramento, CA

Re: 550-5.7.1 error when sending mail to gmail.com recipient

Post by MarkEHansen » 2015/01/04 01:43:04

Okay, I found the following FAQ:
http://wiki.centos.org/FAQ/CentOS7#head ... 67f2fcd8ee

which said that I can add the following entries to the /etc/sysctl.conf file:

Code: Select all

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
However, after doing that, I was no longer able to get out on the network from my local Windows 7 PCs. Note that they were able to connect to my Linux host via ssh, but they were not able to get out the external network.

I removed the entries and rebooted and now the network is back. What did I do wrong? Is there a way to disable the IPv6 network without killing external network access to my internal Windows 7 PCs?

User avatar
TrevorH
Forum Moderator
Posts: 29160
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: 550-5.7.1 error when sending mail to gmail.com recipient

Post by TrevorH » 2015/01/04 02:58:18

Just add an rdns entry for your ipv6 address. Much simpler and then you'll be ready for the future when it arrives any day now ;-)
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

MarkEHansen
Posts: 118
Joined: 2005/11/25 02:50:31
Location: Sacramento, CA

Re: 550-5.7.1 error when sending mail to gmail.com recipient

Post by MarkEHansen » 2015/01/04 03:13:10

I tried that the last time this came up. After working with it for quite a while, I found that I had to have this added by my ISP, but in working with my ISP, they were not willing to add it.

Is this something I can do without help from my ISP?

I can't change ISPs at this time, so that's not an option for me.

Thanks,

MarkEHansen
Posts: 118
Joined: 2005/11/25 02:50:31
Location: Sacramento, CA

Re: 550-5.7.1 error when sending mail to gmail.com recipient

Post by MarkEHansen » 2015/01/04 19:59:24

With help from someone on the Network forum, I was shown that to display the IPv6 network, I can add the following entries to a new file: /etc/sysctl.d/ipv6.conf:

Code: Select all

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.enp2s0.disable_ipv6 = 1
net.ipv6.conf.enp5s5.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
This resolved my problem. Thanks for all who looked.

Post Reply

Return to “CentOS 7 - General Support”