OpenVPN problems (Solved)

General support questions
Post Reply
ov10fac
Posts: 44
Joined: 2010/06/08 13:30:51
Contact:

OpenVPN problems (Solved)

Post by ov10fac » 2015/01/03 23:14:37

I have been trying to get OpenVPN running in CentOS7. Openvpn runs, but cannot read the certificate. Here's the screen display when I try to run it.

Sat Jan 3 17:05:16 2015 OpenVPN 2.3.6 x86_64-redhat-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Dec 2 2014
Sat Jan 3 17:05:16 2015 library versions: OpenSSL 1.0.1e-fips 11 Feb 2013, LZO 2.06
Sat Jan 3 17:05:16 2015 UDPv4 link local: [undef]
Sat Jan 3 17:05:16 2015 UDPv4 link remote: [AF_INET]184.187.13.197:1194
Sat Jan 3 17:05:16 2015 VERIFY ERROR: depth=0, error=certificate signature failure: C=US, ST=Nebraska, O=Skrupa Law, OU=c16e94dec247235c, CN=server.does.not.exists, dnQualifier=server
Sat Jan 3 17:05:16 2015 TLS_ERROR: BIO read tls_read_plaintext error: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
Sat Jan 3 17:05:16 2015 TLS Error: TLS object -> incoming plaintext read error
Sat Jan 3 17:05:16 2015 TLS Error: TLS handshake failed
Sat Jan 3 17:05:16 2015 SIGTERM[soft,tls-error] received, process exiting

From what I have read this seems to be a problem with MD5 encryption that is no longer supported by CentOS. I can't change the encryption of the Certificate, so I need to get CentOS to recognize MD5 encryption. I have followed the guidance found here: http://software-engineer.gatsbylee.com/ ... e-failure/.

The solution was to run the commands as root. I was trying to use sudo which doesn't seem to work for some reason. As soon as I ran my script as root, all was working fine. Really strange, but as long as its all working, thats all I need for the time being.

But that didn't seem to solve the problem. I am out of airspeed, altitude and ideas so hope someone here that's smarter than me can give me some advice.

Thanks. :(

Post Reply

Return to “CentOS 7 - General Support”