[SOLVED] CentOS 7.0 Exfat Support

General support questions
Post Reply
Chiefahol
Posts: 9
Joined: 2014/12/13 02:22:28

[SOLVED] CentOS 7.0 Exfat Support

Post by Chiefahol » 2014/12/13 04:06:31

***Solution found, NOOB problem: i hadn't installed the proper el7 rpms for both exfat-utils and fuse-exfat.

Hi guys, i'm desperately in need of help! I can't get my exfat drive working at all...

Code: Select all

Unable to access “scottyhdd”
Error mounting /dev/sdb1 at /run/media/jack/scottyhdd: Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,namecase=0,errors=remount-ro,umask=0077" "/dev/sdb1" "/run/media/jack/fatty"' exited with non-zero exit status 32: mount: unknown filesystem type 'exfat'
I've tried installing: exfat-utils-1.0.1-2.el6.x86_64.rpm, No luck.

This page got me nowhere sadly:

viewtopic.php?t=7592

I posted attempts there. (Not sure how long mod approval takes.)

If anyone could find any relevant information on this i'd love you long time. I'm very tired of hopping from distro to disto. :mrgreen:
Last edited by Chiefahol on 2014/12/15 08:22:07, edited 1 time in total.

User avatar
WhatsHisName
Posts: 1547
Joined: 2005/12/19 20:21:43
Location: /earth/usa/nj

Re: CentOS 7.0 Exfat Support

Post by WhatsHisName » 2014/12/13 06:26:29

$ rpm -qa|grep -i exfat

exfat-utils-1.0.1-2.el6.x86_64
fuse-exfat-1.0.1-2.el6.x86_64

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: CentOS 7.0 Exfat Support

Post by gerald_clark » 2014/12/13 13:54:43


User avatar
AlanBartlett
Forum Moderator
Posts: 9324
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: CentOS 7.0 Exfat Support

Post by AlanBartlett » 2014/12/13 15:22:45

Please clarify.

You have posted in the CentOS 7 - General Support forum, your subject line makes reference to CentOS 7.0 but you mention atempting to install a CentOS 6 package . . .
I've tried installing: exfat-utils-1.0.1-2.el6.x86_64.rpm, No luck.
Is the system in question using CentOS 6 or CentOS 7?
Image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

Chiefahol
Posts: 9
Joined: 2014/12/13 02:22:28

Re: CentOS 7.0 Exfat Support

Post by Chiefahol » 2014/12/14 02:54:31

$ rpm -qa|grep -i exfat

exfat-utils-1.0.1-2.el6.x86_64
fuse-exfat-1.0.1-2.el6.x86_64
My terminal gives me:

[user@localhost bin]$ rpm -qa|grep -i exfat
exfat-utils-1.0.1-2.el6.x86_64

To be clear. I do have CentOS7, i tried to install a 6 package because i couldn't find one for 7!! (If this is a big no-no, my bad.)

This is what i get after removing that package, and trying to reinstall exfat-utils:

Code: Select all

[user@localhost bin]$ sudo yum install exfat-utils
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.mirror1.spango.com
 * epel: ftp.uni-koeln.de
 * extras: centos.mirror1.spango.com
 * updates: mirrors.supportex.net
[b]No package exfat-utils available.[/b]
Error: Nothing to do
To make matters worse, my backup file system ext is having problems, but i made a separate topic here to avoid double posting: viewtopic.php?f=47&t=50121 :mrgreen: :mrgreen:

So... how might i get centOS working with Exfat? :P I still have no idea how to proceed.

User avatar
WhatsHisName
Posts: 1547
Joined: 2005/12/19 20:21:43
Location: /earth/usa/nj

Re: CentOS 7.0 Exfat Support

Post by WhatsHisName » 2014/12/14 07:12:40

You should install both exfat-utils and fuse-exfat for el7 (my post was from an el6 system that supports exFAT).

The nux-dextop repo has both for el7 @ http://li.nux.ro/download/nux/dextop/el7/x86_64/

Chiefahol
Posts: 9
Joined: 2014/12/13 02:22:28

Re: [SOLVED] CentOS 7.0 Exfat Support

Post by Chiefahol » 2014/12/15 08:18:40

WhatsHisName wrote:You should install both exfat-utils and fuse-exfat for el7 (my post was from an el6 system that supports exFAT).

The nux-dextop repo has both for el7 @ http://li.nux.ro/download/nux/dextop/el7/x86_64/
SUCCESS!! It now works perfectly! Thankyou WhatsHisName, i love you long time. <3 :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen:

Post Reply

Return to “CentOS 7 - General Support”