How to set up multiseat on Centos 7

General support questions
charlie101
Posts: 20
Joined: 2012/06/17 22:40:34

Re: How to set up multiseat on Centos 7

Post by charlie101 » 2014/12/11 03:51:03

rjt69 wrote:

Code: Select all

Registered Authentication Agent for unix-session:c2
Does this appear in the log when someone attempts to logon to seat2? Is that 'c2' console 2? Or when X starts on seat2?
All three lines also appear when I login from bootup at seat2 as root:

Code: Select all

secure:Dec 11 03:16:06 localhost polkitd[748]: Registered Authentication Agent for unix-session:c1 (system bus name :1.64 [gnome-shell --mode=gdm], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
secure:Dec 11 03:16:06 localhost polkitd[748]: Registered Authentication Agent for unix-session:c2 (system bus name :1.49 [gnome-shell --mode=gdm], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
secure:Dec 11 03:16:21 localhost polkitd[748]: Registered Authentication Agent for unix-session:1 (system bus name :1.83 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
The lines are virtually identical though no error/crash occurred. The only login was on seat2.
The third unix-session is different than the others because it is just a number, not 'cX' and then gnome-shell segfaults:

Code: Select all

unix-session:1
Yes but also in the example above where there was no crash.
Does the X org log show anything?
Note that I can find. I have scan read and grep'ed for words like 'error' but nothing looked out of the ordinary.
I'll create and few more crashes from a clean start and see if I can find anything.

Charlie101

charlie101
Posts: 20
Joined: 2012/06/17 22:40:34

Re: How to set up multiseat on Centos 7

Post by charlie101 » 2014/12/11 04:11:18

rjt69 wrote:On seat2, i assume you can logon successfully to the TTY consoles:

Code: Select all

CTRL-ALT+F2

Code: Select all

CTRL-ALT+F5
No I can't access any of the virtual consoles. But from other doc's I've read this is normal for multiseat; only the master seat 'seat0' can access the virtual consoles.
I guess they have to be assigned to some seat.

The documentation you referenced manually starting X, or doing `init 3`, then `init 5`
Yes that document did say switch run levels but I didn't do that. As I was the only on the machine and simply restarted X I didn't think it mattered.
I previous setup ubuntu 14.10 with multiseat on the same machine and it worked fine, accept.
Wondering if it is a Xwindow cookie that does not have the right permissions or if it is trying to use the same Xwindow cookie for both seats which would be a problem. These are often under /tmp/
I don't know anything about X cookies I'm afraid. All I could find from X under tmp was:

Code: Select all

/tmp/.X11-unix
/tmp/.X11-unix/X0
/tmp/.X11-unix/X1
/tmp/.X0-lock
/tmp/.X1-lock
Charlie101

charlie101
Posts: 20
Joined: 2012/06/17 22:40:34

Re: How to set up multiseat on Centos 7

Post by charlie101 » 2014/12/11 04:55:05

rjt69 wrote:

Code: Select all

loginctl --help
seems to be promising:

Code: Select all

loginctl list-sessions
loginctl show-seat
loginctl list-users
Here is loginctl list-sessions:

Code: Select all

[root@localhost log]# loginctl list-sessions
   SESSION        UID USER             SEAT            
        c1         42 gdm              seat0           
        c2         42 gdm              seat2           
         1          0 root             seat2 
No one is logged into seat0 but I am logged in on 'seat2' as root.
I note there are two sessions for seat2 and gdm is still around.
Also root has a session id of 1 ( could be what you mentioned earlier?).

Next I go and login as 'charlie' on seat0:

Code: Select all

[root@localhost log]# loginctl list-sessions
   SESSION        UID USER             SEAT            
        c2         42 gdm              seat2           
         1          0 root             seat2           
        10       1000 charlie          seat0 

 
gdm has been replaced by my session.

Now 'loginctl show-seat' for root session on seat2:

Code: Select all

[root@localhost log]# loginctl show-seat
NAutoVTs=6
KillExcludeUsers=root
KillUserProcesses=no
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
BlockInhibited=handle-power-key:handle-suspend-key:handle-hibernate-key:handle-lid-switch
DelayInhibited=sleep
InhibitDelayMaxUSec=5s
HandlePowerKey=poweroff
HandleSuspendKey=suspend
HandleHibernateKey=hibernate
HandleLidSwitch=suspend
IdleAction=ignore
IdleActionUSec=30min
PreparingForShutdown=no
PreparingForSleep=no
Now 'loginctl show-seat' for charlie session on seato:

Code: Select all

[charlie@localhost ~]$ loginctl show-seat
NAutoVTs=6
KillExcludeUsers=root
KillUserProcesses=no
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
BlockInhibited=handle-power-key:handle-suspend-key:handle-hibernate-key:handle-lid-switch
DelayInhibited=sleep
InhibitDelayMaxUSec=5s
HandlePowerKey=poweroff
HandleSuspendKey=suspend
HandleHibernateKey=hibernate
HandleLidSwitch=suspend
IdleAction=ignore
IdleActionUSec=30min
PreparingForShutdown=no
PreparingForSleep=no
Finally loginctl list-users:

Code: Select all

[root@localhost log]# loginctl list-users
       UID USER            
         0 root            
      1000 charlie         

2 users listed.
Charlie101

charlie101
Posts: 20
Joined: 2012/06/17 22:40:34

Re: How to set up multiseat on Centos 7

Post by charlie101 » 2014/12/11 05:45:22

Update

By trawling through the files in the 'dump' directory I managed to determine that the error was occurring with/in gnome-shell.
I further tracked it to the gnome-shell-classic.desktop settings. However, gnome-shell.desktop didn't seem to work either.

Anyway, as a quick 'debug' check I commented out everything below the 'exec' statement and it worked.
Well It didn't give me much of a gnome shell but it stopped the crashing and allowed me to login.
Tomorrow I'll try and find out exactly which line(s) is causing the problem.


Charlie101

rjt69
Posts: 27
Joined: 2013/07/12 18:03:14
Location: Omaha, NE
Contact:

Re: How to set up multiseat on Centos 7

Post by rjt69 » 2014/12/11 23:17:02

Charlie, please, please upload the desktop file in which you commented lines out. When i get hardware to set up MultiSeat myself and others... MultiSeat just is not something Microsoft can compete against and Linux could have had this capability more than a decade ago.

I wonder if there is not an "off-by-one" error, Seat0, Seat1,Seat2 is three seats, not two and maybe gnome-shell is referencing a seat that does not exist.

i would think "NAutoVTs=6" would mean there are 6 Virtual Terminals as in CTRL-ALT+F[1-6]. Fedora and RHEL broke away from CTRL+ALT-F7 as the XWindow as the default and switched it to CTRL-ALT+F1. Sometimes that confuses things and i find that my CentOS F1 XWindow is broken, but it works fine on CTRL-ALT+[ F7 | F8 ].

rjt69
Posts: 27
Joined: 2013/07/12 18:03:14
Location: Omaha, NE
Contact:

Re: How to set up multiseat on Centos 7

Post by rjt69 » 2014/12/11 23:19:12

Traditionally, "(EE)" is for errors and "(WW)" for warnings in the X log files.

charlie101
Posts: 20
Joined: 2012/06/17 22:40:34

Re: How to set up multiseat on Centos 7

Post by charlie101 » 2014/12/12 04:19:10

Hi rjt69
rjt69 wrote: please upload the desktop file in which you commented lines out.
So the file is /usr/share/applications/gnome-shell-classic.desktop

The important stuff is here:

Code: Select all

Exec=/usr/bin/gnome-shell
TryExec=/usr/bin/gnome-shell
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-shell
X-GNOME-Bugzilla-Component=general
X-GNOME-Bugzilla-Version=3.8.4
Categories=GNOME;GTK;Core;
OnlyShowIn=GNOME;
NoDisplay=true
X-GNOME-Autostart-Phase=WindowManager
X-GNOME-Provides=panel;windowmanager;
X-GNOME-Autostart-Notify=true
X-GNOME-AutoRestart=false
The specific line related to the login problem is:

Code: Select all

X-GNOME-Autostart-Phase=WindowManager
I've tried deleting and changes all the the above lines (except Exec) and the one change that makes a difference is to the line above.
If I delete this line or change WindowManager to something like 'Desktop' I can login on seat 2. But if the line above is in the file I can't login as a normal user on seat2 period.

When I remove or change the line above and login as a normal user I nolonger have a panel, menu or task bar. I only have the desktop and windows manager. Petty bare unusable stuff really.
The interesting thing is that if I login as root on seat2 or I login as any user on seat0 everything is fine. I have the full gnome classic desktop. Removing that line only seems to effect standard users on seat2.

Nor is it the case that the file is only being read when standard users login on seat2.
If I remove the file and replace it with a symbolic link to another desktop config' file say 'metacity' this effects everyone on any seat.
So why is that line so important to standard users on non-primary seats and not to any other login path?


I wonder if there is not an "off-by-one" error, Seat0, Seat1,Seat2 is three seats, not two and maybe gnome-shell is referencing a seat that does not exist.
I tried this out ie change the seat name/number to seat1 and it had no effect.



File gnome-shell-classic.desktop attached as a txt file.

Charlie101
Attachments
gnome-shell-classic.txt
File Attached
(3.6 KiB) Downloaded 63 times

rjt69
Posts: 27
Joined: 2013/07/12 18:03:14
Location: Omaha, NE
Contact:

Re: How to set up multiseat on Centos 7

Post by rjt69 » 2014/12/12 06:41:14

The desktop seems useless, but does ALT+F2 --> gnome-terminal work?
or gnome-session-properties to turn off autostarting apps.

rjt69
Posts: 27
Joined: 2013/07/12 18:03:14
Location: Omaha, NE
Contact:

Re: How to set up multiseat on Centos 7

Post by rjt69 » 2014/12/12 07:55:36

gdm and ConsoleKit log files should be spitting out something as well:
/var/log/gdm/
/var/log/ConsoleKit/


If not, enable debugging by editing the [debug] section of /etc/gdm/custom.config by inserting Enabled=true.

rjt69
Posts: 27
Joined: 2013/07/12 18:03:14
Location: Omaha, NE
Contact:

Re: How to set up multiseat on Centos 7

Post by rjt69 » 2014/12/12 07:56:52

In the interest of simplifying all the things Gnome does upon logon as seat2user, shut sh** OFF.
Disable Compiz (and use Metacity) by setting the following boolean to false:
gconftool-2 --get /apps/gdm/simple-greeter/wm_use_compiz
gconftool-2 --type boolean --set /apps/gdm/simple-greeter/wm_use_compiz false

Turn sound off:
gconftool-2 --get /apps/gdm/simple-greeter/settings-manager-plugins/sound/active
gconftool-2 --type boolean --set /apps/gdm/simple-greeter/settings-manager-plugins/sound/active

https://help.gnome.org/admin/gdm/stable ... ingsdaemon

Post Reply

Return to “CentOS 7 - General Support”