PXE Install and Python Error [RESOLVED]

General support questions
Post Reply
gw1500se
Posts: 191
Joined: 2012/05/07 13:53:35

PXE Install and Python Error [RESOLVED]

Post by gw1500se » 2014/12/07 15:47:12

I am trying to set up a PXE install and am having a problem with python. I am assuming it is part of the base as I do not explicitly request it. However, the install fails with the error:

Code: Select all

15:22:11,880 DEBUG packaging: buildTransaction = (1, [u'python-pyparsing-1.5.6-2.el6.rf.noarch requires python(abi) = 2.6'])
15:22:11,880 WARN packaging: python-pyparsing-1.5.6-2.el6.rf.noarch requires python(abi) = 2.6
That should be a part of the python base install so I don't understand what the complaint it. Does anyone have any suggestions? TIA.
Last edited by gw1500se on 2014/12/07 21:32:54, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 28833
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: PXE Install and Python Error

Post by TrevorH » 2014/12/07 16:01:15

You're either posting in the wrong section (in which case I'll move it to the right one) or you've mixed your repo sources up. That's an el6 package intended for CentOS 6 and you have posted in the CentOS 7 section. Either point to the correct CentOS 7 repo or let me know that this is for CentOS6 and I will move the thread...
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

gw1500se
Posts: 191
Joined: 2012/05/07 13:53:35

Re: PXE Install and Python Error

Post by gw1500se » 2014/12/07 19:35:45

This is indeed CentOS 7 I'm trying to install. I will investigate this further. Thanks for pointing me in the right direction.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: PXE Install and Python Error

Post by gerald_clark » 2014/12/07 19:38:25

Also, that is not a CentOS repo, but repoforge.

gw1500se
Posts: 191
Joined: 2012/05/07 13:53:35

Re: PXE Install and Python Error

Post by gw1500se » 2014/12/07 21:32:32

Found it. Typo in one of the repo references in the kickstart file. Thanks.

Post Reply

Return to “CentOS 7 - General Support”