SIGFPE on application startup after adding second video card

General support questions
Post Reply
thejpster
Posts: 2
Joined: 2014/12/05 10:33:28

SIGFPE on application startup after adding second video card

Post by thejpster » 2014/12/05 10:47:01

Centos 7 has been working well for me for a while, using the onboard Intel HD4000 graphics and two 1080p monitors. The other day, I added an nVidia Geforce 210 and connected a third screen. When the HD4000 was the primary adaptor, the nVidia display had terrible corruption issues (smeared windows / cursors, etc) but with the nVIdia card as the primary, it seems fine.

The HD4000 drives a 1080p and an SXGA screen, and the nVidia card runs the other 1080p screen.

Since adding the nVidia card, I've been having issues running various applications.

Here's libreoffice causing a SIGFPE on startup.

Code: Select all

$ gdb /usr/lib64/libreoffice/program/soffice.bin 
GNU gdb (GDB) Red Hat Enterprise Linux 7.6.1-51.el7
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib64/libreoffice/program/soffice.bin...Reading symbols from /usr/lib64/libreoffice/program/soffice.bin...(no debugging symbols found)...done.
(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install libreoffice-core-4.1.4.2-3.el7.x86_64
(gdb) run
Starting program: /usr/lib64/libreoffice/program/soffice.bin 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffe8300700 (LWP 30725)]

Program received signal SIGFPE, Arithmetic exception.
0x00007fffded73216 in SalDisplay::Init() () from /usr/lib64/libreoffice/program/libvclplug_genlo.so
(gdb) bt
#0  0x00007fffded73216 in SalDisplay::Init() () from /usr/lib64/libreoffice/program/libvclplug_genlo.so
#1  0x00007fffe116b0bf in GtkSalDisplay::GtkSalDisplay(_GdkDisplay*) () from /usr/lib64/libreoffice/program/libvclplug_gtklo.so
#2  0x00007fffe116b768 in GtkData::Init() () from /usr/lib64/libreoffice/program/libvclplug_gtklo.so
#3  0x00007fffe116d9e8 in create_SalInstance () from /usr/lib64/libreoffice/program/libvclplug_gtklo.so
#4  0x00007ffff3672d9d in tryInstance(rtl::OUString const&, bool) () from /usr/lib64/libreoffice/program/libvcllo.so
#5  0x00007ffff3673092 in CreateSalInstance() () from /usr/lib64/libreoffice/program/libvcllo.so
#6  0x00007ffff3338e62 in InitVCL() () from /usr/lib64/libreoffice/program/libvcllo.so
#7  0x00007ffff3339f48 in ImplSVMain() () from /usr/lib64/libreoffice/program/libvcllo.so
#8  0x00007ffff333a012 in SVMain() () from /usr/lib64/libreoffice/program/libvcllo.so
#9  0x00007ffff7953785 in soffice_main () from /usr/lib64/libreoffice/program/libsofficeapp.so
#10 0x000000000040071b in main ()
(gdb)
Here's Beyond Compare 3 causing a SIGFPE in libqt3. I've removed their binary bundled libqt3-mt.so so it uses the OS supplied version, but the result is the same:

Code: Select all

$ LD_LIBRARY_PATH=/usr/lib/beyondcompare gdb /usr/lib/beyondcompare/BCompare 
GNU gdb (GDB) Red Hat Enterprise Linux 7.6.1-51.el7
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/beyondcompare/BCompare...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/lib/beyondcompare/BCompare 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".

Program received signal SIGFPE, Arithmetic exception.
0xf714ca62 in create_dpis() [clone .part.12] () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
Missing separate debuginfos, use: debuginfo-install bcompare-3.3.13-18981.i386
(gdb) bt
#0  0xf714ca62 in create_dpis() [clone .part.12] () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#1  0xf714cf75 in QPaintDevice::x11AppDpiY(int) () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#2  0xf714cf9b in QPaintDevice::x11AppDpiY() () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#3  0xf712d139 in qt_init_internal(int*, char**, _XDisplay*, unsigned long, unsigned long) () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#4  0xf712e4eb in qt_init(int*, char**, QApplication::Type) () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#5  0xf7192d86 in QApplication::construct(int&, char**, QApplication::Type) () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#6  0xf7192e8a in QApplication::QApplication(int&, char**) () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#7  0xf7cd2d92 in new_QApplication () from /usr/lib/beyondcompare/libqtc.so.1
#8  0x0808efd6 in ?? ()
#9  0x080e9e4f in ?? ()
#10 0x080f83ba in ?? ()
#11 0x080617a0 in ?? ()
#12 0x080688e4 in ?? ()
#13 0x08068972 in ?? ()
#14 0xf7789933 in __libc_start_main () from /lib/libc.so.6
#15 0x080689c8 in ?? ()
(gdb) 
I've got other crashes in dmesg too - Python and client is probably Rabbit VCS which crashed on me earlier:

Code: Select all

[11691.104484] traps: soffice.bin[10521] trap divide error ip:7fd018ca4216 sp:7fff5448c0c0 error:0 in libvclplug_genlo.so[7fd018c71000+89000]
[11703.405789] traps: soffice.bin[10590] trap divide error ip:7f31d3d08216 sp:7fff79908fc0 error:0 in libvclplug_genlo.so[7f31d3cd5000+89000]
[11726.073566] traps: soffice.bin[10662] trap divide error ip:7fec370b5216 sp:7fff3496fae0 error:0 in libvclplug_genlo.so[7fec37082000+89000]
[11732.640993] traps: soffice.bin[10726] trap divide error ip:7fe8ed926216 sp:7fff668dd480 error:0 in libvclplug_genlo.so[7fe8ed8f3000+89000]
[11896.995905] traps: soffice.bin[10916] trap divide error ip:7f3669993216 sp:7fff43f7e3b0 error:0 in libvclplug_genlo.so[7f3669960000+89000]
[16450.949743] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[16451.026762] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[18319.142857] Netfilter messages via NETLINK v0.30.
[18726.135448] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[18726.160884] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[83497.306270] userif-3: sent link down event.
[83497.306274] userif-3: sent link up event.
[86707.179464] vmware-netcfg[19191]: segfault at 18000000006f ip 00007f60c98d221b sp 00007fffdcaca8b0 error 4 in libvmware-netcfg.so[7f60c988f000+ae000]
[93028.968919] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[93029.104440] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[96497.328107] traps: soffice.bin[22792] trap divide error ip:7f97abadf216 sp:7fffbfaa2a10 error:0 in libvclplug_genlo.so[7f97abaac000+89000]
[105235.844721] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[105236.106697] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[113506.123793] chrome[11385]: segfault at fbadbeef ip 00007f7ec2cbdce6 sp 00007fffd335df40 error 6 in chrome[7f7ec0701000+4fa6000]
[138342.518057] traps: polkitd[1011] general protection ip:7f5aecc1ecf2 sp:7fff8f236aa0 error:0 in libmozjs-17.0.so[7f5aecae0000+3b3000]
[162424.637901] python[30474]: segfault at 7f220000001e ip 00007f2321bed847 sp 00007fffd6023390 error 4 in libglib-2.0.so.0.3600.3[7f2321b89000+127000]
[162424.637918] python[30481]: segfault at 7f220000001e ip 00007f2320435baf sp 00007f22f82108f0 error 4 in libgtk-x11-2.0.so.0.2400.22[7f2320202000+475000]
[162736.263971] client[30387]: segfault at 7fffb3efaff8 ip 00007fddd03d53fa sp 00007fffb3efb000 error 6 in libc-2.17.so[7fddd035c000+1b6000]
Here is lspci

Code: Select all

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 Display controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:16.2 IDE interface: Intel Corporation 7 Series/C210 Series Chipset Family IDE-r Controller (rev 04)
00:16.3 Serial controller: Intel Corporation 7 Series/C210 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.6 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 7 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a4)
00:1f.0 ISA bridge: Intel Corporation Q77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
03:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
04:03.0 FireWire (IEEE 1394): LSI Corporation FW322/323 [TrueFire] 1394a Controller (rev 70)
The CPU is reported as: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz. There's 16 GiB of DDR3 which ran through a complete memtest86+ loop OK.

I'm happy to dig around further, so can anyone suggest any next steps?

thejpster
Posts: 2
Joined: 2014/12/05 10:33:28

Re: SIGFPE on application startup after adding second video

Post by thejpster » 2014/12/08 14:12:40

I removed the nVidia card and have two screens using the on-board HD4000. LibreOffice and Beyond Compare now work fine.

Edit: I've now added a Radeon HD5870 and disabled the on-board Intel HD4000. I've got all three monitors working (from one card) and LibreOffice / BC3 are still fine. So it's not a display width thing. Must be a mixed-card thing.

Post Reply

Return to “CentOS 7 - General Support”