X11 forwarding

General support questions
Post Reply
rajeshdavid
Posts: 4
Joined: 2014/11/18 15:44:42

X11 forwarding

Post by rajeshdavid » 2014/11/18 15:52:51

Current Setup:
Now, i have windows 7 with xming configured on it. I connect to the KVM server using putty with X11 forwarding. Once i am in the kvm server, i am able to run virt-manager and see all my virtuals.
(X11 forwarding works perfect here)

Problem at hand:
One of the virtuals on the KVM server is a 389-ldap. I need to use the 389-console for the ldap server. so when i ssh -X ldapserver from the KVM server and run 389-console i am getting " Console: Can't connect to X11 window server using localhost:0: as the value of the DISPLAY variable.

What is the best way to get the X11 forwarding work in this situation, please help

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: X11 forwarding

Post by gerald_clark » 2014/11/18 16:33:17

Are you trying to chain ssh connections?
Just ssh into the target from your windows machine.
Is xorg-x11-auth installed on the target?

rajeshdavid
Posts: 4
Joined: 2014/11/18 15:44:42

Re: X11 forwarding

Post by rajeshdavid » 2014/11/18 16:38:08

Yes, i am trying chain ssh connections, because the KVM server has a public ip which i can reach from my windows 7 laptop, but none of the virtuals running on the KVM server have a public ip.
They all have private ips which are unreachable from my windows 7 laptop.

Yes, i have xorg-x11 installed on target.

Post Reply

Return to “CentOS 7 - General Support”