Trying to use steam on CentOS 7

General support questions
Post Reply
42yeah
Posts: 8
Joined: 2014/11/10 09:22:49

Trying to use steam on CentOS 7

Post by 42yeah » 2014/11/10 09:46:38

i installed CentOS and installed steam and yumed libGL
But my device is not supported by nvidia!
For the first time my computer couldn't reboot or boot, so i reinstalled CentOS
And now i am doing that again
Will this issue happened again?
I dunno if this issue is caused by libGL, or yum update
But I dont want to lose Steam in CentOS!
If you have some ways, tell me plz
And if this is the reason, and you are sure about it, tell me plz
thanks!

scottro
Forum Moderator
Posts: 2456
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: Trying to use steam on CentOS 7

Post by scottro » 2014/11/10 11:08:00

Sorry, I have no experience with Steam, but...

Please read the links in my signature. Don't use textspeak abbreviations, it's please, not plz.

You will note that I changed the subject from "Need help" to a meaningful subject. (Subject lines like
need help are often ignored by busy people who are just looking at thread subjects.)
New users should check the FAQ and Read Me First pages

User avatar
Vladi
Posts: 128
Joined: 2014/08/22 01:25:43
Location: Nyíregyháza/Hungary/EU

Re: Trying to use steam on CentOS 7

Post by Vladi » 2014/11/10 11:25:19

42yeah wrote: Will this issue happened again?
thanks!
If you do the same, same issue will happened.
I think the problem is your video card. What kind of vga do you have?

42yeah
Posts: 8
Joined: 2014/11/10 09:22:49

Re: Trying to use steam on CentOS 7

Post by 42yeah » 2014/11/10 12:02:12

scottro wrote:Sorry, I have no experience with Steam, but...

Please read the links in my signature. Don't use textspeak abbreviations, it's please, not plz.

You will note that I changed the subject from "Need help" to a meaningful subject. (Subject lines like
need help are often ignored by busy people who are just looking at thread subjects.)
Alright, thank you very much, scottro.
I tried that again and the same issue happened, but after i typed this in tty, the desktop returned:
yum remove nvidia-x11-drv
That certainly works, but my steam cannot be launched again!
So i fetched the libGL.so.1 from the rpm directly and put it into the /usr/lib directly
And installed the libs it lacked, this time without nvidia*.
So, steam worked, but it cannot launched any OpenGL-based game!
Forgive my English and please take a full look at it.
There are an error occured when i launched steam, and it says:

OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_art ... -EYZB-7457.

From Zenity.
So, what's the solution?
If you know, please tell me.
Thanks.

42yeah
Posts: 8
Joined: 2014/11/10 09:22:49

Re: Trying to use steam on CentOS 7

Post by 42yeah » 2014/11/10 12:04:14

Vladi wrote:
42yeah wrote: Will this issue happened again?
thanks!
If you do the same, same issue will happened.
I think the problem is your video card. What kind of vga do you have?
Well, i don't know it, but...
My device is Microsoft's Surface Pro.
If you know something about it, you may know.
Or i can search for it...
Maybe amd? Or is AMD a video card?

P.S. And yes, the same issue happened. But how to deal with it? I really want my steam
What's more, after my remove i can sure that my device don't support nvidia-powered softwares. So the video card can't be Nvidia.

User avatar
Vladi
Posts: 128
Joined: 2014/08/22 01:25:43
Location: Nyíregyháza/Hungary/EU

Re: Trying to use steam on CentOS 7

Post by Vladi » 2014/11/10 14:14:13

42yeah wrote: P.S. And yes, the same issue happened. But how to deal with it? I really want my steam
What's more, after my remove i can sure that my device don't support nvidia-powered softwares. So the video card can't be Nvidia.
When you have a running linux, please press:

Code: Select all

lspci
command in terminal. The output will say a lot of. :)

42yeah
Posts: 8
Joined: 2014/11/10 09:22:49

Re: Trying to use steam on CentOS 7

Post by 42yeah » 2014/11/10 14:32:49

Vladi wrote:
42yeah wrote: P.S. And yes, the same issue happened. But how to deal with it? I really want my steam
What's more, after my remove i can sure that my device don't support nvidia-powered softwares. So the video card can't be Nvidia.
When you have a running linux, please press:

Code: Select all

lspci
command in terminal. The output will say a lot of. :)
So I should show every output to you?

User avatar
Vladi
Posts: 128
Joined: 2014/08/22 01:25:43
Location: Nyíregyháza/Hungary/EU

Re: Trying to use steam on CentOS 7

Post by Vladi » 2014/11/10 16:51:38

Yes, it would be nice from you. :D

42yeah
Posts: 8
Joined: 2014/11/10 09:22:49

Re: Trying to use steam on CentOS 7

Post by 42yeah » 2014/11/14 13:59:26

Vladi wrote:Yes, it would be nice from you. :D

Code: Select all

[heo@Surface ~]$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
[heo@Surface ~]$ 
Hah, that's it. Any problems?
I still can't use my steam :(

Post Reply

Return to “CentOS 7 - General Support”