6.5 to 7.0 upgrade tool experience (informative)

General support questions
Post Reply
User avatar
probe_79
Posts: 3
Joined: 2011/12/19 17:38:58
Location: Belgium

6.5 to 7.0 upgrade tool experience (informative)

Post by probe_79 » 2014/08/23 18:21:58

I'm sharing my Centos 6.5 to 7.0 upgrade experience for those who are curious about the upgrade tool.
! The tool is only available for testing, don't try it on important servers.
I followed this guide http://wiki.centos.org/TipsAndTricks/CentOSUpgradeTool.
The server I've upgraded is just a gameserver, used on a lanparty.
It contains: centos 6.5, pure-ftpd, nginx, Xorg, IceWM, teamspeak, tiger-vnc-server, Counterstrike GO dedicated server, Team Fortress 2 dedicated server.

1) The results of the preupgrade assistant are available here:
http://pastebin.centos.org/12016/
Copy/paste the html code and save as result.html.
Open in a browser and read carefully.

2) Folllow the advise as stated in the result.html
(I only executed this: semodule -r sandbox, and ignored the nic naming remark and uid remark)
3) Run the upgrade command
4) After downloading packages it asks you to type the reboot command
5) The upgrade will run, just look at it (cli-mode no gui-mode)

6) I'm now able to login, vnc-server and IceWM is working.
nic naming is still the same, UID's are still the old ones
nginx is not working, php is broken

7) run yum update:
ERROR with transaction check vs depsolve:
php(api) = 20090626 is needed by (installed) php-pecl-apc-3.1.9-2.el6.x86_64
php(zend-abi) = 20090626 is needed by (installed) php-pecl-apc-3.1.9-2.el6.x86_64
php-common(x86-64) = 5.3.3-27.el6_5.1 is needed by (installed) php-imap-5.3.3-27.el6_5.1.x86_64
php-common(x86-64) = 5.3.3-27.el6_5.1 is needed by (installed) php-tidy-5.3.3-27.el6_5.1.x86_64
** Found 14 pre-existing rpmdb problem(s), 'yum check' output follows:
ConsoleKit-x11-0.4.1-3.el6.x86_64 has missing requires of ConsoleKit = ('0', '0.4.1', '3.el6')
cloog-ppl-0.15.7-1.2.el6.x86_64 has missing requires of libgmp.so.3()(64bit)
nginx-1.6.1-1.el6.ngx.x86_64 has missing requires of libpcre.so.0()(64bit)
openscap-1.0.8-1.0.1.el6.centos.x86_64 has missing requires of libpcre.so.0()(64bit)
openscap-1.0.8-1.0.1.el6.centos.x86_64 has missing requires of librpm.so.1()(64bit)
openscap-1.0.8-1.0.1.el6.centos.x86_64 has missing requires of librpmio.so.1()(64bit)
php-imap-5.3.3-27.el6_5.1.x86_64 has missing requires of php-common(x86-64) = ('0', '5.3.3', '27.el6_5.1')
php-pecl-apc-3.1.9-2.el6.x86_64 has missing requires of php(api) = ('0', '20090626', None)
php-pecl-apc-3.1.9-2.el6.x86_64 has missing requires of php(zend-abi) = ('0', '20090626', None)
php-tidy-5.3.3-27.el6_5.1.x86_64 has missing requires of php-common(x86-64) = ('0', '5.3.3', '27.el6_5.1')
ppl-0.10.2-11.el6.x86_64 has missing requires of libgmp.so.3()(64bit)
pure-ftpd-1.0.36-1.el6.rf.x86_64 has missing requires of libmysqlclient.so.16()(64bit)
pure-ftpd-1.0.36-1.el6.rf.x86_64 has missing requires of libmysqlclient.so.16(libmysqlclient_16)(64bit)
qpdf-libs-5.1.1-2.el6.x86_64 has missing requires of libpcre.so.0()(64bit)

! Once more, don't to this on important servers.
I hope that the preupgrade results can give you an idea of what to expect.

Post Reply

Return to “CentOS 7 - General Support”