autostart has me flummoxed

General support questions
Post Reply
iwishitwouldwork
Posts: 72
Joined: 2014/02/08 14:56:39

autostart has me flummoxed

Post by iwishitwouldwork » 2014/08/19 14:22:53

Okay, I guess the idea of saving a session/workspace config at logout is now verboten.
autostart has taken its place. I ran gnone-session-properties and tried to set up autostart
by clicking options and then the current applications button. This accomplished nothing.

What I want (as a beginning) is just a couple of terminals 80cols x53 lines. I did
ps -ef | awk '{print $8}' | sort | uniq -c
with a bunch of terminals open, hoping to find out what the terminal program was called,
and things didn't match up. With 4 terms going, nothing in ps's output had 4 copies.
ps -ef | grep term likewise didn't tell me what the terminal program was called (ie, path).

So, I presume I'm doing it wrong. How do I get what I want? Is this even an autostart
issue? Should I be posting to a Gnome site? I've been using Solaris' java desktop
forever so the Gnome approach is unfamiliar.

CentOS 7, did yum update, Gnome 3.8.4.

User avatar
ongoto
Posts: 6
Joined: 2014/08/15 08:38:33
Location: USA

Re: autostart has me flummoxed

Post by ongoto » 2014/08/25 20:26:00

Did you get this working?

If not try this:
Copy /usr/share/applications/gnome-terminal.desktop to $HOME/.config/autostart/
Make two copies and rename them
gnome-terminal-1.desktop
gnome-terminal-2.desktop
logout

You can then configure your size, etc. in Edit->Profile Preferences.
-- Only a penguin could make a nest out of some rocks --

Post Reply

Return to “CentOS 7 - General Support”