[SOLVED] CentOS 7 can't find kernel on booting

General support questions
Post Reply
dms05
Posts: 1
Joined: 2014/07/19 13:30:59

[SOLVED] CentOS 7 can't find kernel on booting

Post by dms05 » 2014/07/19 13:46:45

I've just installed CentOS 7 on a system which already has Mint16/Mint17/Ubuntu on sdb and W7/W8 on sda all are 64 bit. Whilst everything else boots OK CentOS 7 doesn'y boot at all and an error message appears fleetingly. It says something like:

Error: boot vmlinz-o-rescue - then a very long chain of letters/numbers
Load kernel first

I initially installed from the full 4.15 GB DVD and then tried the LiveCD. Both had the same problem.

I allowed the Anacoda installer to install a bootloader and chose the partition to install CentOS on (I had divided sdb in to 50 GB partitions and chose an unused one sdb7 as /.)

I tried using Grub Customize from within Mint 17 to see if I could change anything . CentOS 7 is clearly there and seems to have the appropriate scripts associated with it.

Any ideas why CentOS 7 isn't finding the kernel and how can I correct it. It certainly looks a very professional distro but at this time I can only make it load/run from the LiveCD.

Any help apprecaited.


Edit - eventually solved this myself. The bootloader wasn't loading correctly to the MBR. Once that was corrected all was well.

Post Reply

Return to “CentOS 7 - General Support”