CentOS 7 Hpyer-V IC 3.1

General support questions
Post Reply
AuZZZie
Posts: 1
Joined: 2014/07/17 15:47:11

CentOS 7 Hpyer-V IC 3.1

Post by AuZZZie » 2014/07/17 15:50:11

Can anyone clarify why CentOS 7 has chosen to integrate Hyper-V Integration Service v3.1.
It seems that up until 6.3, installing the Integration Services was up to you. 6.5 and up appear to be apart of the base build. I'm just confused why they would use such an old version for a current release. Not even 3.4,3.3,3.2.. But 3.1.

I'm going to attempt to upgrade them, but I'm not sure how well that will go.

Cheers

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: CentOS 7 Hpyer-V IC 3.1

Post by gerald_clark » 2014/07/17 16:20:18

CentOS doesn't choose the versions. It is a rebuild of RHEL.

mevans336
Posts: 47
Joined: 2007/09/06 15:19:57
Contact:

Re: CentOS 7 Hpyer-V IC 3.1

Post by mevans336 » 2014/07/19 19:25:59

You can't upgrade them. The Integration Services are now included in the kernel. Yes, Microsoft now contributes to the Linux Kernel directly. Since LIS was included as of RHEL/CentOS 6.4 (kernel something or other, I forget) improvements stopped. The later editions of the LIS were to fix bugs with the 5.x-6.3 versions of RHEL/CentOS and Hyper-V.

In other words, you don't need to worry about installing them, at all.

Source: http://blogs.technet.com/b/in_the_cloud ... vices.aspx
Source: http://www.aidanfinn.com/?p=15838

Post Reply

Return to “CentOS 7 - General Support”