Samba

General support questions
Post Reply
alexb
Posts: 1
Joined: 2014/07/16 22:04:26

Samba

Post by alexb » 2014/07/16 22:07:08

I ran Samba in Centos 7 but I could not connect to any folder shared or iven if i put the ip i got no response

selinux is disabled as well as iptables..


any idea about it?

thank you.

dylan.lindgen
Posts: 1
Joined: 2014/07/17 01:08:21

Re: Samba

Post by dylan.lindgen » 2014/07/17 01:18:37

try the below maybe?

Code: Select all

firewall-cmd --permanent --add-service=samba

User avatar
vonskippy
Posts: 839
Joined: 2006/12/30 03:00:04
Location: Western Slope Colorado

Re: Samba

Post by vonskippy » 2014/07/17 02:11:24

Users?
Permissions?

Are we supposed to guess how you set both your Samba server and your window clients?
For the 2.5^15th time :: Better Details = Better Answers

sirmonkey
Posts: 11
Joined: 2014/07/19 03:09:34

Re: Samba

Post by sirmonkey » 2014/07/21 23:55:29

I'm haveing similar problems....
firewalld disabled
minimual centos 7 install

(tested on 3 machines)

ran
smbpasswd -a
and
chmod -R 777

windows can login and see shares but not access anything

Code: Select all

[root@boxA8 samba]# testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[homes]"
Processing section "[glusterfs]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
        netbios name = MYSERVER
        server string = Samba Server Version %v
        log file = /var/log/samba/log.%m
        max log size = 50
        idmap config * : backend = tdb

[homes]
        comment = Home Directories
        read only = No

[glusterfs]
        comment = testing 123
        path = /mnt/glusterfs
        read only = No
        guest ok = Yes


gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Samba

Post by gerald_clark » 2014/07/21 23:59:24

ran
smbpasswd -a
and
chmod -R 777

Neither of which will do anything.

sirmonkey
Posts: 11
Joined: 2014/07/19 03:09:34

Re: Samba

Post by sirmonkey » 2014/07/22 01:07:01

ubuntu dosen't like to samba share unless you 755 or 777 the directory.

smbpasswd -a <username>
got it so that i could atleast login and see the folder shares

I did just figure out that when my glusterfs isn't mounted i can see in the folder, and once it's mounted can't get in agian.

I can see and play in the folder when i ssh in tho.

whale
Posts: 5
Joined: 2014/07/22 06:12:26

Re: Samba

Post by whale » 2014/07/22 07:13:05

It's hard to figure out what is the root cause with fragment info.
Assume iptables off,selinux disabled,smbuser1 is a valid user in local system and samba user.
part of smb.conf

Code: Select all

[global]
security = user

[share]
  comment = test
  path = /mnt/share
  browsable = yes
  writable = yes
  writelist = smbuser1 #Account have write permission
And /mnt/share still needs the right permission for smbuser1.
Or you can just attach permission for one user,see below

Code: Select all

setfacl -m u:smbuser1:rwx /mnt/share
Then start smb and nmb service.
enjoy~

Post Reply

Return to “CentOS 7 - General Support”