Page 1 of 1

[Solved] "Server with GUI" environment loads libreoffice?

Posted: 2014/07/16 03:38:14
by Don
I have set up a PXEboot install server. Using this I am able to use kickstart to automatically load a system. This all works.

One thing has me puzzled though... why is the libreoffice group (office-suite) loaded when I configure a system to load only the "Server with GUI" environment group (graphical-server-environment)? I can't even deselect the office-suite explicitly by using the following in my kickstart file:

%packages
@^graphical-server-environment
-@office-suite
-libreoffice*
%end


I have been studying the repodata/*-c7-x86_64-comps.xml file. For all the groups of which office-suite is a member, office-suite is in the optionlist not the grouplist. So this should mean office-suite is an option right? Not mandatory or default. So why is it loaded?

Can anyone explain why the office-suite group is apparently loaded?

FWIW... there seems to be a bug in whatever generated this XML fileā€¦ sometimes it lists the first item twice (and with the wrong indention) like on lines 7811 and 7812 backup-client is listed twice.

Thanks in advance for any pointers to the answer!
--Don

Re: "Server with GUI" environment loads libreoffice?

Posted: 2014/07/18 20:12:09
by Don

Re: "Server with GUI" environment loads libreoffice?

Posted: 2014/07/22 02:35:22
by Don
On deeper investigation I found that the "graphical-server-environment" loads the group "gnome-desktop" which in turn loads the package "unoconv". "unoconv" has a dependency of much of libreoffice-*.

I tried loading a graphical-server-environment from the upstream server DVD. This resulted in libreoffice not being loaded. On digging into this, it appears the unoconv package is not on the DVD.

So there is a difference in the behaviour between CentOS-7.0-1406-x86_64-Everything.iso and the upstream server DVD when loading the "Server with GUI" environment. But I don't think the bug is on CentOS' side.

Re: [Solved] "Server with GUI" environment loads libreoffice

Posted: 2014/07/25 03:43:57
by ccbasubas
if you dont want to go into hassles of editing the xml file, just remove or uninstall it after I completely installed the server.

Code: Select all

sudo rpm -e --nodeps `rpm -qa | grep libreoffice`
or
rpm -e --nodeps `rpm -qa | grep libreoffice`

Re: [Solved] "Server with GUI" environment loads libreoffice

Posted: 2014/07/25 11:42:31
by TrevorH
Using rpm -e --nodeps is never a good idea since it leaves your yum/rpm db inconsistent and they will complain or undo your changes at a later date.