Unable to login at the console

General support questions
Post Reply
ebbers
Posts: 5
Joined: 2013/04/17 20:21:53
Location: UK

Unable to login at the console

Post by ebbers » 2021/06/08 15:18:31

Afternoon,

I've got a Centos v7.9 in vCentre that won't let me login at the console.
No such issue with ssh.

I've tried both myself (member of the wheel group, UID > 1000) and the root account.
In both instances I get the error Login incorrect.

Checked for any character substitutions by checking the pwd in the login field and it looks ok.
Nothing is being generated in either /var/log/secure or messages, I do get logging when using ssh.

console is present in the securetty file
nothing is configured in access.conf

pam_console.so doesn't appear to be specified in any of the pam config except in login as an optional under session
Tried changing my pwd to something more stringent in case it was pwquality but nope still can't get in.

Not sure why the denial is not being logged either.
Has anyone possibly seen this before and knows the resolution?

Thanks

pjsr2
Posts: 580
Joined: 2014/03/27 20:11:07

Re: Unable to login at the console

Post by pjsr2 » 2021/06/09 11:59:00

Are you using a non-en_US keyboard or is your VM defaulting to expect a non-en_US keyboard or a keyboard that differs from yours?

The vCentre web-console is really bad in handling input from non-en_US keyboards. The VMWare remote console is not as bad as the web console, but still far from perfect.

I've never had serious issues with the way ssh clients and servers handle non-en_US keyboards.

You could try to login with ssh as the normal user and change the password to something with only a-zA-Z0-9 and if it requires additional characters use period or comma. Leave out zZ and yY if german keybard layout could be in view. Similar restrictions if you have AZERTY type keyboard in the game. Any other key may have shifted positions between the various layouts.

User avatar
TrevorH
Forum Moderator
Posts: 30871
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Unable to login at the console

Post by TrevorH » 2021/06/09 16:17:41

Also make sure that the device it uses as its console is listed in securetty. For example, xen machines have a /dev/hvc0 that they use for console and that's not in securetty by default and has to be added.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

ebbers
Posts: 5
Joined: 2013/04/17 20:21:53
Location: UK

Re: Unable to login at the console

Post by ebbers » 2021/06/14 07:13:29

Thanks for the replies.

I did a bit more digging and it looks like someone has created a 2nd VM in vCentre with the same hostname and re-named the original VM name to something else (yet to be determined) :(

So it explains why I could logon with ssh no problem but the console was a no go. .

Post Reply

Return to “CentOS 7 - General Support”