no graphical login after update -/- Plymouth Boot Screen

General support questions
fatcharly@gmx.de
Posts: 12
Joined: 2018/08/22 16:20:16

no graphical login after update -/- Plymouth Boot Screen

Post by fatcharly@gmx.de » 2021/03/23 11:43:07

Hi,

I'm running a CentOS Linux release 7.9.2009 (Core) 3.10.0-1160.21.1.el7.x86_64 on a HP DL380 G7 as a KVM/QEMU hostsystem. Yesterday, after an update via yum I was not able to login via runlevel 5. Only when I hit the F-keys some time, the comes an messages:

[ * ] A start job is running for Wait for Plymouth Boot Screen to Quit (2min 41s / no limit)

The only possible way to get a login is to boot to runlevel 3.

What is the problem and how can I fix it ?

Any Suggestions are welcome

Kind regards and stay save

fatcharly

fatcharly@gmx.de
Posts: 12
Joined: 2018/08/22 16:20:16

Re: no graphical login after update -/- Plymouth Boot Screen

Post by fatcharly@gmx.de » 2021/03/30 14:46:56

I got some more logs about the x-server, maybe somebody has an idea what the problem is:

Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: X Error of failed request: BadValue (integer parameter out of range for operation)
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Major opcode of failed request: 140 (RANDR)
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Minor opcode of failed request: 44 ()
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Value in failed request: 0x149
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Serial number of failed request: 194
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Current serial number in output stream: 195
Mar 30 16:27:43 yoruko gnome-session-binary[2146]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 30 16:27:43 yoruko gnome-session: gnome-session-binary[2146]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: X Error of failed request: BadValue (integer parameter out of range for operation)
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Major opcode of failed request: 140 (RANDR)
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Minor opcode of failed request: 44 ()
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Value in failed request: 0x149
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Serial number of failed request: 194
Mar 30 16:27:43 yoruko org.gnome.Shell.desktop: Current serial number in output stream: 195
Mar 30 16:27:43 yoruko gnome-session-binary[2146]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 30 16:27:43 yoruko gnome-session: gnome-session-binary[2146]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 30 16:27:43 yoruko gnome-session: gnome-session-binary[2146]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
Mar 30 16:27:43 yoruko gnome-session-binary[2146]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
Mar 30 16:27:43 yoruko gnome-session-binary: Unrecoverable failure in required component org.gnome.Shell.desktop
Mar 30 16:27:43 yoruko journal: Cannot open display:
Mar 30 16:27:43 yoruko dbus[914]: [system] Activating via systemd: service name='org.freedesktop.locale1' unit='dbus-org.freedesktop.locale1.service'
Mar 30 16:27:43 yoruko systemd: Starting Locale Service...
Mar 30 16:27:43 yoruko dbus[914]: [system] Activating via systemd: service name='org.freedesktop.ColorManager' unit='colord.service'
Mar 30 16:27:43 yoruko spice-vdagent[2340]: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
Mar 30 16:27:43 yoruko gnome-session-binary[2146]: WARNING: App 'spice-vdagent.desktop' exited with code 1
Mar 30 16:27:43 yoruko gnome-session: gnome-session-binary[2146]: WARNING: App 'spice-vdagent.desktop' exited with code 1
Mar 30 16:27:43 yoruko gnome-session-binary: Entering running state
Mar 30 16:27:43 yoruko systemd: Starting Manage, Install and Generate Color Profiles...
Mar 30 16:27:43 yoruko dbus[914]: [system] Successfully activated service 'org.freedesktop.locale1'
Mar 30 16:27:43 yoruko systemd: Started Locale Service.
Mar 30 16:27:43 yoruko rtkit-daemon[866]: Successfully made thread 2351 of process 2351 (/usr/bin/pulseaudio) owned by '42' high priority at nice level -11.
Mar 30 16:27:43 yoruko dbus[914]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service'
Mar 30 16:27:43 yoruko journal: failed to get edid data: EDID length is too small
Mar 30 16:27:43 yoruko systemd: Starting Hostname Service...
Mar 30 16:27:43 yoruko dbus[914]: [system] Successfully activated service 'org.freedesktop.ColorManager'
Mar 30 16:27:43 yoruko systemd: Started Manage, Install and Generate Color Profiles.
Mar 30 16:27:43 yoruko dbus[914]: [system] Successfully activated service 'org.freedesktop.hostname1'


Any suggestions are welcome

Kind regards

fatcharly

phil.e
Posts: 81
Joined: 2018/02/13 20:28:14

Re: no graphical login after update -/- Plymouth Boot Screen

Post by phil.e » 2021/04/06 19:21:18

On some systems I work on, I typically have to reinstall a video driver after an update that includes a new kernel - X windows won't start until I reinstall the driver. Are you using an NVIDIA video card, by any chance? (the same thing probably applies to other video cards, but I'm only working with NVIDIA cards where I am now)

fatcharly@gmx.de
Posts: 12
Joined: 2018/08/22 16:20:16

Re: no graphical login after update -/- Plymouth Boot Screen

Post by fatcharly@gmx.de » 2021/04/07 13:12:37

Hi Phil,

I already used a script from the Internet to check for nvidia hardware. The check was negative.
How do I reinstall the gfx drivers ?

Best regards

fatcharly

fatcharly@gmx.de
Posts: 12
Joined: 2018/08/22 16:20:16

org.gnome.Shell.desktop: X Error of failed request

Post by fatcharly@gmx.de » 2021/04/09 14:53:31

I'm running a CentOS Linux release 7.9.2009 (Core) 3.10.0-1160.21.1.el7.x86_64 on a HP DL380 G7 as a KVM/QEMU hostsystem.
After an update I'm no longer able to log in via X-Server. In the /var/log/messages I found this:

Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: X Error of failed request: BadValue (integer parameter out of range for operation)
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Major opcode of failed request: 140 (RANDR)
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Minor opcode of failed request: 44 ()
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Value in failed request: 0x148
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Serial number of failed request: 194
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Current serial number in output stream: 195
Apr 9 15:17:42 yoruko gnome-session: gnome-session-binary[2149]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Apr 9 15:17:42 yoruko gnome-session-binary[2149]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: X Error of failed request: BadValue (integer parameter out of range for operation)
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Major opcode of failed request: 140 (RANDR)
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Minor opcode of failed request: 44 ()
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Value in failed request: 0x148
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Serial number of failed request: 194
Apr 9 15:17:42 yoruko org.gnome.Shell.desktop: Current serial number in output stream: 195
Apr 9 15:17:42 yoruko gnome-session-binary[2149]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Apr 9 15:17:42 yoruko gnome-session: gnome-session-binary[2149]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Apr 9 15:17:42 yoruko gnome-session: gnome-session-binary[2149]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
Apr 9 15:17:42 yoruko gnome-session-binary[2149]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
Apr 9 15:17:42 yoruko gnome-session-binary: Unrecoverable failure in required component org.gnome.Shell.desktop
Apr 9 15:17:42 yoruko journal: Cannot open display:
Apr 9 15:17:42 yoruko dbus[894]: [system] Activating via systemd: service name='org.freedesktop.locale1' unit='dbus-org.freedesktop.locale1.service'
Apr 9 15:17:42 yoruko systemd: Starting Locale Service...
Apr 9 15:17:42 yoruko dbus[894]: [system] Activating via systemd: service name='org.freedesktop.ColorManager' unit='colord.service'
Apr 9 15:17:42 yoruko systemd: Starting Manage, Install and Generate Color Profiles...
Apr 9 15:17:42 yoruko spice-vdagent[2343]: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
Apr 9 15:17:42 yoruko gnome-session: gnome-session-binary[2149]: WARNING: App 'spice-vdagent.desktop' exited with code 1
Apr 9 15:17:42 yoruko gnome-session-binary[2149]: WARNING: App 'spice-vdagent.desktop' exited with code 1
Apr 9 15:17:42 yoruko gnome-session-binary: Entering running state
Apr 9 15:17:42 yoruko dbus[894]: [system] Successfully activated service 'org.freedesktop.locale1'
Apr 9 15:17:42 yoruko systemd: Started Locale Service.
Apr 9 15:17:42 yoruko rtkit-daemon[866]: Successfully made thread 2352 of process 2352 (/usr/bin/pulseaudio) owned by '42' high priority at nice level -11.
Apr 9 15:17:42 yoruko dbus[894]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service'



What can I do to solve the problem ?

Any suggestions are welcome

Stay safe and healthy

fatcharly

User avatar
TrevorH
Forum Moderator
Posts: 30670
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: no graphical login after update -/- Plymouth Boot Screen

Post by TrevorH » 2021/04/09 15:25:53

I have merged your duplicate post into the original thread, please don't multipost.

Interrupt your boot at the grub menu and edit the current kernel entry and remove the words 'rhgb' and 'quiet' from the kernel command line then press Ctrl-X to continue. That will enable verbose messages during boot so you can see any errors that come out.

If you have no GUI and system appears to hang, press Ctrl-Alt-F2 to switch to terminal 2 where you can find a command line login prompt. Login as root and inspect the log files on your system. For GUI related problems it's most likely that you will find clues in /var/log/Xorg.0.log and maybe in /var/log/messages or /var/log/secure.

What is the output from lspci -nn | grep -i vga ?
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

fatcharly@gmx.de
Posts: 12
Joined: 2018/08/22 16:20:16

Re: no graphical login after update -/- Plymouth Boot Screen

Post by fatcharly@gmx.de » 2021/04/12 13:35:55

HI Trevor,

sorry for the multipost.

I allready removed the 'rhgb' and 'quiet' settings from the kernel command line.

I can't find anything execpt the lines from messages postet before and this little line from the Xorg.0.log:

[ 27.995] (II) Initializing extension GLX
[ 28.000] (EE) AIGLX error: dlopen of /usr/lib64/dri/radeon_dri.so failed (/usr/lib64/dri/radeon_dri.so: cannot open shared object file: No such file or directory)
[ 28.000] (EE) AIGLX error: unable to load driver radeon
[ 28.498] (II) IGLX: Loaded and initialized swrast
[ 28.498] (II) GLX: Initialized DRISWRAST GL provider for screen 0

and this is my output of lspci -nn | grep -i vga:
01:03.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] ES1000 [1002:515e] (rev 02)

I only find problems from 2014/2015 which seems to be related and already have been corrected.

I'm really stuck, what can I do to resolve this problem or maybe shall I install a different Desktop-System as gnome ? This is a totally normal server out of the box and was running with no problems for 5 years, what has happend ? And there is a sister-system which is having the same problem.

Any suggestions are welcome

Best regards and stay safe

fatcharly

User avatar
TrevorH
Forum Moderator
Posts: 30670
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: no graphical login after update -/- Plymouth Boot Screen

Post by TrevorH » 2021/04/12 15:29:25

Well that is an ancient video card so solutions from 2014/15 might still be applicable.

Switching to a different desktop won't make any difference, that's the video driver used by all of them that will not load.

Do you have an /etc/X11/xorg.conf? If so, try renaming it to something different, not a file ending in .conf at all. The default for most video cards just works using autodetection so no xorg.conf file is usually required.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

fatcharly@gmx.de
Posts: 12
Joined: 2018/08/22 16:20:16

Re: no graphical login after update -/- Plymouth Boot Screen

Post by fatcharly@gmx.de » 2021/04/13 09:57:35

Sorry but no /etc/X11/xorg.conf, only :

/etc/abrt/plugins/xorg.conf
/usr/share/abrt/conf.d/plugins/xorg.conf

Hmm so how do I install a different driver or get the default running again ?

Would it help to try this :
yum remove xorg-x11-drv-ati ?, nope just tried it, no change, reinstalled it.

fatcharly@gmx.de
Posts: 12
Joined: 2018/08/22 16:20:16

Solved Re: no graphical login after update -/- Plymouth Boot Screen

Post by fatcharly@gmx.de » 2021/04/13 13:00:58

Solved !

here is what I did:

removed the not working ati-driver :
yum remove xorg-x11-drv-ati

installed/checked if vesa-driver is installed:
yum install xorg-x11-drv-vesa

and then edit the grub2 kernel line in /etc/default/grub:
nomodeset xdriver=vesa

so mine looked like that right now:
GRUB_CMDLINE_LINUX="crashkernel=auto nomodeset xdriver=vesa"

then rebuild the grub with:
grub2-mkconfig -o /boot/grub2/grub.cfg

and after a reboot the login-screen is back.

Post Reply

Return to “CentOS 7 - General Support”