centos 5.2 pxe does not load marvel yukon onboard lan driver

Having issues using the CentOS WebSite? Then describe your problem(s) here. Please include details of your platform (Linux, Mac, Windows) and browser -- not forgetting the versions of each.
Post Reply
Posts: 1
Joined: 2010/06/04 06:45:48

centos 5.2 pxe does not load marvel yukon onboard lan driver

Post by crvdmerwe » 2010/06/04 07:25:42

Hi all

I have spent a couple of days researching this issue. I HAVE to network boot and install several servers. OS HAS to CentOS 5.2 (by the way problem is solved in CentOS 5.5).

I have 5 NIC's on the ASUS P5E board (two onboard, and 3 add on's). The bios only allows you to pxe boot from one onboard port (marvell yukon...). When pxe boot starts, on marrvell nic, initrd loads and then loses the onboard lan. The three add on nic's are detected and at this point I have to switch to one of these to get the kickstart and finish installation. This is fine during development, but it cannot be tollerated in production.

I cannot add the driver/kmod afterwards - not an option.

I have tried adding the sk98lin.ko to my initrd.img, but this still does not help - I see that there are some forum posts that suggest that this driver was excluded - not sure what the deal is...?

Is there a way to build an initrd.img from an installed system (with kernel module installed and loaded and functional) and then use that initrd.img? If so how?

Thanks a million for your time and trouble!

Post Reply

Return to “Website Problems”