Suddenly ... device or resource busy

If it doesn't fit in another category, ask it here.
Post Reply
Posts: 1
Joined: 2011/05/14 21:04:01

Suddenly ... device or resource busy

Post by IADventurer01 » 2011/05/14 21:15:44

I installed centOS 4 on some old home hardware and setup a hardware RAID of NTFS drives for use as a home data server. The OS is installed on a separate drive. Everything worked great for months until a fairly recent barrage of updates apparently changed [i]something[/i] and in the startup processes it now gives me a device or resource busy error.

I get the same error when attempting to mount it manually as well. The device is not currently mounted, or at least that's what umount claims. I've removed the mount information from fstab and all other references to the mount point or device that I can remember configuring, but the device still claims to be busy. fuser & lsof aren't revealing much of anything to me either, though I could be using these tools incorrectly, as I'm not experienced with them.

Any help with this issue would be much appreciated, thanks!

Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Suddenly ... device or resource busy

Post by pschaff » 2011/05/14 21:57:36

Welcome to the CentOS fora. Reading [url=]FAQ & Readme First[/url] is recommended for new users.

It is impossible to give specific help without more details, such as the exact error message in context, and information about the disk partitions and filesystems. Please try again after doing the recommended reading.

Post Reply

Return to “CentOS 4 - Miscellaneous Questions”